Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: не могу установить hp-plugin для сканера M2727nf  (Прочитано 8214 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vovchok

  • Автор темы
  • Участник
  • *
  • Сообщений: 119
    • Просмотр профиля
Проблема возникла после установки с сайта HP новой версии hplip 3.19.1 и последующего ее удаления, т.к.с ней не печатает принтер.
устанавливаю родную версию hplip 3.16.11 для ubuntu zesty, принтер с ней работает,пытаюсь установить hp-plugin для сканера и ставится не та версия (соответственно и не сканирует), принудительно скачал нужную версию и запустил установку, но ругается на несовместимость с правильной (3.16.11) версией hplip (почему-то ей мерещится другая, удаленная перед этим версия 3.19.1, хотя ее нет).Как вправить мозг этому плагину?
user@comp4:~/Загрузки$ sudo /home/user/Загрузки/hplip-3.16.11-plugin.run
Verifying archive integrity... All good.
Uncompressing HPLIP 3.16.11 Plugin Self Extracting Archive................................................
Error importing HPLIP modules.  Is HPLIP installed?
user@comp4:~/Загрузки$ sudo apt-get install hplip
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
  hplip-data libhpmud0 libsane-hpaio printer-driver-hpcups printer-driver-postscript-hp
Предлагаемые пакеты:
  hplip-doc hplip-gui python3-notify2
НОВЫЕ пакеты, которые будут установлены:
  hplip hplip-data libhpmud0 libsane-hpaio printer-driver-hpcups printer-driver-postscript-hp
обновлено 0, установлено 6 новых пакетов, для удаления отмечено 0 пакетов, и 96 пакетов не обновлено.
Необходимо скачать 7.710 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 15,3 MB.
Хотите продолжить? [Д/н]
Пол:1 http://old-releases.ubuntu.com/ubuntu zesty/main amd64 hplip-data all 3.16.11+repack0-2 [6.392 kB]
Пол:2 http://old-releases.ubuntu.com/ubuntu zesty/main amd64 libhpmud0 amd64 3.16.11+repack0-2 [106 kB]
Пол:3 http://old-releases.ubuntu.com/ubuntu zesty/main amd64 libsane-hpaio amd64 3.16.11+repack0-2 [115 kB]
Пол:4 http://old-releases.ubuntu.com/ubuntu zesty/main amd64 printer-driver-hpcups amd64 3.16.11+repack0-2 [248 kB]
Пол:5 http://old-releases.ubuntu.com/ubuntu zesty/main amd64 hplip amd64 3.16.11+repack0-2 [65,7 kB]                                                                                           
Пол:6 http://old-releases.ubuntu.com/ubuntu zesty/main amd64 printer-driver-postscript-hp all 3.16.11+repack0-2 [783 kB]                                                                       
Получено 7.710 kБ за 6с (1.138 kБ/c)                                                                                                                                                           
Выбор ранее не выбранного пакета hplip-data.
(Чтение базы данных … на данный момент установлен 209461 файл и каталог.)
Подготовка к распаковке …/0-hplip-data_3.16.11+repack0-2_all.deb …
Распаковывается hplip-data (3.16.11+repack0-2) …
Выбор ранее не выбранного пакета libhpmud0:amd64.
Подготовка к распаковке …/1-libhpmud0_3.16.11+repack0-2_amd64.deb …
Распаковывается libhpmud0:amd64 (3.16.11+repack0-2) …
Выбор ранее не выбранного пакета libsane-hpaio:amd64.
Подготовка к распаковке …/2-libsane-hpaio_3.16.11+repack0-2_amd64.deb …
Распаковывается libsane-hpaio:amd64 (3.16.11+repack0-2) …
Выбор ранее не выбранного пакета printer-driver-hpcups.
Подготовка к распаковке …/3-printer-driver-hpcups_3.16.11+repack0-2_amd64.deb …
Распаковывается printer-driver-hpcups (3.16.11+repack0-2) …
Выбор ранее не выбранного пакета hplip.
Подготовка к распаковке …/4-hplip_3.16.11+repack0-2_amd64.deb …
Распаковывается hplip (3.16.11+repack0-2) …
Выбор ранее не выбранного пакета printer-driver-postscript-hp.
Подготовка к распаковке …/5-printer-driver-postscript-hp_3.16.11+repack0-2_all.deb …
Распаковывается printer-driver-postscript-hp (3.16.11+repack0-2) …
Обрабатываются триггеры для cups (2.2.2-1ubuntu1) …
Настраивается пакет hplip-data (3.16.11+repack0-2) …
Обрабатываются триггеры для libc-bin (2.24-9ubuntu2.2) …
Обрабатываются триггеры для man-db (2.7.6.1-2) …
Обрабатываются триггеры для dbus (1.10.10-1ubuntu2) …
Настраивается пакет libhpmud0:amd64 (3.16.11+repack0-2) …
Настраивается пакет libsane-hpaio:amd64 (3.16.11+repack0-2) …
Настраивается пакет printer-driver-hpcups (3.16.11+repack0-2) …
Настраивается пакет hplip (3.16.11+repack0-2) …
Creating/updating hplip user account...
dpkg-statoverride: предупреждение: указан --update, но /var/run/hplip не существует
Настраивается пакет printer-driver-postscript-hp (3.16.11+repack0-2) …
Обрабатываются триггеры для libc-bin (2.24-9ubuntu2.2) …
Обрабатываются триггеры для dbus (1.10.10-1ubuntu2) …
user@comp4:~/Загрузки$ sudo /home/user/Загрузки/hplip-3.16.11-plugin.run
Verifying archive integrity...
 All good.
Uncompressing HPLIP 3.16.11 Plugin Self Extracting Archive................................................

HP Linux Imaging and Printing System (ver. 3.19.1)
Plugin Installer ver. 3.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Plug-in version mismatch:
error:   Plug-in version: 3.16.11
error:   Installed HPLIP version: 3.19.1
error:   Installed HPLIP version and plug-in version must match.
user@comp4:~/Загрузки$

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 4559
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #1 : 12 Февраль 2019, 20:08:45 »
sudo /home/user/Загрузки/hplip-3.16.11-plugin.run --uninstallПопробуйуте.

Оффлайн vovchok

  • Автор темы
  • Участник
  • *
  • Сообщений: 119
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #2 : 18 Февраль 2019, 10:18:24 »
не конает
user@comp4:~$ /home/user/Загрузки/hplip-3.16.11-plugin.run  --uninstall
Unrecognized flag : --uninstall
Makeself version 2.1.5
 1) Getting help or info about /home/user/Загрузки/hplip-3.16.11-plugin.run :
  /home/user/Загрузки/hplip-3.16.11-plugin.run --help   Print this message
  /home/user/Загрузки/hplip-3.16.11-plugin.run --info   Print embedded info : title, default target directory, embedded script ...
  /home/user/Загрузки/hplip-3.16.11-plugin.run --lsm    Print embedded lsm entry (or no LSM)
  /home/user/Загрузки/hplip-3.16.11-plugin.run --list   Print the list of files in the archive
  /home/user/Загрузки/hplip-3.16.11-plugin.run --check  Checks integrity of the archive
 
 2) Running /home/user/Загрузки/hplip-3.16.11-plugin.run :
  /home/user/Загрузки/hplip-3.16.11-plugin.run [options] [--] [additional arguments to embedded script]
  with following options (in that order)
  --confirm             Ask before running embedded script
  --noexec              Do not run embedded script
  --keep                Do not erase target directory after running
the embedded script
  --nox11               Do not spawn an xterm
  --nochown             Do not give the extracted files to the current user
  --target NewDirectory Extract in NewDirectory
  --tar arg1 [arg2 ...] Access the contents of the archive through the tar command
  --                    Following arguments will be passed to the embedded script
user@comp4:~$
Проблема заключается в том, что плагин при установке неправильно определяет версию hplip - он где-то находит ту версию, которую я давно снес, а не сейчас установленную в системе. Вопрос в том, где остаются хвосты после удаления новой версии.

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1241
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #3 : 18 Февраль 2019, 10:40:29 »
vovchok, плагин для сканера - это отдельный проприетарный компонент для hplip.
error:   Installed HPLIP version: 3.19.1
Вот как ты его установил, так он и остался. Так и будет, пока ты его не удалишь. Ты хоть 100500 раз переустанавливай сам пакет hplip. Это понятно?
Как вправить мозг этому плагину?
Себе сначала мозги вправьлю, а потом уже плагину другим.
FIXED

Будьте добрее и снисходительней.
Не хотите отвечать- просто пройдите мимо.
С уважением, Morisson.
« Последнее редактирование: 22 Февраль 2019, 08:09:30 от Morisson »

Оффлайн vovchok

  • Автор темы
  • Участник
  • *
  • Сообщений: 119
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #4 : 22 Февраль 2019, 08:02:56 »
Так и будет, пока ты его не удалишь
Я и спрашиваю - как удалить плагин?
В его опциях нет удаления:
       Specify the path to the plugin file:
              -p <path> or --path=<path> or --plugin=<path>

       Set the logging level:
              -l<level> or --logging=<level> <level>: none, info*, error, warn, debug (*default)

       Run in debug mode:
              -g (same as option: -ldebug)

       This help information:
              -h or --help

Себе сначала мозги вправь, а потом уже плагину.
Спасибо за грубость...

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1389
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #5 : 22 Февраль 2019, 09:57:51 »
Error importing HPLIP modules.  Is HPLIP installed?

что ответили?

sudo /home/user/Загрузки/hplip-3.16.11-plugin.run

не надо sudo

запустите hplip 3.19.1 и внимательно читайте вопросы установщика в терминале, в какой-то момент будет задан вопрос: -установить, -удалить или -выход. Выберите удалить.

Оффлайн vovchok

  • Автор темы
  • Участник
  • *
  • Сообщений: 119
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #6 : 22 Февраль 2019, 12:35:09 »
запустите hplip 3.19.1 и внимательно читайте вопросы установщика в терминале, в какой-то момент будет задан вопрос: -установить, -удалить или -выход
Нет такого к сожалению, предлагает лишь "d=download*, p=specify path, q=quit" и подтверждение согласия с установкой приняв лицензионное соглашение:
user@comp4:~/$ hp-plugin -i

HP Linux Imaging and Printing System (ver. 3.19.1)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.19.1)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


-----------------------------------------
| PLUG-IN INSTALLATION FOR HPLIP 3.19.1 |
-----------------------------------------

  Option      Description                                       
  ----------  --------------------------------------------------
  d           Download plug-in from HP (recommended)           
  p           Specify a path to the plug-in (advanced)         
  q           Quit hp-plugin (skip installation)               

Enter option (d=download*, p=specify path, q=quit) ? d

-------------------
| DOWNLOAD PLUGIN |
-------------------

Checking for network connection...
Downloading plug-in from:
Downloading plug-in: [\                                                                                                                                                   ] 0% Receiving digital keys: /usr/bin/gpg --homedir /home/user/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9
 
error: Unable to recieve key from keyserver
Do you still want to install the plug-in? (y=yes, n=no*, q=quit) ? y

----------------------
| INSTALLING PLUG-IN |
----------------------

Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.1 Plugin Self Extracting Archive..............................................................

HP Linux Imaging and Printing System (ver. 3.19.1)
Plugin Installer ver. 3.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.19.1
Installed HPLIP version: 3.19.1
Number of files to install: 64

You must agree to the license terms before installing the plug-in:

---ТУТ БЫЛО ДЛИННОЕ ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ---

Do you accept the license terms for the plug-in (y=yes*, n=no, q=quit) ? y
Please enter the sudoer (user)'s password:
Plugin installation failed
error: Plugin installation failed

Done.

Пользователь добавил сообщение 22 Февраль 2019, 12:43:52:
не надо sudo
Пробовал и с sudo и без (тогда оно запросит пароль в процессе установки).
« Последнее редактирование: 22 Февраль 2019, 12:43:52 от vovchok »

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1389
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #7 : 22 Февраль 2019, 13:38:36 »
Скачать соответствующий hplip, запустить установщик:
sh ~/путь к установщику/hplip-3.19.1.run
далее читайте сообщения в терминале...

и покажите
dpkg -l | grep hplip*

zse

  • Гость
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #8 : 22 Февраль 2019, 14:15:59 »
             Я хоть и не люблю hp, но приходится, обычно меньше проблем при установке драйверов когда устанавливаешь из консоли TTY, но читать там нужно что они пишут „с толком, чувством, расстановкой😈“…
             2019 Feb 22; 06:17 AM

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 4559
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #9 : 22 Февраль 2019, 15:56:17 »
Скачать соответствующий hplip, запустить установщик:
вот так косяки и случаются. а ведь его можно тупо при установке принтера качнуть- там спрашивают.
вот наставят run-ов, а потом выпиливай из системы их, потому как встали они в обход менеджера пакетов.)

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1389
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #10 : 22 Февраль 2019, 17:08:10 »
вот наставят run-ов

эт точно, HP ничего не понимают в Убунте

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 4559
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #11 : 22 Февраль 2019, 18:13:31 »
Я не понял это камень в мой огород или нет  :P
Но там первым делом пишут, что в первую очередь эти пакеты следует проверить среди установленных. Если его нет- установить средствами hp-setup.
Если очень уж хочется сильно новый hplip- тогда можно поставить run.
Даже в арче этот плагин опакечен, правда он в АУР. А так из той же гуевины ставится.
run скриптом пользовался однажды, когда моего принтера еще в версии дистрибутива не было.
Так вот, у нвидиа, когда ставишь драйвер с сайта- среди прочих скриптов (не помню точно папку системную) есть uninstall-скрипт.
А ведь его тупо может и не быть. И в этом случае, т.к. менеджер пакетов не будет знать об этом пакете, выковыривать его придется руками.
В этом случае я не проверял, как там все устроено.
Но с другими пакетами подобный опыт был.

Оффлайн vovchok

  • Автор темы
  • Участник
  • *
  • Сообщений: 119
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #12 : 26 Февраль 2019, 23:51:22 »
sh ~/путь к установщику/hplip-3.19.1.run

далее читайте сообщения в терминале...
Да ставил я его - запросы в терминале не отличаются от вышеприведенных мной для hplip-3.16.11.run
разница только в появлении голубого hp значка в системном трее (в старой версии значка нет). И удаляется он через "sudo apt remove hplip", только похоже, что не полностью удаляется, раз плагин его где-то еще находит.

HP ничего не понимают в Убунте
Они похоже и в дровах к своим принтерам косячат - на версии hplip 3.16.11 нормально работает печать/сканирование на моделях p2015 и m2727, но не работает на m1536 - для этого мфу и нужна была версия 3.19.1 - с ней все заработало на m1536, но перестали печатать p2015 и m2727! Поэтому мне пришлось из-за кривых дров отказаться от использования m1536, но откатить плагин сканера теперь проблема...

Пользователь добавил сообщение 26 Февраль 2019, 23:58:19:
dpkg -l | grep hplip*
ii  hplip                                       3.16.11+repack0-2                             amd64        HP Linux Printing and Imaging System (HPLIP)
ii  hplip-data                                  3.16.11+repack0-2                             all          HP Linux Printing and Imaging - data files
« Последнее редактирование: 26 Февраль 2019, 23:58:19 от vovchok »

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 4559
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #13 : 27 Февраль 2019, 09:19:31 »
зачем вы его run ставите??
При добавлении принтера если нужно будет- попросит. Введете пароль и все должно заработать.
И перестаньте без необходимости тащить мимо apt всякую бяку.

Оффлайн vovchok

  • Автор темы
  • Участник
  • *
  • Сообщений: 119
    • Просмотр профиля
Re: не могу установить hp-plugin для сканера M2727nf
« Ответ #14 : 01 Март 2019, 08:50:01 »
зачем вы его run ставите??
При добавлении принтера если нужно будет- попросит.
При добавлении разумеется ничего не просит - просто потом не работает сканер в новом МФУ. На сайте НР выставлен только run для решения этой проблемы и он ее решает, но создает другую, которая своим приоритетом для меня важнее первой (напрочь перестают работать имеющиеся старые принтеры) - поэтому нужно откатиться, и тут начинаются танцы с бубном...

Пользователь добавил сообщение 01 Март 2019, 08:54:15:
Задал этот вопрос поддержке HP - они отморозились, что в линукс не шарят и перевели стрелки на ланчпад, где тоже никакой реакции не наблюдается :-(
« Последнее редактирование: 01 Март 2019, 08:54:15 от vovchok »

 

Страница сгенерирована за 0.114 секунд. Запросов: 24.