Форум русскоязычного сообщества Ubuntu


Автор Тема: Xubuntu 16.04 перестал работать 3G модем  (Прочитано 432 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ksenz83

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Здравствуйте. На компьютере с xubuntu 16.04 время от времени пользовался модемом мегафон E173. Через NM и Wammu. Сейчас подключаю, оба его не видят. Как я понял перестало создаваться устройство ttyUSB0. Вот грешу на обновление. Так как пользовался не очень часто не могу сказать как давно... lsusb модем видит Bus 001 Device 006: ID 12d1:1446 Huawei Technologies Co., Ltd. Broadband stick (modem on) Устройства ttyUSB0 в системе нет.
Подскажите пожалуйста как исправить.

Оффлайн mmfaddeev

  • Активист
  • *
  • Сообщений: 591
    • Просмотр профиля
Re: Xubuntu 16.04 перестал работать 3G модем
« Ответ #1 : 11 Март 2019, 16:06:14 »
Аналогичная проблема с модемом E1750 от Megafon. Заметил недели две назад. Виновато, по-видимому, обновление udev (до версии 229-4ubuntu21.16). На 14.04 и 18.04 все работает.

На 16.04 с udev версии 21.15 (не обновлявшейся до 21.16) модем также определяется корректно (как 12d1:1001) и работает.

А вот при откате версии udev с 21.16 до 21.15 или 21.10 модем продолжает определяться как CD-rom (12d1:1446).

Рецепт, приведенный здесь помогает, но только на один раз, то есть при переподключении модем снова определяется как CD-rom.

« Последнее редактирование: 11 Март 2019, 18:57:01 от mmfaddeev »

Оффлайн Ksenz83

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Xubuntu 16.04 перестал работать 3G модем
« Ответ #2 : 11 Март 2019, 16:58:38 »
Да ядро 4.4.0-142, но я помнится при настройке в самом модеме at коммандой отключил cd-rom. Вот мне и интересно что сломалось при обновлении, что такое выдает...

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Xubuntu 16.04 перестал работать 3G модем
« Ответ #3 : 11 Март 2019, 17:21:07 »
Ksenz83, прошу показать выводы команд при подключенном в USB-порт модеме (или сообщить что ничего не выводится, если это так):lsusb
mmcli -L
lsusb -v -d `lsusb -d 12d1: | awk '{print $6}'` | grep bNumConfigurations
dmesg | egrep -i "(error|fail|warning)"
И сразу после подключения модема вывод dmesg | tail -n 20
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Ksenz83

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Xubuntu 16.04 перестал работать 3G модем
« Ответ #4 : 19 Март 2019, 08:48:14 »
Ksenz83, прошу показать выводы команд при подключенном в USB-порт модеме (или сообщить что ничего не выводится, если это так):

dmesg
[1001986.767527] usb 1-1.6: new high-speed USB device number 10 using ehci-pci
[1001986.862090] usb 1-1.6: New USB device found, idVendor=12d1, idProduct=1446
[1001986.862098] usb 1-1.6: New USB device strings: Mfr=3, Product=2, SerialNumber=0
[1001986.862103] usb 1-1.6: Product: HUAWEI Mobile
[1001986.862107] usb 1-1.6: Manufacturer: HUAWEI Technology
[1001986.864135] usb-storage 1-1.6:1.0: USB Mass Storage device detected
[1001986.864564] scsi host16: usb-storage 1-1.6:1.0
[1001986.864811] usb-storage 1-1.6:1.1: USB Mass Storage device detected
[1001986.865047] scsi host17: usb-storage 1-1.6:1.1
[1001987.865873] scsi 16:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[1001987.865931] scsi 17:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[1001987.866624] sd 17:0:0:0: Attached scsi generic sg7 type 0
[1001987.871913] sr 16:0:0:0: [sr1] scsi-1 drive
[1001987.872531] sr 16:0:0:0: Attached scsi CD-ROM sr1
[1001987.872686] sr 16:0:0:0: Attached scsi generic sg8 type 5
[1001987.876281] sd 17:0:0:0: [sdg] Attached SCSI removable disk
lsusb
Bus 002 Device 004: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 002 Device 003: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 010: ID 12d1:1446 Huawei Technologies Co., Ltd. Broadband stick (modem on)
Bus 001 Device 003: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
mmcli -L

No modems were found

lsusb -v -d `lsusb -d 12d1: | awk '{print $6}'` | grep bNumConfigurations
Couldn't open device, some information will be missing
  bNumConfigurations   
sudo lsusb -v -d `lsusb -d 12d1: | awk '{print $6}'` | grep bNumConfigurations
  bNumConfigurations      1
  bNumConfigurations      1
« Последнее редактирование: 19 Март 2019, 08:51:10 от Ksenz83 »

 

Страница сгенерирована за 0.132 секунд. Запросов: 24.