Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Проблемы с установкой deepin-screenshot  (Прочитано 2083 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dr.Vadz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • SEOhub
Всем привет. Как по мне Deepin-Scrot одино из самых удобных приложений для скриншотов, но я никак не могу его установить/ Ранее, как-то получилось раз установить, но была замена hdd на ssd, переустановка системы....

Делаю все по http://ubuntuguide.net/deepin-scrot-lightweight-screenshot-capture-program-in-ubuntu.

Система Ubuntu 16.04 LTS

Может кто подсказать, как его установить?
« Последнее редактирование: 02 Май 2019, 08:59:13 от Azure »

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #1 : 02 Май 2019, 08:58:48 »
я никак не могу его установить/ Ранее, как-то получилось раз установить, но была замена hdd на ssd, переустановка системы....
Делаю все по
Информации абсолютно недостаточно. Там всего две команды: выполните в терминале и покажите результат выполнения.
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн dr.Vadz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • SEOhub
Re: Проблемы с установкой deepin-screenshot
« Ответ #2 : 02 Май 2019, 10:07:29 »
Спасибо за ответ. Вот скрин https://prnt.sc/njdkd4.
При попытке установить .deb через менеджер приложений, после клика по кнопке Install ничего не происходит.Ну и команда с установкой python-xlib тоже на скрине

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #3 : 02 Май 2019, 11:15:25 »
При попытке установить .deb через менеджер приложений
Попробуйте установить в терминале:sudo dpkg -i <путь>/название.debP.S. Вывод терминала просто выделяют и копируют (не надо скриншотов)
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн dr.Vadz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • SEOhub
Re: Проблемы с установкой deepin-screenshot
« Ответ #4 : 02 Май 2019, 11:47:41 »
ошибка

Selecting previously unselected package deepin-screenshot.
(Reading database ... 214905 files and directories currently installed.)
Preparing to unpack .../Desktop/deepin-screenshot.deb ...
Unpacking deepin-screenshot (4.0.11-1) ...
dpkg: dependency problems prevent configuration of deepin-screenshot:
 deepin-screenshot depends on libdtkcore2 (>= 0.3.3+git20170731); however:
  Package libdtkcore2 is not installed.
 deepin-screenshot depends on libdtkwidget2 (>= 2.0.7); however:
  Package libdtkwidget2 is not installed.
 deepin-screenshot depends on libdtkwm2 (>= 0.1.0~20170815); however:
  Package libdtkwm2 is not installed.
 deepin-screenshot depends on libqt5core5a (>= 5.9.0~beta); however:
  Version of libqt5core5a:amd64 on system is 5.5.1+dfsg-16ubuntu7.5.
 deepin-screenshot depends on libqt5gui5 (>= 5.8.0); however:
  Version of libqt5gui5:amd64 on system is 5.5.1+dfsg-16ubuntu7.5.

dpkg: error processing package deepin-screenshot (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1.1) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 deepin-screenshot


Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #5 : 02 Май 2019, 15:47:17 »
deepin-screenshot depends on libdtkcore2 (>= 0.3.3+git20170731); however:
  Package libdtkcore2 is not installed.
 deepin-screenshot depends on libdtkwidget2 (>= 2.0.7); however:
  Package libdtkwidget2 is not installed.
 deepin-screenshot depends on libdtkwm2 (>= 0.1.0~20170815); however:
  Package libdtkwm2 is not installed.
 deepin-screenshot depends on libqt5core5a (>= 5.9.0~beta); however:
  Version of libqt5core5a:amd64 on system is 5.5.1+dfsg-16ubuntu7.5.
 deepin-screenshot depends on libqt5gui5 (>= 5.8.0); however:
  Version of libqt5gui5:amd64 on system is 5.5.1+dfsg-16ubuntu7.5.
Придется устанавливать все требуемые пакеты (и то не факт что заработает - версии намного ниже требуемых: что в этой программе такого чего нет в других?)
И, кстати, где Вы взяли 4.0.11-ю версию? Почему не указанную в "инструкции" https://mirror.yandex.ru/mirrors/deepin/packages/pool/main/d/deepin-scrot/deepin-scrot_2.0-0deepin_all.deb ?
« Последнее редактирование: 02 Май 2019, 15:57:23 от Azure »
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн dr.Vadz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • SEOhub
Re: Проблемы с установкой deepin-screenshot
« Ответ #6 : 02 Май 2019, 15:52:04 »
что в этой программе такого чего нет в других?

возможность выбрать область для скрина, на лету наложить указатели и текст. Более удобного приложения для Ubuntu не встречал. Шутеры разные не то

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
« Последнее редактирование: 02 Май 2019, 16:06:06 от Azure »
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн dr.Vadz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • SEOhub
Re: Проблемы с установкой deepin-screenshot
« Ответ #8 : 02 Май 2019, 18:05:21 »
Дело в том, что именно этот deb я и устанавливаю. Там пример инструкции привел.

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #9 : 02 Май 2019, 22:31:08 »
Дело в том, что именно этот deb я и устанавливаю
Не верь своим глазам!
Preparing to unpack .../Desktop/deepin-screenshot.deb ...
Unpacking deepin-screenshot (4.0.11-1) ...
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн ALiEN175

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4708
  • Capture the truth
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #10 : 02 Май 2019, 22:54:50 »
есть пакет из 5cm.ru - делает всё то же (кружочки, стрелочки, текст). Негативных отзывов не нашел.
ASUS P5K-C :: Intel Xeon E5450 :: 8 GB RAM :: Nvidia 8500GT :: XFCE
SAMSUNG N150 :: Intel Atom N450 :: 2 GB RAM :: Intel GMA3150 :: XFCE

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #11 : 03 Май 2019, 09:51:36 »
Куча программ (тот же Shutter)
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 4742
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #12 : 03 Май 2019, 10:02:24 »
flameshot

Оффлайн dr.Vadz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
    • SEOhub
Re: Проблемы с установкой deepin-screenshot
« Ответ #13 : 06 Декабрь 2019, 01:52:24 »

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1158
    • Просмотр профиля
Re: Проблемы с установкой deepin-screenshot
« Ответ #14 : 06 Декабрь 2019, 10:31:38 »
Вот интересно даже что есть в нём такое чего нет во всемогущем kde-spectacle ?

 

Страница сгенерирована за 0.092 секунд. Запросов: 25.