Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: При закгрузке колод для anki появляется ошибка  (Прочитано 324 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 353
    • Просмотр профиля
Kubuntu 19.04

Если ставить Anki из репозитория, то программа после успешной установки просто не запускается. Если использовать инструкцию с их чудесного сайта:
$ tar xjf Downloads/anki-2.1.13-amd64.tar.bz2
$ cd anki-2.1.13-linux-amd64
$ sudo make install

, то все публичные колоды с их сайта загружаются в программу с ошибкой:



Как добиться нормальной работы?

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Если ставить Anki из репозитория, то программа после успешной установки просто не запускается.

Вот с этого по-подробнее можно? Какую ошибку пишет в терминале?

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 353
    • Просмотр профиля
Вот с этого по-подробнее можно? Какую ошибку пишет в терминале?

С помощью make uninstall удалил приложение поставленное из архива с их сайта (при этом действительно в выборе программ пропала anki) и установил из репозитория. При запуске только что поставленной программы anki из терминала получаю такую ошибку:
denis@denis-pc:~$ anki
Traceback (most recent call last):
  File "/usr/bin/anki", line 6, in <module>
    import aqt
  File "/usr/share/anki/aqt/__init__.py", line 32, in <module>
    import aqt.forms
  File "/usr/share/anki/aqt/forms/__init__.py", line 44, in <module>
    from . import about
  File "/usr/share/anki/aqt/forms/about.py", line 42, in <module>
    from aqt.webview import AnkiWebView
  File "/usr/share/anki/aqt/webview.py", line 90, in <module>
    class AnkiWebView(QWebEngineView):
NameError: name 'QWebEngineView' is not defined

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2115
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Ваша программа требует QWebEngineView.
Я не пользуюсь Ubuntu 19.04 и не знаю, что есть у неё в репозиториях.  Можно пытаться искать в репах или ставить отдельно, а потом снова запускать вашу программу и смотреть на результат.
Вы установили тестовую версию Ubuntu, значит как разработчик или тестировщик знаете что делаете и подобные вопросы для вас пара пустяков.

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 353
    • Просмотр профиля
Снова снес установленную версию (культурненько с помощью Discover) и поставил второй найденный в Discover вариант: Anki unofficial (это более свежая версия).
Программа запустилась, но теперь при загрузке колод появляется точно такая же ошибка, как для дистрибутива с их сайта!




Вопросы по профильному ПО лучше задавать на форумах, посвященных этому ПО, или напрямую разработчику. К Ubuntu тема отношения не имеет. Ввиду отсутствия ответов, по состоянию на 25.02.2020 модератором раздела принято решение топик заблокировать.
--zg_nico
« Последнее редактирование: 25 Февраль 2020, 01:48:18 от zg_nico »

 

Страница сгенерирована за 0.073 секунд. Запросов: 23.