Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Обновление не поддерживаемого релиза  (Прочитано 917 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Miki+

  • Автор темы
  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
всем привет!
подскажите пжл как обновить не поддерживающийся релиз, на данный момент стоит 11.04
#lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
#cat /etc/apt/sources.list

#deb cdrom:[Ubuntu 11.04 _Natty Narwhal_ - Release amd64 (20110427.1)]/ natty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ua.archive.ubuntu.com/ubuntu/ natty main restricted
deb-src http://ua.archive.ubuntu.com/ubuntu/ natty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ua.archive.ubuntu.com/ubuntu/ natty-updates main restricted
deb-src http://ua.archive.ubuntu.com/ubuntu/ natty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ua.archive.ubuntu.com/ubuntu/ natty universe
deb-src http://ua.archive.ubuntu.com/ubuntu/ natty universe
deb http://ua.archive.ubuntu.com/ubuntu/ natty-updates universe
deb-src http://ua.archive.ubuntu.com/ubuntu/ natty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ua.archive.ubuntu.com/ubuntu/ natty multiverse
deb-src http://ua.archive.ubuntu.com/ubuntu/ natty multiverse
deb http://ua.archive.ubuntu.com/ubuntu/ natty-updates multiverse
deb-src http://ua.archive.ubuntu.com/ubuntu/ natty-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://ua.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# deb-src http://ua.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu natty-security main restricted
deb-src http://security.ubuntu.com/ubuntu natty-security main restricted
deb http://security.ubuntu.com/ubuntu natty-security universe
deb-src http://security.ubuntu.com/ubuntu natty-security universe
deb http://security.ubuntu.com/ubuntu natty-security multiverse
deb-src http://security.ubuntu.com/ubuntu natty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu natty partner
# deb-src http://archive.canonical.com/ubuntu natty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu natty main
deb-src http://extras.ubuntu.com/ubuntu natty main
я так понимаю репозитории не рабочие

ТС не появлялся на Форуме более трех месяцев по состоянию на 23/02/2020 (последняя явка: 25/07/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 23 Февраль 2020, 05:19:10 от zg_nico »

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #1 : 24 Июль 2019, 09:52:31 »
подскажите пжл как обновить не поддерживающийся релиз, на данный момент стоит 11.04
11.04=>11.10=>12.04=>14.04=>16.04
Легче переустановить актуальную версию начисто.

Оффлайн Miki+

  • Автор темы
  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #2 : 24 Июль 2019, 09:56:00 »
Легче переустановить актуальную версию начисто
нужно именно обновление

Пользователь добавил сообщение 24 Июль 2019, 09:56:28:
11.04=>11.10
при обновлении получаю
W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/InRelease 

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/InRelease 

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-security/InRelease 

W: Не удалось получить http://archive.canonical.com/ubuntu/dists/natty/InRelease 

W: Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/InRelease 

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/Release.gpg  Не удалось найти IP адрес для archive.ubuntu.com

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/Release.gpg  Не удалось найти IP адрес для archive.ubuntu.com

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-security/Release.gpg  Не удалось найти IP адрес для archive.ubuntu.com

W: Не удалось получить http://archive.canonical.com/ubuntu/dists/natty/Release.gpg  Не удалось найти IP адрес для archive.canonical.com

W: Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/Release.gpg  Не удалось найти IP адрес для extras.ubuntu.com

W: Some index files failed to download. They have been ignored, or old ones used instead.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #3 : 24 Июль 2019, 10:14:49 »
при обновлении получаю
Репозитории перемещены в архив, поэтому не получается. Нужно прописывать адреса вручную, как это делать при обновлении, я лично не имею понятия. Легче установить вручную, чем мучиться с обновлениями. Почти уверен, что придется походить по граблям.

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #4 : 24 Июль 2019, 10:20:44 »
archive.ubuntu.com на old-releases.ubuntu.com
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн Miki+

  • Автор темы
  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #5 : 24 Июль 2019, 10:24:29 »
archive.ubuntu.com на old-releases.ubuntu.com
#deb http://ua.archive.ubuntu.com/ubuntu/ natty main restricted
deb http://old-releases.ubuntu.com/ubuntu natty main restricted
так правильно будет заменить? или natty main restricted дописывать не надо?

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #6 : 24 Июль 2019, 10:28:28 »
да.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн Miki+

  • Автор темы
  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #7 : 24 Июль 2019, 10:31:51 »
да.
$ sudo apt-get update
Ош  http://extras.ubuntu.com natty InRelease
 
Ош  http://extras.ubuntu.com natty Release.gpg
  Не удалось найти IP адрес для extras.ubuntu.com
Ош  http://old-releases.ubuntu.com natty InRelease
 
Ош  http://old-releases.ubuntu.com natty-updates InRelease
 
Ош  http://old-releases.ubuntu.com natty-security InRelease
 
Ош  http://old-releases.ubuntu.com natty Release.gpg
  Не удалось найти IP адрес для old-releases.ubuntu.com
Ош  http://old-releases.ubuntu.com natty-updates Release.gpg
  Не удалось найти IP адрес для old-releases.ubuntu.com
Ош  http://old-releases.ubuntu.com natty-security Release.gpg
  Не удалось найти IP адрес для old-releases.ubuntu.com
Чтение списков пакетов... Готово
W: Не удалось получить http://old-releases.ubuntu.com/ubuntu/dists/natty/InRelease 

W: Не удалось получить http://old-releases.ubuntu.com/ubuntu/dists/natty-updates/InRelease 

W: Не удалось получить http://old-releases.ubuntu.com/ubuntu/dists/natty-security/InRelease 

W: Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/InRelease 

W: Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/Release.gpg  Не удалось найти IP адрес для extras.ubuntu.com

W: Не удалось получить http://old-releases.ubuntu.com/ubuntu/dists/natty/Release.gpg  Не удалось найти IP адрес для old-releases.ubuntu.com

W: Не удалось получить http://old-releases.ubuntu.com/ubuntu/dists/natty-updates/Release.gpg  Не удалось найти IP адрес для old-releases.ubuntu.com

W: Не удалось получить http://old-releases.ubuntu.com/ubuntu/dists/natty-security/Release.gpg  Не удалось найти IP адрес для old-releases.ubuntu.com

W: Some index files failed to download. They have been ignored, or old ones used instead.
к сожалению безуспешно

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #8 : 24 Июль 2019, 10:36:08 »
deb http://extras.ubun... на #....
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1175
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #9 : 24 Июль 2019, 11:16:19 »
Я в 17м году ради интереса вставил в машину с Xubuntu 11.04 iso c Lubuntu 17.10 и мне эта iso предложила обновить систему сразу до 17.10.
На удивление обновление прошло успешно, от 11.04 осталось только ядро (которое я потом удалил) и тема plymouth
Система работает до сих пор (обновлена уже до 18.04)
Debian Testing (Gnome), Ubuntu Server 18.04

Оффлайн Miki+

  • Автор темы
  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #10 : 24 Июль 2019, 11:36:03 »
#do-release-upgrade

Fetched 0 B in 0s (0 B/s)                                                                       
Reading package lists... Done   
Building dependency tree         
Reading state information... Done
Building data structures... Done

Обновление информации о репозитории
WARNING: Failed to read mirror file

Не найдено ни одного действующего
зеркала

В процессе сканирования информации о
ваших репозиториях, не было найдено
зеркало для обновления дистрибутива.
Такое возможно в случае, если вы
используете внутреннее зеркало или
информация о зеркалах устарела.

Желаете ли вы перезаписать файл
«sources.list» в любом случае? Если вы
выберите «Да», то будут обновлены все
«natty» записей до «oneiric».
Если же вы выберите «Нет», то
обновление будет отменено.
выбираю да и получаю
Ошибка при обновлении

При обновлении возникла проблема.
Обычно это бывает вызвано проблемами
в сети. Проверьте сетевые подключения
и повторите попытку.

W:Failed to fetch
http://extras.ubuntu.com/ubuntu/dists/oneiric/main/source/Sources 404
Not Found
, W:Failed to fetch
http://extras.ubuntu.com/ubuntu/dists/oneiric/main/binary-amd64/Packages
404 Not Found
, W:Failed to fetch
http://extras.ubuntu.com/ubuntu/dists/oneiric/main/binary-i386/Packages
404 Not Found
, E:Some index files failed to download. They have been ignored, or
old ones used instead.


Восстановление первоначального состояния системы

Прерывание
Reading package lists... Done   
Building dependency tree         
Reading state information... Done
Building data structures... Done
как дальше быть?

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #11 : 24 Июль 2019, 12:09:22 »
строк найти h++p://extras.ubuntu.com/ ?

Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #12 : 24 Июль 2019, 12:10:12 »
Miki+, установите актуальную версию ОС , и не мучайтесь с этим обновлением.
Все равно ничем  хорошим это, как правило не заканчивается.

Оффлайн Miki+

  • Автор темы
  • Любитель
  • *
  • Сообщений: 62
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #13 : 24 Июль 2019, 13:02:26 »
строк найти h++p://extras.ubuntu.com/ ?
пришлось в соурс листе вручную изменить все natty на oneiric и плюсом закоментить вами указанные строки, спс за помощь, пока обновился до 11.10
ничем  хорошим это, как правило не заканчивается
к примеру? что может быть не так?

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Re: Обновление не поддерживаемого релиза
« Ответ #14 : 24 Июль 2019, 13:20:50 »
как дальше быть?
Правильно прописать репозитории. Указать old-releases недостаточно.

 

Страница сгенерирована за 0.09 секунд. Запросов: 23.