Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Как запретить выключение аудиокарты.  (Прочитано 1560 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tsimur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Столкнулся с такой проблемой. При отсутсвии воспроизвдения звука через 8 секнд появляется шум в колонках. Шум напоминает наводу от 50Гц.

Также если открыть системные настройки звука то шум пропадает, а если закрыть то появляется через 8 секунд.

Еще момент -- если вытащить микрофон то шум пропадает на 3 секунды, также если втавить микрофон то шум пропдаает на 3 секунды.

Я предполагаю, что причиной шума является отключение аудиовыхода, когда тот не используется.

Подскажите пожалуйста решение этой проблемы. Я предполагаю, что можно настроить систему так, чтобы аудиокарта не отключала выход при простое, но не смог нагуглить инструкцию ни по русски ни по английски.

Пока решаю проблему тем, что открываю настройки звука и оно остается открытм до выключения. Но это не удобно.


Ubuntu 19-04

Оффлайн ALiEN175

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5440
  • Сделай шаг и пройдешь милю
    • Просмотр профиля
ASUS P5K-C :: Intel Xeon E5450 @ 3.00GHz :: 8 GB DDR2 :: Radeon R7 260X :: XFCE
ACER 5750G :: Intel Core i5-2450M @ 2.50GHz :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5733
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #2 : 17 Августа 2019, 20:30:03 »
tsimur, что за компьютер, аудиокарта?aplay -linxi -A

Оффлайн tsimur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #3 : 18 Августа 2019, 11:33:17 »
ALiEN175, спасибо, информация по ссылке помогла мне в поиске решения. Оно находится тут

Там описано место где лежит файл содержащий параметр, управляющим энергосбережением для аудиокарты. Я изменил парметр 1 на 0 в файле:

sys/module/snd_hda_intel/parameters/power_save
И это решило проблему.

Однако после перезагрузки параметр возвращается в еденицу.
Подскажите плз как изменить этот параметр пермоментно.

БТР, вот инф:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio
  driver: snd_hda_intel
  Device-2: AMD Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.0.0-25-generic
« Последнее редактирование: 18 Августа 2019, 11:41:06 от tsimur »

Оффлайн rubear

  • Новичок
  • *
  • Сообщений: 29
  • Ubuntu 18.04
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #4 : 18 Августа 2019, 12:56:34 »
Однако после перезагрузки параметр возвращается в еденицу.
К примеру можно запретить файлу изменяться -
chattr +i /путь/файл
Незаменимых нет !

Оффлайн ALiEN175

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5440
  • Сделай шаг и пройдешь милю
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #5 : 18 Августа 2019, 15:46:07 »
rubear, не сработает для /sys /proc /dev. Угадайте, почему.

tsimur,
На арчвики решение:
/etc/modprobe.d/modprobe.conf
options snd_hda_intel power_save=0Не сработало?
ASUS P5K-C :: Intel Xeon E5450 @ 3.00GHz :: 8 GB DDR2 :: Radeon R7 260X :: XFCE
ACER 5750G :: Intel Core i5-2450M @ 2.50GHz :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн tsimur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #6 : 19 Августа 2019, 22:15:50 »
На арчвики решение:
/etc/modprobe.d/modprobe.conf

Попрбовав во втрой раз, я понял, что это то что я искал.
Первый раз я стлкнуля с тем, что у меня нет такого фала и ошибочно рпедполжил, что арч отличается от Ubuntu и что это решение мне не подойдет.

Но сейча я понимаю, что файл следовало создать)

Спасибо за помощ, все работает)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13909
  • Xubuntu 18.04
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #7 : 26 Августа 2019, 14:25:06 »
Я бы этот файл переименовал из modprobe.conf во что-то более содержательное типа sound-powersave.conf чтобы потом не удивляться и вспомнить откуда файл взялся. Имя файла значение не имеет, но при апгрейде и т.п. лучше делать так.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #8 : 26 Августа 2019, 15:30:21 »
Цитировать
Ubuntu 19-04
также бета.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн tsimur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #9 : 24 Июня 2020, 19:22:18 »
Резюмирую для тех кто будет искать ответ на этот же вопрос.
Чтобы убрать треск надо сделать:

sudo bash -c 'echo options snd_hda_intel power_save=0 power_save_controller=N > /etc/modprobe.d/modprobe.conf'

После этого перезагрузиться.
« Последнее редактирование: 24 Июня 2020, 20:26:18 от tsimur »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28018
    • Просмотр профиля
Re: Как запретить выключение аудиокарты.
« Ответ #10 : 24 Июня 2020, 22:22:07 »
tsimur,
echo options snd_hda_intel power_save=0 power_save_controller=N | sudo tee -a /etc/modprobe.d/options-snd_hda_intel.conf
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.049 секунд. Запросов: 25.