Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Флешка подключается не с первого раза - Недопустимая ссылка  (Прочитано 2786 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 539
    • Просмотр профиля
Когда подключаю любую флешку и на вслпывающем окне первый раз нажимаю "Открыть в диспетчере файлов" получаю диалоговое окно с заголовком "Ошибка - Клиент KIO", текстом "Недопустимая ссылка" и единственной кнопкой "ОК". Если в dolphin нажать на соответствующее устройство слева, то он выдает ошибку
При обращении к «Домашняя папка» произошла ошибка, ответ системы: Устройство уже подключено: Device /dev/sdb is already mounted at `/media/homa/1D35-C8C3'.
Если сначала нажать на всплывающем окне на маленький треугольник справа (кнопку "Сделать носитель доступным для приложений"), то флешку открыть удается.

Пользователь добавил сообщение 02 Сентябрь 2019, 17:06:33:
$ screenfetch
                          ./+o+-       homa@ryzen
                  yyyyy- -yyyyyy+      OS: Ubuntu 18.04 bionic
               ://+//////-yyyyyyo      Kernel: x86_64 Linux 4.20.12-042012-generic
           .++ .:/++++++/-.+sss/`      Uptime: 5h 46m
         .:++o:  /++++++++/:--:/-      Packages: 3344
        o:+o+:++.`..```.-/oo+++++/     Shell: bash
       .:+o:+o/.          `+sssoo+/    Resolution: 1920x1080
  .++/+:+oo+o:`             /sssooo.   DE: KDE 5.44.0 / Plasma 5.12.6
 /+++//+:`oo+o               /::--:.   WM: KWin
 \+/+o+++`o++o               ++////.   WM Theme: BreezeCust
  .++.o+++oo+:`             /dddhhh.   GTK Theme: Breeze [GTK2/3]
       .+.o+oo:.          `oddhhhh+    Icon Theme: breeze
        \+.++o+o``-````.:ohdhhhhh+     Font: Noto Sans Regular
         `:o+++ `ohhhhhhhhyo++os:      CPU: AMD Ryzen 3 2200G with Radeon Vega Graphics @ 4x 3.5GHz [28.0°C]
           .o:`.syhhhhhhh/.oo++o`      GPU: AMD RAVEN (DRM 3.27.0, 4.20.12-042012-generic, LLVM 6.0.0)
               /osyyyyyyo++ooo+++/     RAM: 2880MiB / 6977MiB
                   ````` +oo+++o\:   
                          `oo++.

Вот тут написано, что это уже вроде как пропатчили, но я не пойму, как мне воспользоваться этим патчем.
« Последнее редактирование: 02 Сентябрь 2019, 17:06:33 от damix »

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1175
    • Просмотр профиля
Product: plasmashell
Version Fixed: 5.46

Ждать, когда данный пакет обновится до данной версии. Или вы хотите патчить?
Debian Testing (Gnome), Ubuntu Server 18.04

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 539
    • Просмотр профиля
m-svo, так уже пропатчили, аж в прошлом году. Я хочу себе поставить исправленную версию какого надо пакета. По необходимости могу собрать что-то из исходников.

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1175
    • Просмотр профиля
Не могу разобраться в версиях KDE, насколько я знаю собрать плазму / KDE не легко.
Проще сделать полный бэкап системы, обновиться до 19.04, если не поможет, до 19.10 (альфы) - там уже KDE 5.16, последняя версия. Конечно, можно словить баги и похуже.
Debian Testing (Gnome), Ubuntu Server 18.04

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 539
    • Просмотр профиля
Конечно, можно словить баги и похуже.
Вот и я о том же. Наверняка словлю баги похуже. Ждать или слезать с LTS - не вариант, <ирония>я хочу пользоваться стабильным софтом, который гарантировано работает без багов</ирония>.
(Нажмите, чтобы показать/скрыть)

Я тоже не разбираюсь в KDE, но как я понял, тут нужны вот эти пакеты, а они зависят от libqt5core5a 5.11.1, а ей нужна libc6 2.28, а
# dpkg -i libc6_2.28-0ubuntu1_amd64.deb
dpkg: относительно libc6_2.28-0ubuntu1_amd64.deb, содержащего libc6:amd64:
 libc6:amd64 ломает locales (<< 2.28)
  locales (версия 2.27-3ubuntu1) существует и установлен.

dpkg: ошибка при обработке архива libc6_2.28-0ubuntu1_amd64.deb (--install):
 установка libc6:amd64 сломает locales, и
 деконфигурация не разрешена (--auto-deconfigure может помочь)
При обработке следующих пакетов произошли ошибки:
 libc6_2.28-0ubuntu1_amd64.deb

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1175
    • Просмотр профиля
Смешивать версии пакетов - для меня ещё ничем хорошим не заканчивалось.
Уж лучше полный бэкап и попытать удачи.

(Нажмите, чтобы показать/скрыть)
Debian Testing (Gnome), Ubuntu Server 18.04

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Стыдоба и позор! Оказывается, в  KDE проблемы с монтированием флэшки! Ёпрст.. :'(

Пользователь добавил сообщение 10 Сентябрь 2019, 23:55:23:
Разрабы из GNOME, например, крайне недовольны тем, какие версии браузера Canonical выбирает для своих релизов.
А кто, простите, кроме разрабов Gnome, зарелизил глючный релиз, попавший в репозитории Ubuntu? Если разрабы Gnome не довольны, они могли бы сделать свой PPA для Ubuntu и предоставлять свой правильный браузер для актуальных версий Ubuntu. Понятно, что в репозитории попадают пакеты из дебиановского тестинга, а пакеты такие, какие они там есть. А для одного из наиболее популярных каналов распространения их браузера можно и пошевелиться самим, а не постить девичий плач с претензиями.
« Последнее редактирование: 10 Сентябрь 2019, 23:55:23 от Tear »

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1175
    • Просмотр профиля
Tear, так они эту злополучную 3.28 фиксили ещё год, сейчас актуальна уже 3.28.5. Кто не работает, тот не ошибается. Вы думаете они для Арча или для Федоры фиксят старый релиз? Нет, для Убунты и Дебиан. Но в коммерческой компании Canonical ресурсов не хватает, чтобы протестировать и залить фикс. С момента написания того поста (май 2019) версии пакетов в 18.04 и 19.04 остались абсолютно те же. А снап Epiphany (который Canonical непонятно зачем вообще создали, без поддержки апстрима) ещё более сломанный, крашится постоянно.
Зачем нужны ppa? Ubuntu пытается быть простым, доступным дистрибутивом, а мы должны пользователя отправлять в терминал за не сломанным браузером...

Пользователь добавил сообщение 11 Сентябрь 2019, 06:21:27:
В Дебиан 10 версия 3.32.1, в Ubuntu 19.04 - 3.32.0. Ну он же упакован уже и собран, просто кнопку нажать...
« Последнее редактирование: 11 Сентябрь 2019, 06:21:27 от m-svo »
Debian Testing (Gnome), Ubuntu Server 18.04

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Но в коммерческой компании Canonical ресурсов не хватает, чтобы протестировать и залить фикс. С момента написания того поста (май 2019) версии пакетов в 18.04 и 19.04 остались абсолютно те же.
Этот пакет из репозитория Каноникал не поддерживает. Это ж не роллинг-дистрибутив. Какой пакет туда попал, такой там и есть.

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 539
    • Просмотр профиля
Стыдоба и позор! Оказывается, в  KDE проблемы с монтированием флэшки! Ёпрст..
Причем тут монтирование? Монтируется все нормально.

На правах оффтопа:
(Нажмите, чтобы показать/скрыть)

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1175
    • Просмотр профиля
damix
(Нажмите, чтобы показать/скрыть)
Debian Testing (Gnome), Ubuntu Server 18.04

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 539
    • Просмотр профиля
Починил!

Проблема решается обновлением Solid до версии 5.46.
Устанавливаем/обновляем необходимые пакеты
apt install git cmake dialog qttools5-dev

Опционально
(Нажмите, чтобы показать/скрыть)

Устанавливаем переменную окружения - путь, куда установить Solid
export KF5=/usr
Собираем и ставим Extra CMake Modules
git clone git://anongit.kde.org/extra-cmake-modules
cd extra-cmake-modules
cmake -DCMAKE_INSTALL_PREFIX=$KF5 .
make -j5
su
make install
exit
cd ..

Собираем и обновляем Solid
git clone git://anongit.kde.org/solid.git
cd solid
git branch v5.46_build 6c916f4e4f48d8fe2256b3acaed5f6f55a3b0bb5
git checkout v5.46_build
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=$KF5 -DCMAKE_PREFIX_PATH=$KF5 ..
make -j5
su
make install
exit

 

Страница сгенерирована за 0.096 секунд. Запросов: 25.