Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Установка Win10 и Ubuntu 18.04.3 в параллель на UEFI  (Прочитано 626 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alexander_d

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
Добрый день всем!
Прошу помощи - целый день убил, ничего не получается.

Дано:
ноутбук Dell Vostro 5581, HDD 1Tb, предустановленная винда.

Что надо:
установить дополнительно SSD, поставить на неё Win10, туда же - Ubuntu (корневой каталог). На HDD - /home + ntfs раздел как общее хранилище файлов.

Что делал:
1. Установил физически SSD.
2. Установил на него Win10 (через UEFI)
3. Установил на него UBUNTU (через UEFI), сделал разделы как и хотел - корень и свап. /home - на обычном винчестере.

Что имеем по факту:
1. В Boot sequence есть 3 записи: Ubuntu, Windows, EFI partition.
2. Грузится только Windows.
3. В разделе EFI всё вроде выглядит пристойно. Есть соответствующие папки (Win, Ubuntu), но при попытке принудительно грузить Ubuntu - ничего не получается.

Утилитой Boot-repair прошёлся, - пишет "неудачно", но ни черта не могу понять в чём неудача. Все папки в EFI на месте, все разделы установлены верно (с live флешки монтировал и смотрел содержимое).

Логи тут: http://paste.ubuntu.com/p/89YRhw2437/

Справочно: /sda - 1 Tb винчестер
           /sdb - флешка live
           /nvme0n1 - SSD диск

Буду очень признателен за помощь!

Спасибо.
« Последнее редактирование: 11 Сентябрь 2019, 21:31:37 от Alexander_d »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4478
    • Просмотр профиля
Re: Установка Win10 и Ubuntu 18.04.3 в параллель на UEFI
« Ответ #1 : 12 Сентябрь 2019, 05:26:47 »
Цитировать
/nvme0n1 - SSD диск
Возможно, здесь твой случай.

Оффлайн Alexander_d

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
Re: Установка Win10 и Ubuntu 18.04.3 в параллель на UEFI
« Ответ #2 : 12 Сентябрь 2019, 09:14:36 »
Возможно, здесь твой случай.

Увы, проблема именно в настройке EFI. При установке, Ubuntu отлично видит SSD, и я размечаю диск так, как следует.

Пользователь добавил сообщение 12 Сентябрь 2019, 09:27:48:
Вопрос решён.
Как и предполагал - неверная сслыка в настройках EFI.
Заходим в BIOS (вернее, в UEFI), удаляем все ненужные пункты и заводим нужный пункт (ubuntu, указываем раздел, указываем верный адрес до efi файла (в моем случае - nvme0n1p2/EFI/ubuntu/shimx64.efi)).
« Последнее редактирование: 12 Сентябрь 2019, 09:27:48 от Alexander_d »

 

Страница сгенерирована за 0.073 секунд. Запросов: 26.