Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Установка VMWare Tools. Помогите найти ошибку [Решено]  (Прочитано 1395 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ubuntix

  • Автор темы
  • Участник
  • *
  • Сообщений: 118
    • Просмотр профиля
Не получается установить. Пожалуйста, посмотрите, где ошибка
Код: (bash) [Выделить]
user@user-virtual-machine:/tmp/vmware-tools-distrib$ sudo ./vmware-install.pl -dThe installer has detected an existing installation of open-vm-tools packages
on this system and will not attempt to remove and replace these user-space
applications. It is recommended to use the open-vm-tools packages provided by
the operating system. If you do not want to use the existing installation of
open-vm-tools packages and use VMware Tools, you must uninstall the
open-vm-tools packages and re-run this installer.
The packages that need to be removed are:
open-vm-tools
Packages must be removed with the --purge option.
The installer will next check if there are any missing kernel drivers. Type yes
if you want to do this, otherwise type no [yes]
INPUT: [yes]  default

A previous installation of VMware Tools has been detected.

The previous installation was made by the tar installer (version 4).

Keeping the tar4 installer database format.

You have a version of VMware Tools installed.  Continuing this install will
first uninstall the currently installed version.  Do you wish to continue?
(yes/no) [yes]
INPUT: [yes]  default

Uninstalling the tar installation of VMware Tools.

Stopping services for VMware Tools

Stopping VMware Tools services in the virtual machine:
   VMware User Agent (vmware-user):                                    done
   Unmounting HGFS shares:                                             done
   Guest filesystem driver:                                            done

Stopping Thinprint services in the virtual machine:
   Stopping Virtual Printing daemon:                                   done

depmod: WARNING: could not open /lib/modules/4.15.0-62-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-62-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-20-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-20-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-34-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-34-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-36-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-36-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-30-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-30-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-58-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-58-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-33-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-33-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-60-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-60-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-55-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-55-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-32-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-32-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-29-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-29-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-38-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-38-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-23-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-23-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-22-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-22-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-24-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-24-generic/modules.builtin: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-64-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/4.15.0-64-generic/modules.builtin: No such file or directory
The removal of VMware Tools 10.2.0 build-7259539 for Linux completed
successfully.

Installing VMware Tools.

In which directory do you want to install the binary files?
[/usr/bin]
INPUT: [/usr/bin]  default

What is the directory that contains the init directories (rc0.d/ to rc6.d/)?
[/etc]
INPUT: [/etc]  default

What is the directory that contains the init scripts?
[/etc/init.d]
INPUT: [/etc/init.d]  default

In which directory do you want to install the daemon files?
[/usr/sbin]
INPUT: [/usr/sbin]  default

In which directory do you want to install the library files?
[/usr/lib/vmware-tools]
INPUT: [/usr/lib/vmware-tools]  default

The path "/usr/lib/vmware-tools" does not exist currently. This program is
going to create it, including needed parent directories. Is this what you want?
[yes]
INPUT: [yes]  default

In which directory do you want to install the documentation files?
[/usr/share/doc/vmware-tools]
INPUT: [/usr/share/doc/vmware-tools]  default

The path "/usr/share/doc/vmware-tools" does not exist currently. This program
is going to create it, including needed parent directories. Is this what you
want? [yes]
INPUT: [yes]  default

The installation of VMware Tools 10.3.10 build-13959562 for Linux completed
successfully. You can decide to remove this software from your system at any
time by invoking the following command: "/usr/bin/vmware-uninstall-tools.pl".

Before running VMware Tools for the first time, you need to configure it by
invoking the following command: "/usr/bin/vmware-config-tools.pl". Do you want
this program to invoke the command for you now? [yes]
INPUT: [yes]  default


You have chosen to install VMware Tools on top of an open-vm-tools package. 
You will now be given the option to replace some commands provided by
open-vm-tools.  Please note that if you replace any commands at this time and
later remove VMware Tools, it may be necessary to re-install the open-vm-tools.

WARNING:  It appears your system is missing the required /usr/bin/vmhgfs-fuse

Initializing...


Making sure services for VMware Tools are stopped.

Stopping VMware Tools services in the virtual machine:
   VMware User Agent (vmware-user):                                    done
   Unmounting HGFS shares:                                             done
   Guest filesystem driver:                                            done


The module vmci has already been installed on this system by another installer
or package and will not be modified by this installer.

The module vsock has already been installed on this system by another installer
or package and will not be modified by this installer.

The module vmxnet3 has already been installed on this system by another
installer or package and will not be modified by this installer.

The module pvscsi has already been installed on this system by another
installer or package and will not be modified by this installer.

The module vmmemctl has already been installed on this system by another
installer or package and will not be modified by this installer.

The VMware Host-Guest Filesystem allows for shared folders between the host OS
and the guest OS in a Fusion or Workstation virtual environment.  Do you wish
to enable this feature? [yes]
INPUT: [yes]  default

The vmxnet driver is no longer supported on kernels 3.3 and greater. Please
upgrade to a newer virtual NIC. (e.g., vmxnet3 or e1000e)


Skipping configuring automatic kernel modules as no drivers were installed by
this installer.


Skipping rebuilding initrd boot image for kernel as no drivers to be included
in boot image were installed by this installer.

The configuration of VMware Tools 10.3.10 build-13959562 for Linux for this
running kernel completed successfully.

Found VMware Tools CDROM mounted at /media/user/VMware Tools. Ejecting device
/dev/sr0 ...
Found VMware Tools CDROM mounted at /mnt/cdrom. Ejecting device /dev/sr0 ...
Enjoy,

--the VMware team
« Последнее редактирование: 18 Март 2020, 11:26:39 от zg_nico »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4454
    • Просмотр профиля
Re: Установка VMWare Tools. Помогите найти ошибку
« Ответ #1 : 24 Октябрь 2019, 04:35:02 »
Читай, что тебе написали и действуй по порядку.
Цитировать
It is recommended to use the open-vm-tools packages
У тебя уже установлена версия. Или пользуйся ей, или сначала удали, потом устанавливай.

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1484
    • Просмотр профиля
Re: Установка VMWare Tools. Помогите найти ошибку
« Ответ #2 : 24 Октябрь 2019, 10:01:08 »
The vmxnet driver is no longer supported on kernels 3.3 and greater. Please upgrade to a newer virtual NIC. (e.g., vmxnet3 or e1000e)

Цитировать
The following entry must be added to the VMware configuration file to provide the vmx
     device:

           ethernet0.virtualDev = "vmxnet3"

сцыль
« Последнее редактирование: 24 Октябрь 2019, 10:11:35 от bezbo »

Оффлайн ubuntix

  • Автор темы
  • Участник
  • *
  • Сообщений: 118
    • Просмотр профиля
Re: Установка VMWare Tools. Помогите найти ошибку
« Ответ #3 : 24 Октябрь 2019, 23:51:24 »
У тебя уже установлена версия
Но система так не считает
Или пользуйся ей
Не получается
или сначала удали
Пробовал. Ничего не изменилось
(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 24 Октябрь 2019, 23:59:38:
ethernet0.virtualDev = "vmxnet3"
Если добавить в конфиг виртуальной машины строку ethernet0.virtualDev = "vmxnet3", то она вообще перестает запускаться. Выдает ошибку Dictionary problem
« Последнее редактирование: 26 Октябрь 2019, 15:56:39 от zg_nico »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4454
    • Просмотр профиля
Re: Установка VMWare Tools. Помогите найти ошибку
« Ответ #4 : 25 Октябрь 2019, 07:06:10 »
Цитировать
Пробовал. Ничего не изменилось
sudo /usr/bin/vmware-uninstall-tools.pl
А система говорит, что удалять надо:
Цитировать
If you do not want to use the existing installation of

open-vm-tools packages and use VMware Tools, you must uninstall the

open-vm-tools packages and re-run this installer.

The packages that need to be removed are:

open-vm-tools

 

Страница сгенерирована за 0.077 секунд. Запросов: 23.