Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Почему не запускаются X11?  (Прочитано 1161 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Axeles

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Почему не запускаются X11?
« : 27 Октябрь 2019, 09:14:36 »
Добрый день! Добрые люди помогите пожалуйста как запустить X11 на старом пк. Устанавливал иксы следующей командой
Код: (bash) [Выделить]
sudo apt-get install --no-install-recommends xserver-xorg x11-xserver-utils xinit openbox -y, на виртуалке всё работает на реальном железе не в какую(
Конфигурация пк
Код: (bash) [Выделить]
H/W path        Device     Class       Description
==================================================
                           system      PROD00000000
/0                         bus         nForce
/0/0                       memory      128KiB BIOS
/0/4                       processor   AMD Sempron(tm) Processor 2600+
/0/4/8                     memory      128KiB L1 cache
/0/4/9                     memory      128KiB L2 cache
/0/1a                      memory      768MiB System Memory
/0/1a/0                    memory      256MiB DIMM
/0/1a/1                    memory      512MiB DIMM
/0/100                     bridge      nForce3 250Gb Host Bridge
/0/100/1                   bridge      nForce3 250Gb LPC Bridge
/0/100/1.1                 bus         nForce 250Gb PCI System Management
/0/100/2                   bus         CK8S USB Controller
/0/100/2/1      usb2       bus         OHCI PCI host controller
/0/100/2.1                 bus         CK8S USB Controller
/0/100/2.1/1    usb3       bus         OHCI PCI host controller
/0/100/2.2                 bus         nForce3 EHCI USB 2.0 Controller
/0/100/2.2/1    usb1       bus         EHCI Host Controller
/0/100/5        enp0s5     bridge      CK8S Ethernet Controller
/0/100/6                   multimedia  nForce3 250Gb AC'97 Audio Controller
/0/100/8                   storage     CK8S Parallel ATA Controller (v2.5)
/0/100/a                   storage     nForce3 Serial ATA Controller
/0/100/b                   bridge      nForce3 250Gb AGP Host to PCI Bridge
/0/100/b/0                 display     RV350 [Radeon 9550/9600/X1050 Series]
/0/100/b/0.1               display     RV350 [Radeon 9550/9600/X1050 Series] (Secondary)
/0/100/e                   bridge      nForce3 250Gb PCI-to-PCI Bridge
/0/101                     bridge      K8 [Athlon64/Opteron] HyperTransport Technology Configuration
/0/102                     bridge      K8 [Athlon64/Opteron] Address Map
/0/103                     bridge      K8 [Athlon64/Opteron] DRAM Controller
/0/104                     bridge      K8 [Athlon64/Opteron] Miscellaneous Control
/0/1            scsi2      storage
/0/1/0.0.0      /dev/sda   disk        8012MB 8GB SATA Flash D
/0/1/0.0.0/1    /dev/sda1  volume      731MiB Linux filesystem partition
/0/1/0.0.0/2    /dev/sda2  volume      6908MiB Extended partition
/0/1/0.0.0/2/5  /dev/sda5  volume      6908MiB Linux LVM Physical Volume partition

Лог ошибки из файла "/home/kiosk/.local/share/xorg/Xorg.0.log"
во вложении (Log.txt)

Самое интересное что не стартует с двумя видеокартами, но с третьей а именно Radeon X1650 Pro всё заводиться нормально!


Поправлены теги [code] (убраны задвоения тегов, исправлен синтаксис с mysql и javascript на bash). Лог ошибки скачан с https://dropmefiles.com/0Ljlf (он там хранится только 6 дней) и прикреплен в виде вложения к сообщению на форуме.
--zg_nico
« Последнее редактирование: 27 Октябрь 2019, 20:21:39 от zg_nico »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4444
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #1 : 27 Октябрь 2019, 09:33:08 »
Ну с железом более-менее понятно. А система?
Цитировать
Устанавливал иксы следующей командой
К чему такие сложности. Почему не установить сразу нормальную десктоп-систему.
Пробовать самое банальное в таких случаях - загрузку с параметром "nomodeset".

Оффлайн Axeles

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #2 : 27 Октябрь 2019, 09:56:10 »
Вывод команды uname -a
Linux pol2term 4.4.0-142-generic #168-Ubuntu SMP Wed Jan 16 21:01:15 UTC 2019 i6               86 athlon i686 GNU/Linux


Пользователь добавил сообщение 27 Октябрь 2019, 11:32:24:
К чему такие сложности. Почему не установить сразу нормальную десктоп-систему.
Пробовать самое банальное в таких случаях - загрузку с параметром "nomodeset".
Такие сложности потому что это терминал (электронный киоск" с жёстким диском в 8 гигабайт, из которых после форматирование остаётся 7, и и 768 мегабайт оперативки. Поэтому расход памяти максимально снизить хочется. С другой картой всё настроил немного задыхается процессор, при загрузке страницы хрома, буду что то решать, но это совсем другая проблема, а так работает довольно шустро. у кушает 200 метров. Найду другой проц и всё будет ок.
Делал всё этой по статье  https://projects-42.nl/index.php/2018/ubuntu-18-04-lts-kiosk-for-web-or-rdp/
« Последнее редактирование: 27 Октябрь 2019, 11:32:24 от Axeles »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4444
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #3 : 27 Октябрь 2019, 11:58:20 »
Цитировать
с жёстким диском в 8 гигабайт, из которых после форматирование остаётся 7, и и 768 мегабайт оперативки
Ноут с которого пишу, почти ровесник твоего. Оперативы 512мб. Корневой раздел 8гб. Установлена десктопная ЛUbuntu 18.04.
После загрузки занято примерно 120мб оперативы, Если запустить сессию openbox, то еще меньше.
Цитировать
немного задыхается процессор, при загрузке страницы хрома
И будет задыхаться. Таков нынешний интернет, таковы браузеры. И одним процом здесь не отделаешься. Только все железо менять.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27657
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #4 : 27 Октябрь 2019, 12:33:25 »
Поставьте метапакет ubuntu-desktop-чегонибудь.
Это если вам действительно десктопная система нужна.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Axeles

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #5 : 27 Октябрь 2019, 17:05:08 »
А зачем он мне? В том то и дело что он полностью мне не нужен.

Пользователь добавил сообщение 27 Октябрь 2019, 17:05:52:
И будет задыхаться. Таков нынешний интернет, таковы браузеры. И одним процом здесь не отделаешься. Только все железо менять.
Но ведь работает сейчас. Там сайтик то простенький... Регистрация только через ЕСИА (госуслуги)

Оффлайн piyavking

  • Активист
  • *
  • Сообщений: 709
  • никогда так не было, чтобы никак не было
    • Просмотр профиля
    • Пиявкин
Re: Почему не запускаются X11?
« Ответ #6 : 27 Октябрь 2019, 17:26:32 »
Дело, скорее всего, в "--no-install-recommends". У меня похожее что-то было, не взлетали иксы, так я этот флаг убрал, установил вместе с рекомендованными пакетами, и они взлетели. Ещё при отсутствующем ~/.xinitrc иксы отказываются запускаться от пользователя, надо, чтоб был.
крайний LTS Netboot, awesomeWM/иксы без WM, urxvtd, qutebrowser, vim/gvim, mpv/smplayer, linux-lowlatency, jack+wineasio

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1251
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #7 : 27 Октябрь 2019, 19:58:51 »
Xorg не нашел для Вашей видеокарты подходящий драйвер, о чем Вам и сообщил в логах:
Fatal server error:

[   320.145] (EE) AddScreen/ScreenInit failed for driver 0
Вы либо сконфигурируйте его вручную, либо не мучайтесь и поставьте десктоп, как советовали выше. Если поставить что-нибудь легкое, вроде lubuntu, то особой разницы между ручной установкой и установкой мета-пакетом Вы не почувствуете.

Оффлайн Axeles

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #8 : 27 Октябрь 2019, 22:03:26 »
Цитировать
Поправлены теги
Спасибо большое. Я тут первый раз не разобрался толком, постараюсь не допускать такого впредь.

Пользователь добавил сообщение 27 Октябрь 2019, 22:05:52:
Дело, скорее всего, в "--no-install-recommends". У меня похожее что-то было, не взлетали иксы, так я этот флаг убрал, установил вместе с рекомендованными пакетами, и они взлетели. Ещё при отсутствующем ~/.xinitrc иксы отказываются запускаться от пользователя, надо, чтоб был.
Спасибо. Можно чуть подробнее какой командой ставили. И они сейчас стартуют с другой видеокартой. Просто она включается через раз. Причём ошибка не понятная. Выключаешь доп питание и заново включаешь и снова всё работает. Шнур исправен, разъём перепаивал ))) Мистика

Пользователь добавил сообщение 27 Октябрь 2019, 22:08:17:
Вы либо сконфигурируйте его вручную, либо не мучайтесь и поставьте десктоп, как советовали выше. Если поставить что-нибудь легкое, вроде lubuntu, то особой разницы между ручной установкой и установкой мета-пакетом Вы не почувствуете.
Именно это я и думал. Гуглил эту строчку но ничего не понял. Только не давно начал изучать линукс вплотную. Спасибо большое. Драйвер я кстати пытался поставить вручную у меня это не вышло. Может не так ставил
« Последнее редактирование: 28 Октябрь 2019, 04:18:07 от zg_nico »

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1251
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #9 : 27 Октябрь 2019, 23:12:44 »
Нужно создать конфигурационный файл. Производители видеокарт часто приводят его, либо поставляют скрипт, который его генерирует. Можно попробовать самому, если карта не какая-нибудь экзотичная, то может сработать.

Команда:
sudo Xorg :0 -configureсоздаст файл /root/xorg.conf.new, его нужно скопировать в /etc/X11/xorg.conf, потом, возможно, в этом файле надо будет что-то подправить, например, указать явно нужный драйвер.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27657
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #10 : 27 Октябрь 2019, 23:51:47 »
А зачем он мне? В том то и дело что он полностью мне не нужен.
Ну-ну… А ничего, что десктопная система - это не только собственно иксы, но и оконный менеджер, диспетчер входа, и т.д. и т.п.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Axeles

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #11 : 31 Октябрь 2019, 00:07:41 »
Зачем на терминале для оплаты услуг который стартует загружает страницу сайта всё это надо...

Пользователь добавил сообщение 31 Октябрь 2019, 00:08:37:
создаст файл /root/xorg.conf.new, его нужно скопировать в /etc/X11/xorg.conf, потом, возможно, в этом файле надо будет что-то подправить, например, указать явно нужный драйвер.
Спасибо большое попробую

Оффлайн piyavking

  • Активист
  • *
  • Сообщений: 709
  • никогда так не было, чтобы никак не было
    • Просмотр профиля
    • Пиявкин
Re: Почему не запускаются X11?
« Ответ #12 : 02 Ноябрь 2019, 04:41:53 »
Спасибо. Можно чуть подробнее какой командой ставили.
Плохо помню - ставил давно по первому попавшемуся гуглорецепту. по идее, xserver-xorg и xinit, чтоб в иксы от пользователя с консоли заходить, для киоска вполне достаточно. ну и xserver-xorg-video-$видео_кард_нейм проверить.
крайний LTS Netboot, awesomeWM/иксы без WM, urxvtd, qutebrowser, vim/gvim, mpv/smplayer, linux-lowlatency, jack+wineasio

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1263
    • Просмотр профиля
Re: Почему не запускаются X11?
« Ответ #13 : 02 Ноябрь 2019, 14:25:41 »
Зачем на терминале для оплаты услуг который стартует загружает страницу сайта всё это надо
PORTEUS_Kiosk ...не ?

 

Страница сгенерирована за 0.081 секунд. Запросов: 25.