Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: PHP 7.3.11 CLI требует устаревшую libvpx.so.5  (Прочитано 1498 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« : 29 Октябрь 2019, 16:47:01 »
Имеется Ubuntu 19.10, на ней установлен Пых, таким образом: sudo apt-get install php7.3-soap php7.3-curl php7.3-mysql php7.3-xml php7.3-zip php7.3-gd php7.3-mbstring
Как модуль Apache - PHP работает без проблем, а вот запуск из командной строки выглядит так:$ php -v
php: error while loading shared libraries: libvpx.so.5: cannot open shared object file: No such file or directory

Сперва еще требовал libmcrypt4, но ее установил без проблем, а вот libvpx уже присутствует в системе, только более новая. $ sudo apt install libvpx*
Заметьте, выбирается «libvpx6» для шаблона «libvpx*»
Уже установлен пакет libvpx6 самой новой версии (1.8.1-2).

Подскажите, пожалуйста, кто сталкивался с подобным - как быть? Куда рыть?

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1484
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #1 : 29 Октябрь 2019, 17:08:07 »
php -v

sudo apt install php
PHP 7.3.11 CLI
модуль Apache - PHP

а что вам надо? cli или libapache2-mod-php - это две большие разницы.

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #2 : 29 Октябрь 2019, 17:11:57 »
Понимаю, что это не одно и то же ;) Apache mod важнее, но консольный вариант наладить тоже бы не худо.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #3 : 02 Ноябрь 2019, 20:19:18 »
Установите php7.3-cli для начала.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #4 : 03 Ноябрь 2019, 02:11:09 »
Установите php7.3-cli для начала.

php-cli присутствует в системе. Иначе как бы я привел вывод команды php -v в консоли? :coolsmiley:

Уже установлен пакет php7.3-cli самой новой версии (7.3.11-0ubuntu0.19.10.1).

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #5 : 03 Ноябрь 2019, 12:40:08 »
Тогда покажите вывод `update-alternatives --display php`
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #6 : 03 Ноябрь 2019, 14:09:01 »
$ update-alternatives --display php
php - автоматический режим
  link best version is /usr/bin/php7.3
  ссылка сейчас указывает на /usr/bin/php7.3
  link php is /usr/bin/php
  slave php.1.gz is /usr/share/man/man1/php.1.gz
/usr/bin/php7.3 — приоритет 73
  подчинённый php.1.gz: /usr/share/man/man1/php7.3.1.gz

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #7 : 03 Ноябрь 2019, 16:37:59 »
А из какого репо ставили PHP? И откуда libvpx?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
« Последнее редактирование: 04 Ноябрь 2019, 23:24:00 от webhead »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #9 : 04 Ноябрь 2019, 22:57:04 »
Что "всё"? Там только Git, и то неясно, зачем?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #10 : 04 Ноябрь 2019, 23:35:36 »
Прошу прощение, git'овская репа тут не при чем, вы правы.
В /etc/apt/source.list значится следующее:
deb http://ru.archive.ubuntu.com/ubuntu/ eoan main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ eoan-updates main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ eoan universe
deb http://ru.archive.ubuntu.com/ubuntu/ eoan multiverse
и т.п.
Больше никаих репозитариев кроме этого системного и вышеперечисленных не подключено.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #11 : 04 Ноябрь 2019, 23:48:32 »
/etc/apt/sources.list.d/ ?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #12 : 04 Ноябрь 2019, 23:51:07 »
/etc/apt/sources.list.d$ ls
dropbox.list
dropbox.list.save
git-core-ubuntu-ppa-eoan.list
git-core-ubuntu-ppa-eoan.list.save
google-chrome.list
google-chrome.list.save
graphics-drivers-ubuntu-ppa-eoan.list
starws-box-ubuntu-deadbeef-player-eoan.list
starws-box-ubuntu-deadbeef-player-eoan.list.save

Об этом я сообщал выше.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #13 : 05 Ноябрь 2019, 00:03:21 »
Ну вот значит один из этих репо и установил вам лишнюю либу.

apt-cache showpkg libvpx6
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн webhead

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: PHP 7.3.11 CLI требует устаревшую libvpx.so.5
« Ответ #14 : 05 Ноябрь 2019, 00:11:24 »
А почему лишнюю? Просто более новую, чем почему-то хочется новой же Пыхе. :o И как теперь с этим быть?
$ apt-cache showpkg libvpx6
Package: libvpx6
Versions:
1.8.1-2 (/var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_eoan_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_eoan_main_binary-amd64_Packages
                  MD5: 9cee3076e27a3ba8414aeb5e611c4e9f
 Description Language:
                 File: /var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_eoan_main_binary-i386_Packages
                  MD5: 9cee3076e27a3ba8414aeb5e611c4e9f
 Description Language: en
                 File: /var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_eoan_main_i18n_Translation-en
                  MD5: 9cee3076e27a3ba8414aeb5e611c4e9f


Reverse Depends:
  libvpx-dev,libvpx6 1.8.1-2
  virtualbox,libvpx6 1.6.0
  libmyth,libvpx6 1.6.0
  vpx-tools,libvpx6 1.8.1-2
  utox,libvpx6 1.6.0
  sludge-engine,libvpx6 1.6.0
  libxine2-misc-plugins,libvpx6 1.6.0
  libtoxcore2,libvpx6 1.6.0
  libqxmpp1,libvpx6 1.6.0
  libmediastreamer-voip10,libvpx6 1.6.0
  libavcodec58,libvpx6 1.6.0
  libavcodec-extra58,libvpx6 1.6.0
  godot3-server,libvpx6 1.6.0
  godot3-runner,libvpx6 1.6.0
  godot3,libvpx6 1.6.0
  baresip-core,libvpx6 1.6.0
  libvpx6:i386,libvpx6 1.8.1-2
  libvpx6:i386,libvpx6 1.8.1-2
  gstreamer1.0-plugins-good,libvpx6 1.6.0
Dependencies:
1.8.1-2 - libc6 (2 2.29) libvpx6:i386 (35 1.8.1-2) libvpx6:i386 (38 1.8.1-2)
Provides:
1.8.1-2 -
Reverse Provides:

 

Страница сгенерирована за 0.075 секунд. Запросов: 25.