Форум русскоязычного сообщества Ubuntu


Автор Тема: ati4290+amdRX560 и перестал startx  (Прочитано 209 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hesoyamatogun

  • Автор темы
  • Активист
  • *
  • Сообщений: 343
    • Просмотр профиля
ati4290+amdRX560 и перестал startx
« : 22 Ноябрь 2019, 03:39:26 »
Здрасти, нужно установить драйвер на старую встройку HD4290, при этом чтоб не попортило OpenCL и остальное для относительно новой RX560.
С сайта амд драйвер не ставится, там версия amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run. Против неё подпись up to 3.4 версия ядра.
Ну и в логе:
(Нажмите, чтобы показать/скрыть)
Заголовки установлены но файла /lib/modules/4.15.0-70-generic/build/include/linux/version.h там нету.
Как быть?

Ну ладно, хрен с ним, перезагружаю, startx не стартует. Отключаю встроенное видео, не стартует. Он перезаписал xorg.conf(без него тоже не стартует)
Xorg.0.log
(Нажмите, чтобы показать/скрыть)


ТС, как видно по состоянию на 18/03/2020 потерял интерес к созданной им теме (пометка Решено в теме отсутствует, тема оставлена не закрытой, сообщений в теме давно не было). На реплики форумчан реакции со стороны ТС нет. Тема стародавняя (последнее сообщение в топике: 22/11/2019; последнее сообщение от ТС в топике: 22/11/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 18 Март 2020, 11:48:11 от zg_nico »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3061
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
Re: ati4290+amdRX560 и перестал startx
« Ответ #1 : 22 Ноябрь 2019, 16:11:52 »
нужно установить драйвер на старую встройку HD4290
На такое древнее железо проприетарный драйвер можно было установить, используя ядро <= 3.4 и Xserver <= 1.12. И только.
Ссылка.

Я странен, а не странен кто ж? (С)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
Re: ati4290+amdRX560 и перестал startx
« Ответ #2 : 22 Ноябрь 2019, 16:13:09 »
hesoyamatogun,
Не надо было никаких драйверов ставить на это железо. Оно прекрасно поддерживается ядром. А старые драйверы на новые системы не ставятся.
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.082 секунд. Запросов: 23.