Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS  (Прочитано 2999 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« : 30 Ноябрь 2019, 12:40:49 »
Добрый день,

RX 560 [AREZ-4RX560-2G-EVO] была куплена ради трех голов одновременно

В данный момент:
1. u2412mc dell монитор
2. TV Philips

При подключении
Монитор->DP + TV->HDMI "светится" (работает) только монитор;
Монитор->DVI + TV->HDMI "светятся" оба, но как один дисплей (дублирование) (звук в HDMI тоже не идет, но это позже)
Prop-драйвер скачал, но пока не решаюсь накатывать
Тут и так ,вроде как, есть что чинить, да ведь?

$ uname -ri
4.15.0-70-generic x86_64

$ dpkg -l amdgpu-pro
dpkg-query: шаблону amdgpu-pro не соответствует ни один пакет

$ glxinfo|grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

$ aptitude search amdgpu|grep "^i"
i   libdrm-amdgpu1                  - Userspace interface to amdgpu-specific ker
i A libdrm-amdgpu1:i386             - Userspace interface to amdgpu-specific ker
i   xserver-xorg-video-amdgpu-hwe-1 - X.Org X server -- AMDGPU display driver   

Машина - не виртуальная

Спасибо, кто откликнется
« Последнее редактирование: 30 Ноябрь 2019, 12:42:26 от ccstim »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #1 : 30 Ноябрь 2019, 12:42:09 »
Дайте вывод

lspci -knn | grep -EA3 'VGA|Display'
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #2 : 30 Ноябрь 2019, 12:42:59 »
$ lspci -knn | grep -EA3 'VGA|Display'
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/555/560] [1002:67ef] (rev e5)
Subsystem: ASUSTeK Computer Inc. Device [1043:0563]
Kernel modules: amdgpu
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:aae0]

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #3 : 30 Ноябрь 2019, 12:45:47 »
Ничего не понятно. Модуль ядра не используется. Откуда-то renderer VMware.
Что-то вы наколбасили с системой. Понять что именно сложно. Загрузитесь с liveUSB и увидите, что все будет нормально работать.

То ли вы пытались в гостевую машину пробросить устройство, то ли что-то еще наковыряли. Это не догадаться.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #4 : 30 Ноябрь 2019, 12:48:04 »
Загрузитесь с liveUSB и увидите, что все будет нормально работать.
м-да, Вы - правы, с livecd все работает правильно, даже звук в hdmi

Спасибо

Пользователь добавил сообщение 30 Ноябрь 2019, 13:01:27:
то ли что-то еще наковыряли. Это не догадаться
там, еще когда была 12.04 впиливались драйвера nvidia :) наследие - тяжелое, да :)
« Последнее редактирование: 30 Ноябрь 2019, 13:01:27 от ccstim »

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #5 : 02 Декабрь 2019, 16:00:31 »
реанимировал темку (ну очень много нужно "строить" после переустановки)
может кто придумает, как вернуть драйвер ядра к жизни
(vmware-драйвер, который пишется у меня сейчас, говорят, за ради safe используется теперь)

(пробовал поставить amdgpu-pro-17.10-446706 , lightdm в цикл встает, снес)


текущие исходные данные:

с livecd 16.04.6 LTS все работает "из коробки" (3 одновременных монитора + звук в hdmi)$ glxinfo|grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 560 Series (POLARIS11 / DRM 3.23.0 / 4.15.0-45-generic, LLVM 6.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
,но


на "боевой" машине никогда не было VMWare, и это - хостовая машина, но
используются драйверы $ glxinfo|grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5

хотелось бы вернуть к нужным

Спасибо
« Последнее редактирование: 02 Декабрь 2019, 16:32:51 от ccstim »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #6 : 03 Декабрь 2019, 00:36:06 »
хотелось бы вернуть к нужным
Установите заново - будут нужные. Угадать что и где вы там прописали не сможет никто.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #7 : 03 Декабрь 2019, 12:01:47 »
все, новая "паночка померла" тоже
~$ glxinfo|grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

после дерготни в "Настройка экранов" и перезагрузки

Пользователь добавил сообщение 03 Декабрь 2019, 12:24:59:
Угадать что и где вы там прописали не сможет никто.
(vmware-драйвер, который пишется у меня сейчас, говорят, за ради safe используется теперь)
уже выяснили, не я это прописал
это драйвер (чем-то) ставится как safemode-драйвер
« Последнее редактирование: 03 Декабрь 2019, 12:24:59 от ccstim »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #8 : 03 Декабрь 2019, 14:45:13 »
Ну дайте вывод под спойлер

cat /etc/modprobe.d/*
Где-то заблеклистили amdgpu видимо. Но могут быть еще места.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #9 : 03 Декабрь 2019, 14:46:28 »
~$ cat /etc/modprobe.d/*
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
# The microcode module attempts to apply a microcode update when
# it autoloads.  This is not always safe, so we block it by default.
blacklist microcode
# For some Atheros 5K RF MACs, the madwifi driver loads buts fails to
# correctly initialize the hardware, leaving it in a state from
# which ath5k cannot recover. To prevent this condition, stop
# madwifi from loading by default. Use Jockey to select one driver
# or the other. (Ubuntu: #315056, #323830)
blacklist ath_pci

# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac

blacklist usblp
# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# Causes trackpads to stop working on Lenovo 11e 2nd gen (Ubuntu: #1802135)
# and Lenovo x240 to hang on boot (Ubuntu: #1802689)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac
# Select the legacy firewire stack over the new CONFIG_FIREWIRE one.

blacklist ohci1394
blacklist sbp2
blacklist dv1394
blacklist raw1394
blacklist video1394

#blacklist firewire-ohci
#blacklist firewire-sbp2
# Framebuffer drivers are generally buggy and poorly-supported, and cause
# suspend failures, kernel panics and general mayhem.  For this reason we
# never load them automatically.
blacklist aty128fb
blacklist atyfb
blacklist bochs-drm
blacklist radeonfb
blacklist cirrusfb
blacklist cyber2000fb
blacklist cyblafb
blacklist gx1fb
blacklist hgafb
blacklist i810fb
blacklist intelfb
blacklist kyrofb
blacklist lxfb
blacklist matroxfb_base
blacklist neofb
blacklist nvidiafb
blacklist pm2fb
blacklist rivafb
blacklist s1d13xxxfb
blacklist savagefb
blacklist sisfb
blacklist sstfb
blacklist tdfxfb
blacklist tridentfb
#blacklist vesafb
blacklist vfb
blacklist viafb
blacklist vt8623fb
blacklist udlfb
# Uncomment these entries in order to blacklist unwanted modem drivers
# blacklist snd-atiixp-modem
# blacklist snd-intel8x0m
# blacklist snd-via82xx-modem
blacklist ac97
blacklist ac97_codec
blacklist ac97_plugin_ad1980
blacklist ad1848
blacklist ad1889
blacklist adlib_card
blacklist aedsp16
blacklist ali5455
blacklist btaudio
blacklist cmpci
blacklist cs4232
blacklist cs4281
blacklist cs461x
blacklist cs46xx
blacklist emu10k1
blacklist es1370
blacklist es1371
blacklist esssolo1
blacklist forte
blacklist gus
blacklist i810_audio
blacklist kahlua
blacklist mad16
blacklist maestro
blacklist maestro3
blacklist maui
blacklist mpu401
blacklist nm256_audio
blacklist opl3
blacklist opl3sa
blacklist opl3sa2
blacklist pas2
blacklist pss
blacklist rme96xx
blacklist sb
blacklist sb_lib
blacklist sgalaxy
blacklist sonicvibes
blacklist sound
blacklist sscape
blacklist trident
blacklist trix
blacklist uart401
blacklist uart6850
blacklist via82cxxx_audio
blacklist v_midi
blacklist wavefront
blacklist ymfpci
blacklist ac97_plugin_wm97xx
blacklist ad1816
blacklist audio
blacklist awe_wave
blacklist dmasound_core
blacklist dmasound_pmac
blacklist harmony
blacklist sequencer
blacklist soundcard
blacklist usb-midi
blacklist radeon
# Many less commonly used network protocols have recently had various
# security flaws discovered. In an effort to reduce the scope of future
# vulnerability exploitations, they are being blacklisted here so that
# unprivileged users cannot use them by default. System owners can still
# either modify this file, or specifically modprobe any needed protocols.

# ax25
alias net-pf-3 off
# netrom
alias net-pf-6 off
# x25
alias net-pf-9 off
# rose
alias net-pf-11 off
# decnet
alias net-pf-12 off
# econet
alias net-pf-19 off
# rds
alias net-pf-21 off
# af_802154
alias net-pf-36 off
# Watchdog drivers should not be loaded automatically, but only if a
# watchdog daemon is installed.
blacklist acquirewdt
blacklist advantechwdt
blacklist alim1535_wdt
blacklist alim7101_wdt
blacklist booke_wdt
blacklist cpu5wdt
blacklist eurotechwdt
blacklist i6300esb
blacklist i8xx_tco
blacklist ib700wdt
blacklist ibmasr
blacklist indydog
blacklist iTCO_wdt
blacklist it8712f_wdt
blacklist it87_wdt
blacklist ixp2000_wdt
blacklist ixp4xx_wdt
blacklist machzwd
blacklist mixcomwd
blacklist mpc8xx_wdt
blacklist mpcore_wdt
blacklist mv64x60_wdt
blacklist pc87413_wdt
blacklist pcwd
blacklist pcwd_pci
blacklist pcwd_usb
blacklist s3c2410_wdt
blacklist sa1100_wdt
blacklist sbc60xxwdt
blacklist sbc7240_wdt
blacklist sb8360
blacklist sc1200wdt
blacklist sc520_wdt
blacklist sch311_wdt
blacklist scx200_wdt
blacklist shwdt
blacklist smsc37b787_wdt
blacklist softdog
blacklist twl4030_wdt
blacklist w83627hf_wdt
blacklist w83697hf_wdt
blacklist w83697ug_wdt
blacklist w83877f_wdt
blacklist w83977f_wdt
blacklist wafer5823wdt
blacklist wdt
blacklist wdt_pci
blacklist wm8350_wdt
# modprobe information used for DKMS modules
#
# This is a stub file, should be edited when needed,
# used by default by DKMS.
# This file blacklists most old-style PCI framebuffer drivers.

blacklist arkfb
blacklist aty128fb
blacklist atyfb
blacklist radeonfb
blacklist cirrusfb
blacklist cyber2000fb
blacklist kyrofb
blacklist matroxfb_base
blacklist mb862xxfb
blacklist neofb
blacklist pm2fb
blacklist pm3fb
blacklist s3fb
blacklist savagefb
blacklist sisfb
blacklist tdfxfb
blacklist tridentfb
blacklist vt8623fb
# The microcode module attempts to apply a microcode update when
# it autoloads.  This is not always safe, so we block it by default.
blacklist microcode
# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211
# mlx4_core gets automatically loaded, load mlx4_en also (LP: #1115710)
softdep mlx4_core post: mlx4_en

~$ grep amd /etc/modprobe.d/*
/etc/modprobe.d/blacklist.conf:# EDAC driver for amd76x clashes with the agp driver preventing the aperture
/etc/modprobe.d/blacklist.conf:blacklist amd76x_edac
/etc/modprobe.d/blacklist.conf.dpkg-dist:# EDAC driver for amd76x clashes with the agp driver preventing the aperture
/etc/modprobe.d/blacklist.conf.dpkg-dist:blacklist amd76x_edac

~$ sudo ls -l /mnt/etc/modprobe.d/blacklist*
-rw-r--r-- 1 root root  325 мар 13  2016 /mnt/etc/modprobe.d/blacklist-ath_pci.conf
-rw-r--r-- 1 root root 1535 фев 16  2019 /mnt/etc/modprobe.d/blacklist.conf
-rw-r--r-- 1 root root 1667 ноя 13  2018 /mnt/etc/modprobe.d/blacklist.conf.dpkg-dist
-rw-r--r-- 1 root root  210 мар 13  2016 /mnt/etc/modprobe.d/blacklist-firewire.conf
-rw-r--r-- 1 root root  697 мар 13  2016 /mnt/etc/modprobe.d/blacklist-framebuffer.conf
-rw-r--r-- 1 root root  156 июл 31  2015 /mnt/etc/modprobe.d/blacklist-modem.conf
lrwxrwxrwx 1 root root   41 сен 15  2018 /mnt/etc/modprobe.d/blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
-rw-r--r-- 1 root root   17 июн 23  2017 /mnt/etc/modprobe.d/blacklist-radeon.conf
-rw-r--r-- 1 root root  583 мар 13  2016 /mnt/etc/modprobe.d/blacklist-rare-network.conf
-rw-r--r-- 1 root root 1077 мар 13  2016 /mnt/etc/modprobe.d/blacklist-watchdog.conf
и все это - не вчера
« Последнее редактирование: 03 Декабрь 2019, 15:00:09 от ccstim »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #10 : 03 Декабрь 2019, 15:27:03 »
А что говорит

dkms status
sudo modprobe amdgpu
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #11 : 03 Декабрь 2019, 15:31:54 »
$ dkms status
amdgpu-pro, 17.10-446706: added
anbox, 1, 4.15.0-70-generic, x86_64: installed
anbox, 1, 4.15.0-72-generic, x86_64: installed
~$ glxinfo|grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

и дублируются DP+HDMI, DVI - молчит
« Последнее редактирование: 03 Декабрь 2019, 15:36:17 от ccstim »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #12 : 03 Декабрь 2019, 15:36:32 »
amdgpu-pro, 17.10-446706: added
amdgpu-pro, 17.10-446706: added
Ну вот и ответ, судя по всему. Неудачная попытка поставить amdgpu-pro. Его надо удалить

sudo dkms remove amdgpu-pro/17.10-446706 --all
Я только не понял почему вы дали вывод другой второй команды, и почему там совсем другое железо появилось.

Пользователь добавил сообщение 03 Декабрь 2019, 15:39:38:
Ну и blacklist radeon надо убрать. Кто его туда поставил?
« Последнее редактирование: 03 Декабрь 2019, 15:39:38 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ccstim

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #13 : 03 Декабрь 2019, 15:40:34 »
sudo aptitude purge  amdgpu-pro-dkms
$ dkms status
anbox, 1, 4.15.0-70-generic, x86_64: installed
anbox, 1, 4.15.0-72-generic, x86_64: installed
$  glxinfo|grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Пользователь добавил сообщение 03 Декабрь 2019, 15:41:34:
sudo dkms remove amdgpu-pro/17.10-446706 --all
$ sudo dkms remove amdgpu-pro/17.10-446706 --all
Error! There are no instances of module: amdgpu-pro
17.10-446706 located in the DKMS tree.

уже снес

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Radeon RX 560 [AREZ-4RX560-2G-EVO] 16.04LTS
« Ответ #14 : 03 Декабрь 2019, 15:41:38 »
ccstim,
ОК. Уберите blacklist radeon. Видимо с live именно с ним и работает.
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.088 секунд. Запросов: 25.