Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: установка .deb-пакетов для ubuntu 18.4 в Ubuntu 19.10  (Прочитано 776 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RIOCADM

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
мне нужно устанвоить программу из deb -пакета для ubuntu 18.4 в ubuntu 19.10

dpkg: зависимости пакетов не позволяют настроить пакет nausoftphone:
 nausoftphone зависит от libboost-filesystem1.65.1, однако:
  Пакет libboost-filesystem1.65.1 не установлен.
 nausoftphone зависит от libboost-system1.65.1, однако:
  Пакет libboost-system1.65.1 не установлен.
 nausoftphone зависит от libboost-thread1.65.1, однако:
  Пакет libboost-thread1.65.1 не установлен.
 nausoftphone зависит от libqt5quickwidgets5 (>= 5.9.0~beta), однако:
  Пакет libqt5quickwidgets5 не установлен.
 nausoftphone зависит от libqt5script5 (>= 5.6.0~beta), однако:
  Пакет libqt5script5 не установлен.
 nausoftphone зависит от phonon-backend-gstreamer | phonon-backend, однако:
  Пакет phonon-backend-gstreamer не установлен.
  Пакет phonon-backend не установлен.
 nausoftphone зависит от sni-qt, однако:
  Пакет sni-qt не установлен.
pkg: ошибка при обработке пакета nausoftphone (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для libc-bin (2.30-0ubuntu2) …
Обрабатываются триггеры для desktop-file-utils (0.24-1ubuntu1) …
Обрабатываются триггеры для mime-support (3.63ubuntu1) …
Обрабатываются триггеры для gnome-menus (3.32.0-1ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 nausoftphone
root@RIOC-340200150:/media/riocadm/RAID0/UbuntuInstal# apt-get install libboost-filesystem1.65.1
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет libboost-filesystem1.65.1 недоступен, но упомянут в списке зависимостей другого
пакета. Это может означать, что пакет отсутствует, устарел или
доступен из источников, не упомянутых в sources.list

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1175
    • Просмотр профиля
Re: установка .deb-пакетов для ubuntu 18.4 в Ubuntu 19.10
« Ответ #1 : 16 Декабрь 2019, 17:00:50 »
Можно попробовать скачать пакет руками и поставить его в 19.10
https://packages.ubuntu.com/bionic/libboost-filesystem1.65.1

Но за работоспособность системы после этого я не отвечаю  :)
Для совместимости с таким софтом надо использовать 18.04
Debian Testing (Gnome), Ubuntu Server 18.04

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4451
    • Просмотр профиля
Re: установка .deb-пакетов для ubuntu 18.4 в Ubuntu 19.10
« Ответ #2 : 16 Декабрь 2019, 17:29:06 »
Цитировать
нужно устанвоить программу из deb -пакета для ubuntu 18.4 в ubuntu 19.10
Плохая идея.
Цитировать
nausoftphone зависит от libqt5quickwidgets5 (>= 5.9.0~beta), однако:
  Пакет libqt5quickwidgets5 не установлен.
Вдвойне плохая идея, т.к. похоже потянет "много KDE".
Цитировать
за работоспособность системы после этого я не отвечаю
Поддерживаю.
 Но если уж сильно хочется, то не устанавливать пакеты, а распаковывать. Меньше шансов, что порушит систему. В случае если не заработает, можно будет просто и без последствий удалить.
Сложность и опасность в том, что, по всей видимости, придется тащить много "чужих пакетов".
Можно поэкпериментировать на "живой системе".

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3055
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
Re: установка .deb-пакетов для ubuntu 18.4 в Ubuntu 19.10
« Ответ #3 : 16 Декабрь 2019, 23:40:49 »
Вдвойне плохая идея, т.к. похоже потянет "много KDE".
тут ещё хуже другое - что ТС сам себя не полностью процитировал, как он ставил этот nausoftphone и откуда.
Я странен, а не странен кто ж? (С)

Оффлайн RIOCADM

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: установка .deb-пакетов для ubuntu 18.4 в Ubuntu 19.10
« Ответ #4 : 17 Декабрь 2019, 07:22:10 »
сейчас стоит nausoftphone_7.0.55.1., при обновлении с 18.04 до 19.10 он остался и работает, но возникла необходимость поставить новую версию в связи с обновлением сервера.
По сути это програмыный софтфон.

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4451
    • Просмотр профиля
Re: установка .deb-пакетов для ubuntu 18.4 в Ubuntu 19.10
« Ответ #5 : 17 Декабрь 2019, 10:29:40 »
Цитировать
По сути это програмыный софтфон.
Не верно. По сути, это версия программы, чуждая данной версии системы.
А родная...
Цитировать
nausoftphone_7.0.55.1., при обновлении с 18.04 до 19.10 он остался и работает
Впрочем, это все сути не меняет. Все эксперименты на свой страх и риск.
Две версии одной программы только добавляют риска, что они могут мешать друг другу, например конфиг один, но им требуются разные настройки.
Что вполне возможно, ибо...
Цитировать
новую версию в связи с обновлением сервера
На памяти случай, когда новая версия скайпа не работала со старым профилем, требовалось полное его удаление.
« Последнее редактирование: 17 Декабрь 2019, 10:34:16 от andytux »

Оффлайн RIOCADM

  • Автор темы
  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
Re: установка .deb-пакетов для ubuntu 18.4 в Ubuntu 19.10
« Ответ #6 : 17 Декабрь 2019, 19:30:33 »
поставил с deb пакета софт, но он не запусается.
Я так понимаю придется откатываться к ubuntu 18.04

Пользователь добавил сообщение 17 Декабрь 2019, 19:42:50:
тогда еше вопрос, как сохранить программный рейд при переустанвке системы?
« Последнее редактирование: 17 Декабрь 2019, 19:42:50 от RIOCADM »

 

Страница сгенерирована за 0.092 секунд. Запросов: 25.