Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ubuntu 18.04.4 не запускается после установки на внешний HDD [Решено]  (Прочитано 327 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн seaz96

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Здрасте, решил установить Ubuntu 18.04.4 на внешний жесткий диск(2,5 HDD в боксе). Вроде, установилось, подумал я. Захожу. Не заходит. Написано: "error: invalid arch independent EFI magic". Ну, пошел гуглить. Вроде как, сам понял, что надо grub восстанавливать. Наткнулся на это: help.ubuntu.ru/wiki/восстановление_grub. Сделал все нормально, выбрал необходимый раздел с системой. Все как надо(способ LiveCD). Обновлять не стал, т.к. особо и не надо. Ладно. Ребут. Запуск. А дальше выдаёт ошипки "can't find command" с "load_video" и "gfxmode". Дальше "?", название системы и снова бесконечные ?... Немного погуглил, узнал, что сначала он пишет Loading Linux... Второе так и не понятно. Спустя секунд 10 открывает меню grub и предлагает загрузить Ubuntu в рекавери моде(как я понял, т.к. так написано в скобках "recovery"). Ну что, делать нечего. Запускаю. Все повторяется, только заменяется "gfxmode" на "recordfail", и в конце, после ожидания, просит нажать любую кнопку. Нажимаю. Куча текста со скоростью звука и в итоге мы приходим к ничему. Куча непонятного текста, "?help" для помощи и строку, куда можно что-то вводить. И что в таком случае делать?
« Последнее редактирование: 03 Май 2020, 06:11:23 от zg_nico »

Оффлайн Lesopoval

  • Активист
  • *
  • Сообщений: 901
    • Просмотр профиля
В лайф без установки заходит? Какая видеокарта?
...
НО ТУТ ВРОДЕ ЧТО-ТО ДРУГОЕ, SEKURE BOOT ОТКЛЮЧЕН?
« Последнее редактирование: 24 Февраль 2020, 07:22:11 от Lesopoval »

Оффлайн MrRomka

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Здравствуйте, уважаемые специалисты. Решил не создавать новую тему, т.к. мой вопрос в общем-то похож.

После первой загрузки с SD карты /dev/mmcblk0 прописал в cmdline.txt следующий текст: console=serial0,115200 console=tty1 root=/dev/sda2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait, указав системе загружаться с внешней USB флешки. C этим все ок.
Далее добавил в систему еще один диск, /dev/sdb.

Проблема в том, что система не грузится с флешки, если /dev/sdb подключен. Если /dev/sdb выключить, то можно загрузиться. После загрузки тоже оба диска видны.

ubuntu@ubuntu:~$ sudo fdisk -l | grep dev
~~
Disk /dev/mmcblk0: 7.5 GiB, 8001683456 bytes, 15628288 sectors
/dev/mmcblk0p1        8192   532479   524288  256M  c W95 FAT32 (LBA)
/dev/mmcblk0p2      532480 15628287 15095808  7.2G 83 Linux
Disk /dev/sda: 56.3 GiB, 60472426496 bytes, 118110208 sectors
/dev/sda1  *      2048    526335    524288  256M  c W95 FAT32 (LBA)
/dev/sda2       526336 118110174 117583839 56.1G 83 Linux
Disk /dev/sdb: 2.7 TiB, 3000558944256 bytes, 5860466688 sectors
/dev/sdb1   2048 5860466654 5860464607  2.7T Linux filesystem

ubuntu@ubuntu:~$ lsblk
NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda           8:0    1 56.3G  0 disk
├─sda1        8:1    1  256M  0 part /boot/firmware
└─sda2        8:2    1 56.1G  0 part /
sdb           8:16   0  2.7T  0 disk
└─sdb1        8:17   0  2.7T  0 part
mmcblk0     179:0    0  7.5G  0 disk
├─mmcblk0p1 179:1    0  256M  0 part
└─mmcblk0p2 179:2    0  7.2G  0 part

ubuntu@ubuntu:~$ sudo blkid
/dev/mmcblk0p1: LABEL="boot" UUID="4BBD-D3E7" TYPE="vfat" PARTUUID="738a4d67-01"
/dev/mmcblk0p2: LABEL="rootfs" UUID="45e99191-771b-4e12-a526-0779148892cb" TYPE="ext4" PARTUUID="738a4d67-02"
/dev/sda1: LABEL="system-boot" UUID="7297-5AF9" TYPE="vfat" PARTUUID="24c43490-01"
/dev/sda2: LABEL="writable" UUID="6d33dc75-68ae-4697-b3c3-3dfa0473150a" TYPE="ext4" PARTUUID="24c43490-02"
/dev/mmcblk0: PTUUID="738a4d67" PTTYPE="dos"
/dev/sdb1: PARTUUID="45094c36-a7f4-fb4a-b692-593ed82298e6"
ubuntu@ubuntu:~$

Пробовал прописывать root=PARTUUID=24c43490-02 (root=PARTUUID=24c43490-02), загрузиться не получается в этом случае даже без /dev/sdb.
Прошу помощи.


Raspberry_Pi_4_Model_B_Rev_1_2;
Kernel: Linux 4.19.97-v7l+ (armv7l)
Distribution: Ubuntu 18.04.4 LTS
« Последнее редактирование: 01 Апрель 2020, 23:16:05 от MrRomka »

 

Страница сгенерирована за 0.071 секунд. Запросов: 26.