Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Не получается установить Brackets - неудовлетворённая зависимость от libcurl3  (Прочитано 816 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 537
    • Просмотр профиля
Скачал Brackets.Release.1.14.1.64-bit.deb отсюда, хочу установить этот пакет, но
# dpkg -i Brackets.Release.1.14.1.64-bit.deb
Выбор ранее не выбранного пакета brackets.
(Чтение базы данных … на данный момент установлено 389150 файлов и каталогов.)
Подготовка к распаковке Brackets.Release.1.14.1.64-bit.deb …
Распаковывается brackets (1.14.1-17752) …
dpkg: зависимости пакетов не позволяют настроить пакет brackets:
 brackets зависит от libcurl3, однако:
  Пакет libcurl3 не установлен.

dpkg: ошибка при обработке пакета brackets (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
При обработке следующих пакетов произошли ошибки:
 brackets

Тогда я
# apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Пакеты, которые будут УДАЛЕНЫ:
  brackets
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 495 пакетов не обновлено.
Установлено или удалено не до конца 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 326 MB.
Хотите продолжить? [Д/н]
(Чтение базы данных … на данный момент установлено 403980 файлов и каталогов.)
Удаляется brackets (1.14.1-17752) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
# apt install libcurl3
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  cmake-data kicad-doc-en kicad-footprints kicad-libraries kicad-packages3d kicad-symbols kicad-templates libfreeimage3 libjxr0 libngspice-kicad liboce-foundation11 liboce-modeling11 liboce-ocaf-lite11 liboce-ocaf11 liboce-visualization11 librhash0 libwxgtk3.0-gtk3-0v5
  python-wxgtk3.0 python-wxversion
Для их удаления используйте «apt autoremove».
Пакеты, которые будут УДАЛЕНЫ:
  cmake cryfs curl gimp-gmic kicad libcurl4 steam-launcher
НОВЫЕ пакеты, которые будут установлены:
  libcurl3
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 7 пакетов, и 494 пакетов не обновлено.
Необходимо скачать 214 kB архивов.
После данной операции, объём занятого дискового пространства уменьшится на 118 MB.
Хотите продолжить? [Д/н] н
Прервано.
Но мне нужны эти проги (cmake cryfs curl gimp-gmic kicad libcurl4 steam-launcher). Как быть? Чем libcurl3 им мешает?

# inxi -S
System:    Host: ryzen Kernel: 4.20.12-042012-generic x86_64 bits: 64 Desktop: KDE Plasma 5.12.6
           Distro: Ubuntu 18.04.1 LTS
# dpkg -l | grep 'libcurl'
ii  libcurl3-gnutls:amd64                           7.58.0-2ubuntu3.8                                   amd64        easy-to-use client-side URL transfer library (GnuTLS flavour)
ii  libcurl3-nss:amd64                              7.58.0-2ubuntu3.8                                   amd64        easy-to-use client-side URL transfer library (NSS flavour)
ii  libcurl4:amd64                                  7.58.0-2ubuntu3.8                                   amd64        easy-to-use client-side URL transfer library (OpenSSL flavour)
ii  libcurl4-gnutls-dev:amd64                       7.58.0-2ubuntu3.8                                   amd64        development files and documentation for libcurl (GnuTLS flavour)

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1158
    • Просмотр профиля
Видимо у этих программ тоже зависимость от libcurl3 другой версии.
А у программа которую Вы устанавливаете пытается другую версию libcurl3 тянуть, возникает комфликт зависимостей и apt говорит что нужно удалить несовместимые программы. Как то так.

Как быть?  Установить данную программу из flatpack.
Он есть в репозитории.
Или взять flat пакет на flathub
https://flathub.org/apps/details/io.brackets.Brackets
« Последнее редактирование: 27 Февраль 2020, 09:25:33 от Usermaster »

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 537
    • Просмотр профиля
Usermaster, установил Flatpak:
add-apt-repository ppa:alexlarsson/flatpak
apt update
apt install flatpak
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
и перезагрузился.

Установил Brackets:
flatpak install flathub io.brackets.Brackets
Команда flatpak run io.brackets.Brackets запускает программу, но тогда интерфейс страшный как в старом гноме или как у рута.

Как сделать чтобы стиль был как у остальных программ?

А то что приложения, установленные через Flatpak, в песочнице запускаются на производительность как-нибудь влияет?

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1158
    • Просмотр профиля
С каким стилем собрали пакет, такой и будет.
На производительность не должно влиять.
Бывает доступ к локальным директориям ограничен у некоторых программ flatpack.

Оффлайн damix

  • Автор темы
  • Активист
  • *
  • Сообщений: 537
    • Просмотр профиля
Скачал libcurl3 deb-пакетом. Установил Brackets так:
mkdir libcurl3
dpkg -x libcurl3_7.58.0-2ubuntu2_amd64.deb libcurl3/
dpkg -x Brackets.Release.1.14.1.64-bit.deb /opt/brackets/
cp libcurl3/usr/lib/x86_64-linux-gnu/libcurl.so.4.5.0 /opt/brackets/opt/brackets/
Тогда
LD_LIBRARY_PATH=/opt/brackets/opt/brackets /opt/brackets/opt/brackets/Bracketsзапускает программу с нормальным стилем.
Да и просто
/opt/brackets/opt/brackets/Brackets
запускает.
Странно, в зависимостях эта либа есть, а без нее работает.
« Последнее редактирование: 27 Февраль 2020, 21:12:54 от damix »

 

Страница сгенерирована за 0.09 секунд. Запросов: 25.