Форум русскоязычного сообщества Ubuntu


Автор Тема: Установщик Ubuntu не видит SSD M.2 nvme Western Digital  (Прочитано 8698 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн novicheck

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Итак, здравствуйте!
Не вижу иного варианта, как обратиться за помощью к коллективному разуму.
Пытаюсь установить который день Ubuntu server (в идеале) или Ubuntu на ПК "LENOVO ThinkCentre M625q" с целью организовать домашний медиа-сервер (надоело напрягать роутер, который не предназначен ни для DM, ни для Transmission). Доверяя обзору покупателя, установившему на этот ПК Ubuntu server 16.04.06 после обновления BIOS, купил, но ... не тут-то было. Я даже задал ему вопрос после неудачной установки сервера, на который получил следующее видео. Сверил все настройки BIOS, привёл накопитель в состояние нового с разметкой MBR
(Нажмите, чтобы показать/скрыть)
но в результате всё-равно получил следующее:
(Нажмите, чтобы показать/скрыть)
И тут начались эксперименты с различными версиями Ubuntu-server и Ubuntu-desktop (от 16.04 до 19.10). Попытка установки любой версии сервера всегда приводит к отсутствию разделов для инсталляции системы. Запуск версии desktop тоже показал, что установщик не обнаружил каких-либо накопителей, кроме собственно флешки с Ubuntu-Live
(Нажмите, чтобы показать/скрыть)
А вот и Терминал:
(Нажмите, чтобы показать/скрыть)
Опережая вопросы:
настройки BIOS
(Нажмите, чтобы показать/скрыть)
В дополнение хочу сказать, что:
1. Windows 10 ставится легко и непринуждённо (но нафик она нужна на сервере?)
2. BIOS обновлён через CD-образ на флешке
3. Образы писал на Rufus
(Нажмите, чтобы показать/скрыть)
4. Похожие ветки форума мониторил, но ни одно из найденных мной решений не подошло (nvme_load=YES, fixparts, переформат накопителя в fat32, ext3 и т.д), либо я что-то не так делал или что-то упустил (хотя и не должен был)
5. В качестве проверки установочных *.iso была опробована инсталляция образов на 2 физические машины и одну виртуальную - всё завелось на "ура".
И возникло подозрение, что мне не повезло, и в микрокоде (или как его там) накопителя есть какая-то ошибка, т.е. брак.
Что скажете? Шансы есть, или сразу в сервисный тащить?
PS: так-то я в *nix-системах полный лопух, но за эти 2,5 дня...
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 02 Апреля 2020, 17:52:19 от novicheck »

Оффлайн ALiEN175

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5451
  • Сделай шаг и пройдешь милю
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #1 : 04 Марта 2020, 18:49:28 »
BIOS - Ata drive setup
Там что?
(14 секунда видео)
ASUS P5K-C :: Intel Xeon E5450 @ 3.00GHz :: 8 GB DDR2 :: Radeon R7 260X :: XFCE
ACER 5750G :: Intel Core i5-2450M @ 2.50GHz :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн novicheck

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #2 : 04 Марта 2020, 18:55:14 »
BIOS - Ata drive setup
Там что?
AHCI. Вариант только один в конфиге.

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1490
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #3 : 04 Марта 2020, 23:14:07 »
Будет длительная, утомительная переписка в теме . Не проще в адресной строке вбить запрос Ubuntu не видит SSD M.2 nvme и почитать.

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #4 : 05 Марта 2020, 06:21:52 »
настройки BIOS
SecureBoot у Вас на этих настройках нигде не мелькает. В каком состоянии эта опция?
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн novicheck

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #5 : 05 Марта 2020, 06:40:07 »
zg_nico, SecureBoot автоматом отключается при включении CSM в меню Startup. Т.е. сейчас выключено.

Пользователь добавил сообщение 05 Марта 2020, 07:02:04:
vladimirzhuravlev, Прежде, чем обратиться сюда, я себе уже глаза сломал, читая/пробуя/вникая. Уж лучше пусть будет "длительная, утомительная переписка" с теми, кто обладает знаниями и способен увидеть то, что может пройти мимо моего внимания. Тут ведь что особенно интересно? - Почему у человека взлетело, а у меня нет на том же самом железе?
« Последнее редактирование: 05 Марта 2020, 07:02:04 от novicheck »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #6 : 05 Марта 2020, 07:06:52 »
SecureBoot автоматом отключается при включении CSM
А Вы отключите свой CSM, задайте пароль на BIOS, вырубите SecureBoot и загрузитесь в UEFI с параметром nvme_load=YES. Видно будет диск при такой загрузке? Разметка в таком контексте роли с точки зрения видимости диска ядром играть не будет, но я бы её переставил на GPT.

Пользователь добавил сообщение 05 Марта 2020, 07:07:59:
Почему у человека взлетело, а у меня нет на том же самом железе?
А у человека тот же самый диск, что и у Вас? Или под тем же самым железом Вы подразумеваете ту же самую материнку, а про диск в данном случае в подробности не вдаемся?
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн novicheck

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #7 : 05 Марта 2020, 19:09:31 »
zg_nico, Сделал, как Вы написали, но все попытки закончились так же, как и ранее. Как выполнял:
- поменял настройки BIOS,
- разметка флешки и накопителя - в GPT,
- запуск без установки ('e', правка строки на "nvme_load=YES", Ctrl+x) версий 18.04 desktop (с обоими установщиками) и 19.10 desktop.
- 16.04, конечно же, в режиме UEFI не ставится совсем (ПК уходит в перезагрузку после получения пакетов команды "nvme_load=YES").

Пользователь добавил сообщение 05 Марта 2020, 19:15:40:
А у человека тот же самый диск, что и у Вас?
Почему-то казалось, что у двух одинаковых ПК и диски должны быть одинаковые. ThinkCentre M625q [10tl0012ru]=ThinkCentre M625q [10tl0012ru], разве нет? Или Вы о том, что не существует двух одинаковых дисков, и каждый из них по-своему с ума сходит?
« Последнее редактирование: 05 Марта 2020, 19:15:40 от novicheck »

Оффлайн Lex Alexov

  • Модератор форума
  • Активист
  • *
  • Сообщений: 291
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #8 : 05 Марта 2020, 20:06:23 »
Была похожая проблема, правда, с распаянным SSD - не вставал ни один дистрибутив... Пока не попробовал поставить манжару - она встала и завелась с первой попытки. Как оказалось - там установщик создал efi-раздел... Но манжара не понравилась,  вручную разбил диск и создал раздел efi. И только тогда все встало на свои места и завелось))


Samsung NP-530U4b-S01; Intel i3-2367M (4) @ 1.44GHz; 8Gb DDR3 1333 МГц; AMD Radeon HD 7550M; Intel HD Graphics 4000; KDE-Neon 5.21 x64;

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1490
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #9 : 05 Марта 2020, 20:48:07 »
AHCI. Вариант только один в конфиге
Но ведь пишут что в режиме AHCI харды SSD M.2 nvme не работают, его нужно отключать. Опция AHCI не активна, не отключить зайдя в неё по ентер ? И не вижу, что пароль задавал как советовал zg_nico. Только не сложный, обычно 1234 ставят что-бы не забыть.

Оффлайн novicheck

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #10 : 06 Марта 2020, 04:39:32 »
Опция AHCI не активна, не отключить зайдя в неё по ентер ?
Опция активна, но по ентер - там только AHCI. Первый раз такое увидел.
Пароль я задал. Вообще, всё сделал в точности, как написано. Может, и правда, попытаться установить другие ОС, как, например, Lex Alexov?

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5369
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #11 : 06 Марта 2020, 05:47:18 »
Цитировать
правда, попытаться установить другие ОС, как, например, Lex Alexov?
Как  Lex Alexov, но главное не другии, а...
Цитировать
...вручную разбил диск и...
Запусти Гпартед и посмотри, видит он твой диск или нет. Если нет, то нет смысла терять время на установку. Если видит, то можно сразу разметить.

Оффлайн novicheck

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #12 : 06 Марта 2020, 06:22:42 »
andytux, Именно это я и имел ввиду. А Gparted, запущенный в Ubuntu, накопителя не видит. От слова "совсем".

Оффлайн The Green Side

  • Старожил
  • *
  • Сообщений: 1177
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #13 : 06 Марта 2020, 08:52:37 »
Читал о том, как новые Маки прячут диск от Линукса, но от Dell не ожидал такого.
Может гипервизор поставить?
Debian 11, Debian 11 Server

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5369
    • Просмотр профиля
Re: Установщик Ubuntu не видит SSD M.2 nvme
« Ответ #14 : 06 Марта 2020, 09:18:25 »
Еще из простого...
Цитировать
Ubuntu-desktop (от 16.04 до 19.10)
Попробовать образ 18.04.4, в ней ядро чуть новее, чем в образе 19.10. Из этих-же  соображений, попробовать тестовую 20.04.
Если нет, то весьма тщательно перелопатить свой УЕФИ. Может действительно, какая-нибудь настройка "прячет диск".
Цитировать
привёл накопитель в состояние нового с разметкой MBR
Если он съемный, то попробовать разметить его на другом компьютере.

 

Страница сгенерирована за 0.039 секунд. Запросов: 24.