Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: После обновления Ubuntu 18.04.4 LTS на ноутбуке DELL пропал звук  (Прочитано 1009 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nick7

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Купил новый ноутбук DELL G3. Ubuntu 18.04.4 LTS предложила обновление - сразу после обновления пропал полностью звук.
На англоязычных форумах прочитал, что такая проблема есть и у других владельцев новых ноутов этой марки.

Проблему никто решить пока не смог.

Подскажите что делать, пожалуйста.

Вот ссылки на подобную проблему:

https://askubuntu.com/questions/914463/dummy-output-no-sound-in-ubuntu-16-04
https://ru.stackoverflow.com/questions/567030/Не-работает-аудио-драйвер-dummy-output-ubuntu-16-04

Проблема еще в том, что в биос новом не могу найти возможность загрузиться с флешки и переустановить систему.

Пользователь добавил сообщение 21 Март 2020, 07:22:48:
В настройках - аудио. как и у других с подобной проблемой написано "фиктивный выход".
« Последнее редактирование: 21 Март 2020, 07:22:48 от nick7 »

Оффлайн jura12

  • Старожил
  • *
  • Сообщений: 1407
  • 20.04
    • Просмотр профиля
вы обновились на новый дистрибутив или просто текущие обновления? у меня тоже ноутбук делл востро с переустановленной 18.04. проблем не замечено. гляну еще.
сопротивление бесполезно

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
в биос новом не могу найти возможность загрузиться с флешки и переустановить систему
Во всех dell, что мне попадались, было доступно boot-меню (иногда, оно в настройках bios отключено, его предварительно включить надо). Клавиша F12 (редко F2) при загрузке показывает список источников, с которых можно загрузиться. Если во время загрузки вставлена рабочая загрузочная флешка - она в этом списке будет отображена.
сразу после обновления пропал полностью звук
Весьма вероятно, что пришло обновление ядра, и в новом ядре что-то поломано для Вашего железа. Покажите (текстом!!!) выводы команд терминала из своей системы:
Код: (bash) [Выделить]
uname -r
cat /proc/cmdline
linux-version list
/bin/bash -c '[ -d /sys/firmware/efi ] && bootctl status || echo "Installed in Legacy mode"'
dmesg | egrep -i "(error|fail|warning)"
pacmd list-cards | egrep "output:.*input:"
alsamixer --view=all    #из этой программы выходить нажатием на клавишу Esc
Откройте у себя в системе терминал (комбинация клавиш Ctrl+Alt+T), и по одной строчке за раз из вышеприведенного списка выделяйте команду, вставляйте её в терминал, нажимайте в терминале Enter, и текст, который терминал Вам напишет в ответ выделяйте полностью мышкой, копируйте из окна терминала, и текстом вставляйте в сообщение на форум.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
На последнем ядре 5.3 есть такой баг. Лечится параметром boot. Легко находится.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Я тоже из числа пользователей Dell.
Попал ко мне ноут Dell Inspiron с предустановленной Убунтой, дистрибутив OEM 14.04, и тоже после какого-то обновления пропал звук и тиринг стал проявляться.

Разбирался недолго, причина была в том, что производители ПК в устанавливаемые на заводе системы запихивают драйвера хоть и свободные, но зачастую с какими-то "улучшенниями", и работают эти драйвера, допиленные под конкретное железо, вполне прилично (возможно даже что и лучше, чем не"улучшенные" 8)), вот только работают они до тех пор пока в системе что-то не изменится существенного, например, ядро...

Мучался с этим я достаточно долго
(Нажмите, чтобы показать/скрыть)
- пока не закончилась поддержка 14.04

Тут уж деваться было некуда, установил Ubuntu MATE 18.04 (64-bit), переход на эту версию прошел очень даже удачно, система получилась вполне работоспособной и стабильной (на столько стабильной, что ноут не перегружаю месяцами)ю


Оффлайн lotus_flower

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Здравствуйте! у меня тоже ноутбук DELL G3 15 под Ubuntu 18.04.2 LTS (64-бит) и так же после обновления пропал звук. Мне пришлось восстановить систему в предпродажное состояние при помощи утилиты восстановления Dell. Звук, естесственно, появился. Сейчас, когда все в порядке, вывод на команду aplay -l в терминале выглядит так:
(Нажмите, чтобы показать/скрыть)


Когда звука не было, были только первые три строчки:
*** Список PLAYBACK устройств ****
карта 0: NVidia [HDA NVidia], устройство 3: HDMI 0 [HDMI 0]
  Подустройства: 1/1
  Подустройство №0: subdevice #0

В настройках выход звука отображался как "фиктивное устройство", в pulseaudio при воспроизведении звука эквалайзер скакал, но, судя по конфигурациям, из устройств вывода он видел только видеокарту с профилями Dijital Stereo HDMI, Dijital Surround HDMI. (Сейчас, после восстановления, появилось еще устройство вывода sof_skl_hda_card)

Пока что единственное решение, которое я вижу - не обновляться  ;D
Но, возможно, кто-то знает другой способ?
« Последнее редактирование: 28 Март 2020, 14:47:27 от lotus_flower »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
Но, возможно, кто-то знает другой способ?
Это баг в последнем ядре на некотором железе. Решается элементарно.
https://forum.ubuntu.ru/index.php?topic=310609.0

Но люди продолжают создавать темы и задавать вопросы.
« Последнее редактирование: 28 Март 2020, 18:39:19 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.075 секунд. Запросов: 25.