Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Вопрос по работе штатного клиента OpenVPN  (Прочитано 430 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlexDem

  • Автор темы
  • Активист
  • *
  • Сообщений: 467
    • Просмотр профиля
Как то странно работает 19.10 с OpenVPN сервером. Вроде сервер шустро работает, как только подключается, то скорость обмена с интеренет через него от 50 до 80 мбит. Но проходит какое то время, и скорость обмена данными начинает падать, и падает почти что до 1-2 мбит. Если переподключить - то работает какое то время нормально, потом опять.
С виндой и андроид такого счастья не наблюдаю. Где бы поковырять, чтобы понять проблему?

Лог клиента в спойлере, лог сервера тоже могу дать, если это что-то даст...

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 23 Март 2020, 21:18:20 от AlexDem »

Оффлайн AlexDem

  • Автор темы
  • Активист
  • *
  • Сообщений: 467
    • Просмотр профиля
Re: Вопрос по работе штатного клиента OpenVPN
« Ответ #1 : 02 Апрель 2020, 11:13:50 »
Кстати, заметил любопытную закономерность. Скорость интернета в сети каким то непостижимом для меня образом зависит от включения в конфиг сервера поддержки IPv6.
Вот эти строки:

server-ipv6 2001:bc8:47a0:1e53::/64
ifconfig-ipv6 2001:bc8:47a0:1e53::1 2001:bc8:47a0:1e53::2

И происходит непонятное. В домашней сети есть 2 устройства, Ubuntu и Android, c одинаковыми конфигами клиента OpenVPN.
Разница только в том, что Ubuntu подключена напрямую к роутеру Mikrotik, а Android по WiFi через Keenetic Giga III - подключенного в роутер по lan в режиме «Точка доступа/Ретранслятор». Так вот если указанные выше строки есть в конфиге сервера - то шустро работает Android девайс, скорость 80 мбит, но жутко тормозит интернет на Ubuntu до 1 мбит. Но если эти строки закомментить, то картина в точности наоборот, Android начинает тормозить, а Ubuntu летает. Я понимаю если бы устройства вели себя одинаково, но почему они реагируют вот так?

На Mikrotik поддержка IPv6 включена, но её отключение не меняют ничего.
И еще... Если отключить клиент OpenVPN на Ubuntu, а подключится к серверу через клиента роутера, т.е. весь трафик в сети пустить через OpenVPN, то даже с включенным на сервере IPv6 то на всех устройствах скорость связи отличная. Но я бы хотел оставить всетаки возможность на самих устройствах включать и выключать VPN, а не реализовывать это на уровне роутера.

IP addr
ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 54:a0:50:50:99:f6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.5/24 brd 192.168.1.255 scope global dynamic noprefixroute enp3s0
       valid_lft 302sec preferred_lft 302sec
    inet6 2a02:2168:80f3:1c00:9614:a490:cefe:8c8b/64 scope global dynamic noprefixroute
       valid_lft 2591972sec preferred_lft 604772sec
    inet6 fe80::ede3:382d:6b4a:33c6/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
8: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 100
    link/none
    inet 10.100.0.6 peer 10.100.0.5/32 brd 10.100.0.6 scope global noprefixroute tun0
       valid_lft forever preferred_lft forever
    inet6 2001:bc8:47a0:1e53::1000 peer 2001:bc8:47a0:1e53::1/64 scope global noprefixroute
       valid_lft forever preferred_lft forever

« Последнее редактирование: 02 Апрель 2020, 11:29:29 от AlexDem »

Оффлайн AlexDem

  • Автор темы
  • Активист
  • *
  • Сообщений: 467
    • Просмотр профиля
Re: Вопрос по работе штатного клиента OpenVPN
« Ответ #2 : 04 Апрель 2020, 01:52:59 »
Сам спрашивал, сам отвечаю. Так и не понял, в чем там дело, поэтому просто отключил IPv6 сервера на уровне хостинга. Решение неизящное, т.к. причину проблемы я не нашел, но по крайней мере теперь все работает как надо на всех девайсах. Может потом разберусь что там было.

 

Страница сгенерирована за 0.088 секунд. Запросов: 25.