Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не устанавливается Wine  (Прочитано 2141 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн HPDEV

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Не устанавливается Wine
« : 05 Мая 2020, 13:50:59 »
Прошу помощи!
Стоит Xubuntu 16.04.1 LTS
При установке выдаёт:

$ sudo apt install --install-recommends winehq-stable
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 winehq-stable : Зависит: wine-stable (= 5.0.0~xenial)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

Прошу помощи!

Пользователь добавил сообщение 05 Мая 2020, 13:56:41:
$ grep -rh '^deb' /etc/apt/sources* | egrep wine
deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main
deb http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
deb http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
« Последнее редактирование: 05 Мая 2020, 16:03:21 от Aleksandru »

Оффлайн BKegax

  • Активист
  • *
  • Сообщений: 837
  • Я есть root
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #1 : 05 Мая 2020, 15:08:56 »
Попробуй
sudo dpkg --configure -a
sudo apt --fix-broken install
я твой удочка леска рвал
Windows 11 + KUbuntu 20.04 x64

Оффлайн HPDEV

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #2 : 05 Мая 2020, 15:18:21 »
BKegax,
$ sudo dpkg --configure -a
$ sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
$ sudo apt-get install winehq-stable
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 winehq-stable : Зависит: wine-stable (= 5.0.0~xenial)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Не помогло
« Последнее редактирование: 05 Мая 2020, 16:03:47 от Aleksandru »

Оффлайн BKegax

  • Активист
  • *
  • Сообщений: 837
  • Я есть root
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #3 : 05 Мая 2020, 15:29:06 »
Ну, тогда по sysadmin'овски (скопировано оттуда):

Цитировать
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
При попытке установить какие-либо пакеты через apt, можно столкнуться с такой ошибкой. Одной из причин ее появления, может быть ситуация, когда вы подключили какие-либо сторонние репозитории(ий), которые содержат более новые версии пакетов, а потом удалили их (эти репозитории). При этом информация о новых пакетах осталась в системе.

Информация о доступных пакетах, содержится в файле /var/lib/dpkg/status

Одним из способов это исправить будет удаление информации о более новых пакетах (на которые жалуется apt) из файла /var/lib/dpkg/status.
Первым делом делаем резервную копию:

sudo cp /var/lib/dpkg/status /var/lib/dpkg/status_backup

Теперь открываем файл /var/lib/dpkg/status для редактирования и ищем там пакет, на который жалуется apt. Например, в моем случае, ошибка выглядела так:

nvidia-384 : Зависит: nvidia-driver-390 но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Ищем информацию о пакете nvidia-driver-390 в файле /var/lib/dpkg/status и удаляем ее.
Удалять необходимо начинать со строки Package и до следующей строки, начинающейся со слова Package. При этом обязательно должна остаться пустая строчка, разделяющая пакеты один от другого.

После удаления всех мешающих пакетов, необходимо сделать sudo apt-get update
И проверить, исчезла ли ошибка.

Если не получилось, то восстановить резервную копию можно командой:

sudo cp /var/lib/dpkg/status_backup /var/lib/dpkg/status

Также старые резервные копии данного файла можно найти в каталоге /var/backups. Они будут иметь названия вида:
dpkg.status.0
dpkg.status.1.gz
dpkg.status.2.gz
...
я твой удочка леска рвал
Windows 11 + KUbuntu 20.04 x64

Оффлайн x230

  • Любитель
  • *
  • Сообщений: 64
  • Георгий Александрович
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #4 : 05 Мая 2020, 15:49:25 »
1
# Включаем поддержку архитектуры i386:
sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key

2
# Решение проблемы с зависимостями (устан. OBS repo):
sudo dpkg --add-architecture i386
wget -nc https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key
sudo apt-key add Release.key
sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./'

3
# Установка WineHQ:
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt update
sudo apt install --install-recommends winehq-stable -y

...

Заменяем 18.04 на 16.04 и bionic на xenial
i3-3210 / 4GB / VGA на борту / SSD 240ГБ / Artix (runit) / Kernel 5.10.*-lts / KDE 5.87.* / Plasma 5.23.* / Ungoogled-Chromium

Оффлайн HPDEV

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #5 : 05 Мая 2020, 15:55:31 »
Код: (html5) [Выделить]
$ sudo apt install --install-recommends winehq-stable
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 libfreerdp-client2-2 : Зависит: libwinpr2-2 (>= 2.0.0~git20170725.1.1648deb+dfsg1) но он не может быть установлен
 libfreerdp-common1.1.0 : Зависит: libwinpr-crt0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                          Зависит: libwinpr-library0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                          Зависит: libwinpr-path0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                          Зависит: libwinpr-utils0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
 libfreerdp-plugins-standard : Зависит: libwinpr-crt0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                               Зависит: libwinpr-file0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                               Зависит: libwinpr-handle0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                               Зависит: libwinpr-interlocked0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                               Зависит: libwinpr-synch0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                               Зависит: libwinpr-sysinfo0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                               Зависит: libwinpr-thread0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                               Зависит: libwinpr-utils0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
 libfreerdp-utils1.1 : Зависит: libwinpr-handle0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                       Зависит: libwinpr-synch0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                       Зависит: libwinpr-thread0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
                       Зависит: libwinpr-utils0.1 (>= 1.1.0~beta1+git20130629) но он не может быть установлен
 libfreerdp2-2 : Зависит: libwinpr2-2 (>= 2.0.0~git20180411.1.7a7b1802+dfsg1) но он не может быть установлен
 remmina-plugin-rdp : Зависит: libwinpr2-2 (>= 2.0.0~git20160317.1.75ae3f5+dfsg1) но он не может быть установлен
 winehq-stable : Зависит: wine-stable (= 5.0.0~xenial)
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
$

После ввода sudo apt-get -f install всё сново сломалось, переделал снова.

Цитировать
Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла. Длинные гиперссылки следует оформлять при помощи тега [url=]...[/url]

  --Aleksandru
« Последнее редактирование: 05 Мая 2020, 16:07:02 от Aleksandru »

Оффлайн BKegax

  • Активист
  • *
  • Сообщений: 837
  • Я есть root
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #6 : 05 Мая 2020, 16:20:37 »
А что там вообще насчёт поддержки 16.04 говорится?

Пользователь добавил сообщение 05 Мая 2020, 16:26:40:
x230, про замену 18 на 16 и бионик на ксениал лучше бы в начале написать. А то можно прочитать сие, когда уже всё сделано.
« Последнее редактирование: 05 Мая 2020, 16:26:41 от BKegax »
я твой удочка леска рвал
Windows 11 + KUbuntu 20.04 x64

Оффлайн HPDEV

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #7 : 05 Мая 2020, 16:31:44 »
А что там вообще насчёт поддержки 16.04 говорится?

Пользователь добавил сообщение 05 Мая 2020, 16:26:40:
x230, про замену 18 на 16 и бионик на ксениал лучше бы в начале написать. А то можно прочитать сие, когда уже всё сделано.
Должна быть. На офф сайте есть репозиторий.

Пользователь добавил сообщение 05 Мая 2020, 16:32:27:
А так что делать незнаю.

Пользователь добавил сообщение 05 Мая 2020, 16:40:12:
$ sudo apt-get update
Сущ:1 http://ru.archive.ubuntu.com/ubuntu xenial InRelease
Сущ:2 http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu xenial InRelease
Сущ:3 http://ppa.launchpad.net/lutris-team/lutris/ubuntu xenial InRelease
Сущ:4 https://dl.winehq.org/wine-builds/ubuntu xenial InRelease               
Сущ:5 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_16.04 ./ InRelease
Сущ:6 http://ppa.launchpad.net/mc3man/avidemux1/ubuntu xenial InRelease
Сущ:7 http://ppa.launchpad.net/ravefinity-project/ppa/ubuntu xenial InRelease 
Сущ:8 http://ppa.launchpad.net/rebuntu16/avidemux+unofficial/ubuntu xenial InRelease
Чтение списков пакетов… Готово
         
Может что то подскажет  :-\
« Последнее редактирование: 05 Мая 2020, 16:42:14 от HPDEV »

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1843
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #8 : 05 Мая 2020, 16:47:40 »
Может что то подскажет
Поставь 16.04 ( с семёрошным интерфейсом) от BaaTLT. Тему поменяешь за несколько сек на нужную. Там вайн из коробки нормально работает.

Оффлайн HPDEV

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #9 : 05 Мая 2020, 18:15:23 »
Переустановить не могу  :'( Зависает при загрузки установщика с флешки намертво.

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1843
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #10 : 06 Мая 2020, 00:11:05 »
от BaaTLT
В смысле 16.04 от BaaTLT зависает или любой дистрибутив. В сборке BaaTLT есть проблема с загрузчиком, не на все компы ставится.
Ранее я тусовал папки беря их их других дистрибутивов. Я там в теме отписывался что менял. У меня на 2 компа ни в какую не ставились. Кстати я и сейчас еду на авторском debian 10.3 c xfce 14.4 где установлен вайн. Не я конечно ставил с полпинка вайн на некоторые дистрибутивы, но если пытаюсь установить в какой-то и встречаюсь с битыми пакетами, то просто не желаю тратить время.

Оффлайн HPDEV

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #11 : 06 Мая 2020, 12:03:56 »
Оригинальный 18.04 помирает при загрузке

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1843
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #12 : 06 Мая 2020, 12:45:25 »
Оригинальный 18.04 помирает при загрузке
Прости, но не умея заделать правильно простую флешку загрузочную, ты сразу замахнулся на вайн ? В своей установленной Xubuntu 16.04.1 LTS ты уже так глубоко влез, что у меня сомнения большие насчёт того, что ты вайн поставишь. тут уже никакие "sudo apt-get -f install" не помогут, а лезть и чистить глубже, систему вообще сломать можно.
В 16.04 от BaaTLT вайн прекрасно работает даже будучи загруженным в живом режиме, с флешки. Сейчас добавлю сборку BaaTLT на флешку мультизагрузочную AIOBoot (которая помогает грузить исошники с неправильными загрузчиками) и выложу скрин из "живой", с демонстрацией того, что за 5 минут можно сделать.

Оффлайн HPDEV

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Не устанавливается Wine
« Ответ #13 : 07 Мая 2020, 19:24:54 »
Оригинальный 18.04 помирает при загрузке
Прости, но не умея заделать правильно простую флешку загрузочную, ты сразу замахнулся на вайн ? В своей установленной Xubuntu 16.04.1 LTS ты уже так глубоко влез, что у меня сомнения большие насчёт того, что ты вайн поставишь. тут уже никакие "sudo apt-get -f install" не помогут, а лезть и чистить глубже, систему вообще сломать можно.
В 16.04 от BaaTLT вайн прекрасно работает даже будучи загруженным в живом режиме, с флешки. Сейчас добавлю сборку BaaTLT на флешку мультизагрузочную AIOBoot (которая помогает грузить исошники с неправильными загрузчиками) и выложу скрин из "живой", с демонстрацией того, что за 5 минут можно сделать.
Я умею флешку создовать, я не тупой. Я сумел поставить уже. Ты не думай по тому, дело в grub было.

Пользователь добавил сообщение 07 Мая 2020, 19:25:46:
Wine после переустановки системы поставился.

 

Страница сгенерирована за 0.102 секунд. Запросов: 25.