Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ошибка при монтировании SD-карты через fstab (через mount - работает)  (Прочитано 274 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexvu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Здравствуйте.
Ноутбук с Ubuntu-сервер 14.04 используется как сервер.
Карта, постоянно вставленная в картридер ноута, отформатирована в ext4.
Монтируется и работает нормально командойmount /dev/mmcblk0p1 /media/sdcardНо хотелось бы ее постоянно примонтировать через fstab.
Делал так/dev/mcblk0p1 /media/sdcard  ext4 noatime,errors=remount-ro,nofail 0 0и так/dev/mcblk0p1 /media/sdcardРезультат - загрузка зависает с сообщением из квадратиков (см. картинку) и потом только через консоль восстановления удалять эту строку в fstab.

Подозреваю 2 варианта:
1) я что-то делаю не так или
2) какой-то драйвер картридера не успевает подгрузиться.
Что можете посоветовать?
Где посмотреть это сообщение об ошибке? И как исправить?
(Нажмите, чтобы показать/скрыть)
Изображения в виде вложений в сообщения не приветствуются. Вложение извлечено из сообщения и удалено. Изображение извлечено из вложения, перезалито, и оформлено в соответствии с предписаниями Руководства.
  --zg_nico


ТС не появлялся на Форуме более трех месяцев по состоянию на 19/03/2021 (последняя явка: 18/05/2020). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 19 Март 2021, 14:13:29 от zg_nico »

Оффлайн ALiEN175

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4708
  • Capture the truth
    • Просмотр профиля
mount /dev/mmcblk0p1 /media/sdcard
После этого:
mount | grep mmcВывод - на форум.

Пользователь добавил сообщение 17 Май 2020, 03:30:47:
и так
/dev/mcblk0p1 /media/sdcard
точно не так.
ASUS P5K-C :: Intel Xeon E5450 :: 8 GB RAM :: Nvidia 8500GT :: XFCE
SAMSUNG N150 :: Intel Atom N450 :: 2 GB RAM :: Intel GMA3150 :: XFCE

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2429
    • Просмотр профиля
Ещё нужен вывод blkid с установленной в картридер картой

Оффлайн kdt

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Цитировать
mount /dev/mmcblk0p1 /media/sdcard

Делал так
/dev/mcblk0p1 /media/sdcard  ext4 noatime,errors=remount-ro,nofail 0 0
и так
/dev/mcblk0p1 /media/sdcard
В посте ошибся или во fstab тоже так было?

Оффлайн alexvu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
В посте ошибся или во fstab тоже так было?
Так было в fstab! Спасибо!!!
Наверное, проблема решена.

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2429
    • Просмотр профиля
https://help.ubuntu.ru/wiki/%D0%BC%D0%BE%D0%BD%D1%82%D0%B8%D1%80%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5_%D1%80%D0%B0%D0%B7%D0%B4%D0%B5%D0%BB%D0%BE%D0%B2
Чтобы таких проблем не возникало лучше монтировать по uuid. Например добавите еще одну флешку и идентификатор может слететь.

Оффлайн alexvu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Чтобы таких проблем не возникало лучше монтировать по uuid.
А как тогда сделать, чтобы при замене карты на другую она монтировалась туда же? (это я на всякий случай, вдруг карта испортится).

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4448
    • Просмотр профиля
Цитировать
чтобы при замене карты на другую она монтировалась туда же?
Есть еще вариант - монтировать по метке тома. По мне, так самый удобный вариант.
Вообще, если назначена метка тома, то по умолчанию будет монтироваться в /media/<user_name>/<metka_toma>

 

Страница сгенерирована за 0.076 секунд. Запросов: 24.