Форум русскоязычного сообщества Ubuntu


Автор Тема: Обновления - это чистый вред от "двоешников", или что-то в этом есть ?  (Прочитано 5477 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн valentin630

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
ядро 4.15.0-96 работало стабильно. Пришло обновление ряда приложений и ядра впридачу на 4.15.0-101. Во время обновления произошла какая-то ошибка, о которой было предложено сообщить кому надо для искоренения этой пакости.
Отослал, после чего возникло сообщение, что, мол, это известный баг, мол смотри где-то что-то о чем-то(что за баг не было сказано).
После перезагрузки отвалился интернет.
lspci его видит, но ifconfig об этом не знает. Ладно, думаю установлю driver, и будет мне опять счастье... Установил с флэшки
r8168-dkms_8.048.02-1_all.deb, перегружаю, а оно не грузится и висит...
Гружу с предыдущим ядром 4.15.0-96, а оно тоже перестало грузиться!
Пробую 4.15.0-91 - грузится, но ifconfig опять ничего о контроллере не знает.
Было еще ядро 4.4.0-179, и, о чудо (!), система заработала, позволив вам рассказать этот детектив.
Я полностью сконфужен, потому что не знаю, что дальше делать,
имею ввиду, какая правильная политика с апдейтами, и надо ли что-то предпринять, кроме искоренения "кривых" ядер линейки 4.15 из загрузчика?
P.S.16.04
« Последнее редактирование: 23 Май 2020, 14:01:04 от valentin630 »

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Ubuntu 16.04 изначально поставляется с ядром 4.4. В который раз убеждаюсь, что HWE только вредит. Не нужно устанавливать новые стеки от вышедших позднее дистрибутивов.

Оффлайн valentin630

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
Не нужно устанавливать новые стеки от вышедших позднее дистрибутивов.
Непонятно, но здорово!
А на доступном простому юзеру языке, можно?
Ну типа, делай раз, не делай два..

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1268
    • Просмотр профиля
А на доступном простому юзеру языке, можно?
Всё просто, работает не трогай. Обновлениями занимаются подвисшие-повёрнутые на них. Наверное раньше винду постоянно обновляли, всегда ждут новую прошивку на смартфоне, на спутниковом ресивере, на Андроид приставке и прочем железе.
Тут есть пользователи, которые установив крайний дистрибутив ежедневно сидят и ждут не обновится-ли что, вдруг ну хоть какая-то малость прикатит. Если дождались, писаются кипятком от радости, всем сообщают, если нашли баг отписывают. Ну хобби это... голова так у них работает. Вот и ты похоже подсел на обновления, раз пользуешся. Ты этого хотел и получил по полной, будет чем занятся.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
А на доступном простому юзеру языке, можно?
Можно, само собой.. Если собираетесь устанавливать, к примеру, Ubuntu 16.04, то лучше использовать диск с версией 16.04 или 16.04.1, но не 16.04.2 и т.д., т к. в них идут ядра от дистрибутивов, вышедших позднее.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3058
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
Тут есть пользователи, которые установив крайний дистрибутив ежедневно сидят и ждут не обновится-ли что, вдруг ну хоть какая-то малость прикатит.
vladimirzhuravlev, какой дистрибутив вы назвал крайним в своём комменте - 20.04 или 20.10, к которому тоже имеется уже большой интерес? Но сейчас не об этом. Вы понимаете, призывать ТС от обновлений совсем - это ещё больший грех, чем журить тестировщиков 20.10.

Тут скорее будет полезнее направить ТС на выяснение причины неудавшегося обновления. Знаете, бывает так, что на диске мог просто сбойнуть сектор, один или два. И тогда обновление не проходит нормально.

Я странен, а не странен кто ж? (С)

Оффлайн valentin630

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
Всё просто, работает не трогай.
Как-то примитивно, а не просто. Идут приложения, где правят баги и дырки.
Железо у меня новое, старые ядра даже температуру СПУ не показывают, почему я и менял линейку ядра. Вот опять правильная температура СПУ из gkrellm'а исчезла. Иногда у меня по 12 процессов одновременно пашут достаточно долго - как узнать, что пора пыль сдувать с кулера?
Поэтому, я бы очень приветствовал

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1439
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Железо у меня новое, старые ядра даже температуру СПУ не показывают, почему я и менял линейку ядра. Вот опять правильная температура СПУ из gkrellm'а исчезла.
Ну так не меняй линейку ядра, возьми 18.04 или 18.04.1.

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1268
    • Просмотр профиля
какой дистрибутив вы назвал крайним в своём комменте
Да речь не о каком-то дистрибутиве и я когда писал сообщение понимал, что без критики не обойдётся. То-же самое (траблы-баги) встречаются после обновлений в винде, на Андроидной ТВ приставке хаймеди и прочем железе. Я при наличии времени свободного довольно плотно сижу на нескольких форумах и вижу что творится с разными ОС и прошивками Андроидными на различных железках. Имея такие-же и не обновляясь могу сравнивать как у меня всё работает и как у обновляющих.
А ТС сам себе противоречит "ядро 4.15.0-96 работало стабильно" - "Идут приложения, где правят баги и дырки". Нужно выбирать или шашечки или ехать. Багов не было, если были дырки в защите, то как узнал, что утекло ? Это просто не здоровые фантазии на пустом месте.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
кроме искоренения "кривых" ядер линейки 4.15 из загрузчика?
Ядра не кривые. Это у вас что-то кривое в системе.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн valentin630

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
Это у вас что-то кривое в системе.
Было не кривое, но стало кривым после обновления, после очень кривого обновления, такого, что и предыдущие ядра затронуло(как такое вообще возможно?!) Я сообщил факты, только факты, а вы как одна женщина, не очень сильно знакомая с тем же вордом, пользуясь моим компом, говорит, что это "мой ворд" так работает, когда не знает той или  элементарной вещи и ее природы
Вопрос: как мне вернуться сейчас к тому 96му ядру из линейки 4.15?


Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
Было не кривое, но стало кривым после обновления, после очень кривого обновления
А ничего, что у миллионов людей это обновление совсем не кривое? Ну да ладно. Оставайтесь со своим мнением.

Факты, только факты...только неполные. Система работала, пришло обновление - перестала работать. Отсюда вывод: обновление кривое.

Но на самом деле не так обстоят дела.
Вопрос: как мне вернуться сейчас к тому 96му ядру из линейки 4.15?
Да ничего нет проще. Загрузиться через grub с этим ядром и удалить то, с которым проблемы. Но проблемы не с ядром, а с тем, что у вас стоит несовместимое с этим ядром. А может вообще не в ядре дело, раз со старым тоже не работет. ;-)

Пользователь добавил сообщение 23 Май 2020, 23:24:11:
bezbo,
В мейнлайне этих ядер нет.
« Последнее редактирование: 23 Май 2020, 23:26:37 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн valentin630

  • Автор темы
  • Участник
  • *
  • Сообщений: 165
    • Просмотр профиля
у миллионов людей это обновление совсем не кривое?
Откуда статистика, не поделитесь источником?
Сейчас посмотрел, какое ядро стоит на другом моем компе, загородном. Там Ryzen 2600, на этом 1600. Материнки разные, но на одинаковом чип-сете.
Там Ubuntu 16.04.6 LTS (GNU/Linux 4.4.0-178-generic x86_64)
Здесь 16.04.6 LTS (GNU/Linux 4.4.0-179-generic x86_64,
Там видно tC CPU, а здесь те же сенсоры дают постоянную температуру в 16С.
Да, а у "миллионов" все нормально... поэтому сам и виноват, такая логика?
Можно, конечно, списывать все на "халявность" ОС - мол, не платил, то и требовать, чтобы убрали безответственных троешников за свое "прикручивание"
апдейтов, не имеешь права. Такая позиция тоже имеет право на жизнь, тем более здесь она как бы лезет из ушей многих "корифеев" линукса - мало сам разбираешься, значит, лодырь.

Пользователь добавил сообщение 24 Май 2020, 09:18:04:
В мейнлайне этих ядер нет.
Я создавал пост, чтобы проинформировать и узнать опыт других, т.е. их политику
по поводу обновлений: что принимать, что отвергать. А в главной ли очереди те ядра, или они левые, не юзеру же обычному самому разбираться, если они "официально" подсовываются ему в обновлениях?
« Последнее редактирование: 24 Май 2020, 09:18:04 от valentin630 »

Оффлайн damix

  • Активист
  • *
  • Сообщений: 539
    • Просмотр профиля
Присоединяюсь к вопросу. Можно ли как-то так поставить/настроить Ubuntu, чтобы обновления прилетали только с исправлениями багов, но не с новыми багами? Я хочу пользоваться стабильным софтом, проверенным временем.
Если собираетесь устанавливать, к примеру, Ubuntu 16.04, то лучше использовать диск с версией 16.04 или 16.04.1, но не 16.04.2 и т.д., т к. в них идут ядра от дистрибутивов, вышедших позднее.
Т.е. все с ног на голову в этой Ubuntu. Минорная версия же должна закрывать баги.
valentin630, я на данный момент подозреваю, что нормального решения в Ubuntu нет. Но можно взять абы какую версию, (лучше LTS просто чтобы поддержки не лишаться каждый год), найти все программы, которые не работают и обновить их до версий, которые работают, всё. Но для этого придется брать их из сторонних репозиториев или даже из гита, потому что дебильная система пакетов.

 

Страница сгенерирована за 0.112 секунд. Запросов: 26.