Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не могу восстановить grub2 (lvm)  (Прочитано 589 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн CALL|KA

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
  • Водитель НЛО
    • Просмотр профиля
Не могу восстановить grub2 (lvm)
« : 15 Июнь 2020, 16:37:14 »
Дорого времени суток.
Друзья, помогите, пожалуйста, с восстановление Grub2. Почему и как я его прибил это моя постыдная история  ;D
По разделам картина выглядит примерно так:
sda1 - boot раздел
sda2 - группа разделов LVM
Как правильно восстановить загрузчик используя живой образ?
Пробовал в такой последовательностиmkdir -p /mnt/chrootdir/boot
mount /dev/sda1 /mnt/chrootdir/boot
mount /dev/vg_1/root_lv /mnt/chrootdir
mount --rbind /dev  /mnt/chrootdir/dev
mount --rbind /proc /mnt/chrootdir/proc
mount --rbind /sys  /mnt/chrootdir/sys
mount --rbind /usr  /mnt/chrootdir/usr
chroot /mnt/chrootdir
grub-install --root-directory=/mnt/chrootdir/ /dev/sda
exit
umount /mnt/chrootdir/sys /mnt/chrootdir/proc /mnt/chrootdir/dev /mnt/chrootdir/usr
umount /dev/mapper/vg_1-root_lv  /mnt/chrootdir/boot
reboot
груб запускается, но видна только его командная строка и все. Меню не отображается от слова вообще.
В какую сторону копать и где мой косяк?
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 15 Июнь 2020, 19:05:00 от zg_nico »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13698
  • Xubuntu 18.04
    • Просмотр профиля
Re: Не могу восстановить grub2 (lvm)
« Ответ #1 : 15 Июнь 2020, 16:47:45 »
Неправильно делаете. Не надо было создавать лишних директорий.
WIKI: Восстановление GRUB
Второй способ.
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 15 Июнь 2020, 19:06:18 от zg_nico »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн CALL|KA

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
  • Водитель НЛО
    • Просмотр профиля
Re: Не могу восстановить grub2 (lvm)
« Ответ #2 : 15 Июнь 2020, 17:15:38 »

Я смонтировал boot, потом корень, далее примонтировал dev и пр., chroot'улся в нерабочую систему и попытался установить grub. Единственная разница это параметры
у меня --root-directory=/mnt/chrootdir/ 
в статье --recheck --no-floppy

Проблема в этом?

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Не могу восстановить grub2 (lvm)
« Ответ #3 : 15 Июнь 2020, 19:03:29 »
sda1 - boot раздел
sda2 - группа разделов LVM
Ну более-менее понятно. Не понятно начинается здесь:
Цитировать
Код: (bash) [Выделить]
mkdir -p /mnt/chrootdir/boot  #создали каталог /mnt/chrootdir/boot
mount /dev/sda1 /mnt/chrootdir/boot  #смонтировали устройство sda1 в точку /mnt/chrootdir/boot
mount /dev/vg_1/root_lv /mnt/chrootdir #смонтировали нечто, чего я не очень понимаю, и что называется /dev/vg_1/root_lv в точку  /mnt/chrootdir
В связи с последним два вопроса:
1. Что за зверь этот /dev/vg_1/root_lv (я не сталкивался, допускаю, но пояснить было бы неплохо)
2. при таком порядке монтирования у меня нет уверенности, что после того, как в третьей строчке расквартирован этот самый /dev/vg_1/root_lv в /mnt/chrootdir, в точке /mnt/chrootdir/boot остается ранее смонтированный туда /dev/sda1. Вы бы показали вообще lsblk -o NAME,MOUNTPOINT,LABEL,UUID
blkid
Хоть как-то бы отразило картину того, как у Вас разбиты диски. Плюс пара вопросов: Система стояла в EFI или в Legacy? На каком именно томе находился корневой раздел системы?
« Последнее редактирование: 15 Июнь 2020, 19:07:12 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн CALL|KA

  • Автор темы
  • Любитель
  • *
  • Сообщений: 96
  • Водитель НЛО
    • Просмотр профиля
Re: Не могу восстановить grub2 (lvm)
« Ответ #4 : 02 Сентябрь 2020, 12:51:05 »
Блин, забыл в теме отписаться.
zg_nico, спасибо за помощь, все починил. Проблема была в последовательности монтирования.

 

Страница сгенерирована за 0.073 секунд. Запросов: 25.