Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Плохо работает подключение [Решено]  (Прочитано 796 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vova1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Консольные команд с подключением не работают с первого раза.
Код: (html5) [Выделить]
vova@vova-Z68MA-D2H-B3:~|⇒ ping google.com
ping: google.com: Temporary failure in name resolution
vova@vova-Z68MA-D2H-B3:~|⇒ ping google.com
PING google.com (216.58.209.14) 56(84) bytes of data.

git clon также срабатывает со второй попытки
Код: (html5) [Выделить]
ssh: Could not resolve hostname github.com: Temporary failure in name resolution
fatal: Could not read from remote repository. (лог ошибки)

в браузере странички тоже плохо грузятся

на другой ОС и на другом устройстве подключённому к роутеру проблем нет

установлена Ubuntu 20,04

подскажете что стоит попробовать
 (капча при вкладке сообщение тоже говорит проверте коннект)

ТС не появлялся на Форуме более трех месяцев по состоянию на 19/03/2021 (последняя явка: 08/07/2020). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 19 Март 2021, 14:22:32 от zg_nico »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13695
  • Xubuntu 18.04
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #1 : 23 Июнь 2020, 08:52:30 »
vova1,
Абсолютно никакой информации не приведено, чтобы что-то посоветовать. Как хоть подключен и куда? Что за железо?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ennepath

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #2 : 23 Июнь 2020, 09:04:50 »
Похоже на проблему с dns. Выполни и покажи вывод:
ping 8.8.8.8 -c 4
dig google.com

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13695
  • Xubuntu 18.04
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #3 : 23 Июнь 2020, 09:22:48 »
Похоже на проблему с dns.
На мой взгляд похоже на потери пакетов. Я с таким сталкивался на сетевухах Реалтек определенных версия с определенными драйверами.
Если бы dns не работал, то он бы не работал. А когда работает через раз, то это обычно потери пактов.
Могут быть конечно потери на стороне dns сервера, но это маловероятно.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн vova1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #4 : 23 Июнь 2020, 21:43:22 »
Похоже на проблему с dns. Выполни и покажи вывод:
ping 8.8.8.8 -c 4
dig google.com

от ответ от консоли
Меня смущает пинг
Код: (html5) [Выделить]
vova@vova-Z68MA-D2H-B3:~$ ping 8.8.8.8 -c 4
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=118 time=51.4 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=118 time=64.3 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=118 time=51.5 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=118 time=178 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 51.391/86.295/177.975/53.192 ms
vova@vova-Z68MA-D2H-B3:~$ ping 8.8.8.8 -c 4
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=118 time=667 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=118 time=919 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=118 time=1280 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=118 time=1801 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3010ms
rtt min/avg/max/mdev = 666.986/1166.622/1800.738/426.009 ms, pipe 2
vova@vova-Z68MA-D2H-B3:~$ ping 8.8.8.8 -c 4
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=118 time=212 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=118 time=89.7 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=118 time=161 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=118 time=97.3 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 89.705/139.912/211.844/49.857 ms
vova@vova-Z68MA-D2H-B3:~$

Цитировать
Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла. Длинные гиперссылки следует оформлять при помощи тега [url=]...[/url]

  --Aleksandru
« Последнее редактирование: 23 Июнь 2020, 21:51:07 от Aleksandru »

Оффлайн ALiEN175

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4708
  • Capture the truth
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #5 : 24 Июнь 2020, 04:27:14 »
vova1, подключение по wi-fi?
ASUS P5K-C :: Intel Xeon E5450 :: 8 GB RAM :: Nvidia 8500GT :: XFCE
SAMSUNG N150 :: Intel Atom N450 :: 2 GB RAM :: Intel GMA3150 :: XFCE

Оффлайн vova1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #6 : 24 Июнь 2020, 08:20:16 »
подключение по wi-fi?
Кабель

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13695
  • Xubuntu 18.04
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #7 : 24 Июнь 2020, 09:34:03 »
Кабель
Дайте вывод

lspci -knn | grep Eth -A3
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн vova1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #8 : 24 Июнь 2020, 12:16:53 »

Дайте вывод

lspci -knn | grep Eth -A3

(Нажмите, чтобы показать/скрыть)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13695
  • Xubuntu 18.04
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #9 : 24 Июнь 2020, 12:53:54 »
Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
Всё ясно. Поблема в том, что некоторые ревизии этого сетевого адаптера реально плохо работают на ядре 5.4, которое используется в 20.04.

Есть два способа решить эту проблему. Первый простой, но может не помочь.

1) Установить другой драйвер для этого адаптера, поставляемый Реалтеком. Для этого выполните в терминали

sudo apt install r8168-dkmsНо проблема видимо глубже в ядре, и не всегда помогает.

2) Использовать другое ядро из мейнлайна. Можно более свежее.

На ядре 5.3, которое в Ubuntu 18.04 сейчас используется всё нормально. Я надеюсь, что пофиксят до выхода 20.04.1 этот баг. У меня тоже Реалтек. Это один из самых популярных адаптеров. И у меня та же самая ревизия. Если не пофиксят, то нельзя будет обновляться.

Очень прошу отписаться по поводу r8168-dkms. У меня шкурный интерес. Я пока не хочу устанавливать 20.04 и проверять. Если вам поможет, то тогда я буду знать, что помогает.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн vova1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #10 : 24 Июнь 2020, 19:44:26 »
Очень прошу отписаться по поводу r8168-dkms. У меня шкурный интерес. Я пока не хочу устанавливать 20.04 и проверять. Если вам поможет, то тогда я буду знать, что помогает.
Не помогло. но все равно спасибо за помощь

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13695
  • Xubuntu 18.04
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #11 : 24 Июнь 2020, 19:56:40 »
Не помогло. но все равно спасибо за помощь
Попробуйте сделать liveUSB с 18.04 и посмотреть как там работает. Должно быть нормально. Если это так, то больше копать некуда. Баг в ядре.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн vova1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #12 : 26 Июнь 2020, 22:33:36 »
Не помогло. но все равно спасибо за помощь
Попробуйте сделать liveUSB с 18.04 и посмотреть как там работает. Должно быть нормально. Если это так, то больше копать некуда. Баг в ядре.

установил 18,04 полет нормальный

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13695
  • Xubuntu 18.04
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #13 : 26 Июнь 2020, 22:53:08 »
установил 18,04 полет нормальный
Ну тогда надо пока на нем посидеть. А то я думал скоро обновиться. Но нафига мне этот гимор?
Я в личке не консультирую. Вопросы задавайте на форуме.

Онлайн andytux

  • Старожил
  • *
  • Сообщений: 4444
    • Просмотр профиля
Re: Плохо работает подключение
« Ответ #14 : 27 Июнь 2020, 05:21:04 »
"И рыбку съесть и на ..."
Цитировать
установил 18,04 полет нормальный
Из 18.04 скопировать ядро и модули в 20.04 и запускать с этим ядром. Возможно заработает. Когда заработает в новых ядрах, то просто удалить.

 

Страница сгенерирована за 0.087 секунд. Запросов: 25.