Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Debian 8 и curl  (Прочитано 2043 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pogreb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Debian 8 и curl
« : 30 Июня 2020, 10:20:35 »
Добрый день!
Помогите разобраться в вопросе.
Есть ВМ с ОС - Linux unifi 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 GNU/Linux
На данной ВМ работает только одна роль Unifi Controller.
Планирую обновить версию Контроллера с 5.7 на 5.13
И мне установщик говорит, что не установлен curldebian jessie 8 curl Ош http://httpredir.debian.org/debian/ jessie/main php5-common amd64 5.6.30+dfsg-0+deb8u1 404 Not Found [IP: 151.101.38.133 80]
Ош http://httpredir.debian.org/debian/ jessie/main php5-curl amd64 5.6.30+dfsg-0+deb8u1 404 Not Found [IP: 151.101.38.133 80]
E: Не удалось получить http://httpredir.debian.org/debian/pool/main/p/php5/php5-common_5.6.30+dfsg-0+deb8u1_amd64.deb
Подскажите, пожалуйста, как мне правильно установить curl? Из репозиториев или руками?
Спасибо за ответы!
(Нажмите, чтобы показать/скрыть)
Отправлено уведомление о допущенном нарушении. Переезжаем в раздел Разговоры обо всем.
  --zg_nico
« Последнее редактирование: 30 Июня 2020, 16:14:38 от zg_nico »

Оффлайн ALiEN

  • Администратор
  • Старожил
  • *
  • Сообщений: 6828
  • 20% Cooler
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #1 : 30 Июня 2020, 10:38:01 »
1. 404 - это страница не найдена, а не curl. У вас ошибка в ссылке на репозиторий.
2. Форумом не ошиблись?
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6965
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #2 : 30 Июня 2020, 10:40:22 »
Ну понятно, из погреба со слепу не разглядел... С Дебианом здесь тебя пошлют дальше, чем в Тунис.
А если по делу, то зависит от твоих способностей, можешь ставить ручками, можешь ножками.
А думать лучше головой, чтобы не поломать систему. Бэкап конечно-же у тебя есть, так что ничего не страшно.

Оффлайн Pogreb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #3 : 30 Июня 2020, 10:47:34 »
Гуглил репозитории и менял их, в итоге вот что получаюroot@unifi:~# apt-get install curl libcurl3 libcurl3-dev php5-curl php5-mcrypt
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Note, selecting 'libcurl4-openssl-dev' instead of 'libcurl3-dev'
Уже установлена самая новая версия curl.
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
curl: Зависит: libcurl3 (= 7.38.0-4+deb8u16) но 7.38.0-4+deb8u8 будет установлен
 php5-common: Зависит: lsof но он не будет установлен
 php5-curl: Зависит: php5-common (= 5.6.30+dfsg-0+deb8u1) но 5.6.40+dfsg-0+deb8u11 будет установлен
 php5-mcrypt: Зависит: libltdl7 (>= 2.4.2) но он не будет установлен
               Зависит: libmcrypt4 но он не будет установлен
               Зависит: php5-common (= 5.6.30+dfsg-0+deb8u1) но 5.6.40+dfsg-0+deb8u11 будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
Но при этомroot@unifi:~# curl
curl: try 'curl --help' or 'curl --manual' for more information
Как мне правильно его установить и какие зависимости нужно поставить?
(Нажмите, чтобы показать/скрыть)
Отправлено уведомление о нарушении в ЛС пользователю. Исправлено форматирование. Добавлены теги.
  --zg_nico
« Последнее редактирование: 30 Июня 2020, 16:17:06 от zg_nico »

Оффлайн ALiEN

  • Администратор
  • Старожил
  • *
  • Сообщений: 6828
  • 20% Cooler
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #4 : 30 Июня 2020, 10:52:45 »
Как мне правильно его установить и какие зависимости нужно поставить?
Вы читать умеете?
Уже установлена самая новая версия curl.

Цитировать
Гуглил репозитории и менял их, в итоге вот что получаю
Догуглились. Показывайте:
apt-get -f install
apt-get update
apt-get upgrade

🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн andytux

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6965
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #5 : 30 Июня 2020, 10:54:40 »
Систему ты уже поломал.
Цитировать
Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install»
Пока не починишь, ничего ты больше не установишь. Как починить тебе сказано.

Оффлайн Pogreb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #6 : 30 Июня 2020, 10:59:39 »
root@unifi:~# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libperl4-corelibs-perl lsof
Пакеты, которые будут УДАЛЕНЫ:
  curl
НОВЫЕ пакеты, которые будут установлены:
  libperl4-corelibs-perl lsof
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 1 пакетов, и 102 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
Необходимо скачать 0 B/360 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 358 kB.
Хотите продолжить? [Д/н] д
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
  libperl4-corelibs-perl lsof
Установить эти пакеты без проверки? [y/N] y
E: Некоторые пакеты невозможно аутентифицировать
root@unifi:~# apt-get update
Игн http://mirror.yandex.ru jessie InRelease
Игн http://mirror.yandex.ru jessie-proposed-updates InRelease
В кэше http://mirror.yandex.ru jessie Release.gpg
Игн http://mirror.yandex.ru jessie-proposed-updates Release.gpg
В кэше http://mirror.yandex.ru jessie Release
Игн http://mirror.yandex.ru jessie-proposed-updates Release
Игн http://security.debian.org jessie InRelease
В кэше http://archive.debian.org jessie-backports InRelease
Игн http://httpredir.debian.org jessie InRelease
Получено:1 http://security.debian.org stretch/updates InRelease [94,3 kB]
В кэше http://ppa.launchpad.net trusty InRelease
E: Файл Release для http://archive.debian.org/debian/dists/jessie-backports/InRelease просрочен (недостоверный начиная с 496д 11ч 32мин 29с). Обновление этого репозитория производиться не будет.
root@unifi:~# apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 curl : Зависит: libcurl3 (= 7.38.0-4+deb8u16) но 7.38.0-4+deb8u5 уже установлен
 php5-common : Зависит: lsof но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
root@unifi:~#
Не рабочие репозитории я удалю, но дело же не в них
« Последнее редактирование: 30 Июня 2020, 16:17:34 от zg_nico »

Оффлайн ALiEN

  • Администратор
  • Старожил
  • *
  • Сообщений: 6828
  • 20% Cooler
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #7 : 30 Июня 2020, 11:03:43 »
дело же не в них
Как раз-таки в них! Вот этот точно удалить:

Получено:1 http://security.debian.org stretch/updates InRelease [94,3 kB]



Пользователь добавил сообщение 30 Июня 2020, 11:04:53:
В кэше http://ppa.launchpad.net trusty InRelease
Это тоже зачем?  :idiot2:
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн Pogreb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #8 : 30 Июня 2020, 11:15:29 »
Закоментировал проблемные репозитории

root@unifi:~# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
root@unifi:~# apt-get update
В кэше ftp://ftp.ru.debian.org stable InRelease
E: Драйвер для метода /usr/lib/apt/methods/https не найден.
N: Is the package apt-transport-https installed?
root@unifi:~# apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Расчёт обновлений…Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
root@unifi:~#

root@unifi:~# curl
-bash: /usr/bin/curl: Нет такого файла или каталога


Сам файл source.list

#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

#deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main

# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ jessie main contrib non-free
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ jessie main contrib non-free

#deb http://ftp.de.debian.org/debian/ jessie/updates main contrib non-free
#deb-src http://ftp.de.debian.org/debian/ jessie/updates main contrib non-free


#deb http://httpredir.debian.org/debian jessie main
#deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
#deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

## Debian/Ubuntu
# stable => unifi4
deb http://www.ubnt.com/downloads/unifi/debian unifi4 ubiquiti
deb http://www.ubnt.com/downloads/unifi/debian unifi5 ubiquiti

deb http://www.ubnt.com/downloads/unifi/debian stable ubiquiti

# oldstable => unifi3
deb http://www.ubnt.com/downloads/unifi/debian unifi3 ubiquiti
deb http://www.ubnt.com/downloads/unifi/debian oldstable ubiquiti

# Официальный репозиторий Debian
deb ftp://ftp.ru.debian.org/debian/ stable main contrib non-free
# Debian Squeeze - обновления
deb ftp://ftp.ru.debian.org/debian squeeze-updates main
# Debian Squeeze - обновления безопасности
#deb ftp://ftp.ru.debian.org/debian-security squeeze/updates main non-free contrib
# Debian Squeeze - backports
deb ftp://ftp.ru.debian.org/debian-backports squeeze-backports main contrib


# Jessie
     
#deb http://security.debian.org/ jessie updates main
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ stretch/updates main
     
#deb http://mirror.yandex.ru/debian jessie main
#deb-src http://mirror.yandex.ru/debian jessie main
     
     
#deb http://mirror.yandex.ru/debian/ jessie-proposed-updates main non-free contrib
#deb-src http://mirror.yandex.ru/debian/ jessie-proposed-updates main non-free contrib
     
# Backports
#deb http://mirror.yandex.ru/debian jessie-backports main contrib non-free
#deb-src http://mirror.yandex.ru/debian jessie-backports main contrib non-free
     
# Multimedia Официальный сервер
#доступны пакеты для stable testing, unstable, stable-backports, experimental
#deb http://www.deb-multimedia.org jessie main non-free

#deb http://archive.debian.org/debian/ jessie-backports main contrib non-free
#deb-src http://archive.debian.org/debian/ jessie-backports main contrib non-free

#deb http://security.debian.org/debian-security jessie/updates main

« Последнее редактирование: 30 Июня 2020, 16:18:10 от zg_nico »

Dzhoser

  • Гость
Re: Debian 8 и curl
« Ответ #9 : 30 Июня 2020, 11:54:20 »
Pogreb, покажите
cat /etc/issuecat /etc/apt/sources.list

Оффлайн Pogreb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #10 : 30 Июня 2020, 11:55:42 »
root@unifi:~# cat /etc/issue
Debian GNU/Linux 8 \n \l

root@unifi:~# cat /etc/apt/sources.list

#

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main
#deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 NETINST Binary-1 20160917-14:20]/ jessie main
# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ jessie main contrib non-free
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ jessie main contrib non-free

#deb http://ftp.de.debian.org/debian/ jessie/updates main contrib non-free
#deb-src http://ftp.de.debian.org/debian/ jessie/updates main contrib non-free


#deb http://httpredir.debian.org/debian jessie main
#deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
#deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

## Debian/Ubuntu
# stable => unifi4
deb http://www.ubnt.com/downloads/unifi/debian unifi4 ubiquiti
deb http://www.ubnt.com/downloads/unifi/debian unifi5 ubiquiti

deb http://www.ubnt.com/downloads/unifi/debian stable ubiquiti

# oldstable => unifi3
deb http://www.ubnt.com/downloads/unifi/debian unifi3 ubiquiti
deb http://www.ubnt.com/downloads/unifi/debian oldstable ubiquiti

# Официальный репозиторий Debian
deb ftp://ftp.ru.debian.org/debian/ stable main contrib non-free
# Debian Squeeze - обновления
deb ftp://ftp.ru.debian.org/debian squeeze-updates main
# Debian Squeeze - обновления безопасности
#deb ftp://ftp.ru.debian.org/debian-security squeeze/updates main non-free contrib
# Debian Squeeze - backports
deb ftp://ftp.ru.debian.org/debian-backports squeeze-backports main contrib

# Jessie

#deb http://security.debian.org/ jessie updates main
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ stretch/updates main

#deb http://mirror.yandex.ru/debian jessie main
#deb-src http://mirror.yandex.ru/debian jessie main


#deb http://mirror.yandex.ru/debian/ jessie-proposed-updates main non-free contrib
#deb-src http://mirror.yandex.ru/debian/ jessie-proposed-updates main non-free contrib

# Backports
#deb http://mirror.yandex.ru/debian jessie-backports main contrib non-free
#deb-src http://mirror.yandex.ru/debian jessie-backports main contrib non-free

# Multimedia Официальный сервер
#доступны пакеты для stable testing, unstable, stable-backports, experimental
#deb http://www.deb-multimedia.org jessie main non-free

#deb http://archive.debian.org/debian/ jessie-backports main contrib non-free
#deb-src http://archive.debian.org/debian/ jessie-backports main contrib non-free

#deb http://security.debian.org/debian-security jessie/updates main
« Последнее редактирование: 30 Июня 2020, 16:19:40 от zg_nico »

Dzhoser

  • Гость
Re: Debian 8 и curl
« Ответ #11 : 30 Июня 2020, 12:13:36 »
 Приведите source.list к виду
# - Основные репозитории, обновления,  безопасность, свободные и несвободные пакеты

deb http://ftp.ru.debian.org/debian stable main contrib non-free
deb-src http://ftp.ru.debian.org/debian stable main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# - Multimedia

deb http://www.deb-multimedia.org/ jessie main non-free
Последний репозиторий по желанию.
sudo apt-get install deb-multimedia-keyring команда для последнего репозитория.
sudo apt install -fsudo apt install --reinstall curl

Оффлайн Pogreb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #12 : 30 Июня 2020, 12:42:20 »
root@unifi:~# apt-get install deb-multimedia-keyring
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет deb-multimedia-keyring
root@unifi:~# apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 14 пакетов не обновлено.
root@unifi:~# apt install --reinstall curl
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
НОВЫЕ пакеты, которые будут установлены:
  curl
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 14 пакетов не обновлено.
Необходимо скачать 200 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 333 kB.
Ош  http://security.debian.org/ jessie/updates/main curl amd64 7.38.0-4+deb8u5
  404  Not Found [IP: 151.101.0.204 80]
E: Не удалось получить http://security.debian.org/pool/updates/main/c/curl/curl_7.38.0-4+deb8u5_amd64.deb  404  Not Found [IP: 151.101.0.204 80]

E: Невозможно получить некоторые архивы, вероятно надо запустить apt-get update или попытаться повторить запуск с ключом --fix-missing
root@unifi:~# curl
-bash: /usr/bin/curl: Нет такого файла или каталога[/b]

root@unifi:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=109 time=17.4 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=109 time=17.2 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=109 time=17.4 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 17.262/17.386/17.476/0.090 ms


root@unifi:~# ping 151.101.0.204
PING 151.101.0.204 (151.101.0.204) 56(84) bytes of data.
64 bytes from 151.101.0.204: icmp_seq=1 ttl=58 time=38.7 ms
64 bytes from 151.101.0.204: icmp_seq=2 ttl=58 time=38.7 ms
64 bytes from 151.101.0.204: icmp_seq=3 ttl=58 time=38.5 ms
^C
--- 151.101.0.204 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 38.598/38.685/38.758/0.236 ms


sourse.list
# - Основные репозитории, обновления,  безопасность, свободные и несвободные пакеты

deb http://ftp.ru.debian.org/debian stable main contrib non-free
deb-src http://ftp.ru.debian.org/debian stable main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# - Multimedia

deb http://www.deb-multimedia.org/ jessie main non-free
« Последнее редактирование: 30 Июня 2020, 16:20:23 от zg_nico »

Dzhoser

  • Гость
Re: Debian 8 и curl
« Ответ #13 : 30 Июня 2020, 12:54:12 »
sudo apt update

Оффлайн Pogreb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Debian 8 и curl
« Ответ #14 : 30 Июня 2020, 13:02:43 »
sudo apt update
W: Ошибка GPG: http://www.deb-multimedia.org jessie InRelease: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 5C808C2B65558117

Ошибка при добавлении ключа

root@unifi:~# apt-key adv --recv-keys --keyserver http://www.deb-multimedia.org 5C808C2B65558117
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.TbIZDCLRzN --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --recv-keys --keyserver http://www.deb-multimedia.org 5C808C2B65558117
gpg: запрашиваю ключ 65558117 с http сервера www.deb-multimedia.org
gpgkeys: no key data found for http://www.deb-multimedia.org/
gpg: не найдено данных формата OpenPGP.
gpg: Всего обработано: 0


root@unifi:~# apt upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Расчёт обновлений…Следующие пакеты устанавливались автоматически и больше не требуются:
  distro-info-data docutils-common iso-codes libasprintf0c2 libcurl3 libgdbm-compat4 libperl4-corelibs-perl libpng12-0 libuuid-perl libxfont1 libzstd1 lsb-release python-apt-common python-asn1crypto python-certifi python-cffi-backend
  python-cryptography python-defusedxml python-docutils python-enum34 python-idna python-ipaddress python-openssl python-requests python-roman python-soappy python-urllib3 python-wstools python3-certifi python3-chardet
  python3-debianbts python3-httplib2 python3-idna python3-pkg-resources python3-pycurl python3-pysimplesoap python3-requests python3-six python3-urllib3 tcpd
Для их удаления используйте «apt-get autoremove».
Готово
НОВЫЕ пакеты, которые будут установлены:
  apparmor binutils-common binutils-x86-64-linux-gnu bzip2 dirmngr e2fsprogs-l10n fdisk file firmware-linux-free gcc-8-base gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm initramfs-tools-core
  libapparmor1 libargon2-1 libasound2 libasound2-data libassuan0 libbinutils libc-l10n libcom-err2 libcryptsetup12 libdns-export1104 libefiboot1 libefivar1 libelf1 libevent-2.1-6 libext2fs2 libfastjson4 libfdisk1 libgdbm6
  libgnutls-dane0 libgnutls30 libgpg-error-l10n libhogweed4 libidn2-0 libip4tc0 libip6tc0 libiptc0 libisc-export1100 libjansson4 libjson-c3 libksba8 libldap-common liblognorm5 liblz4-1 libmagic-mgc libmagic1 libmpdec2 libncurses6
  libncursesw6 libnetfilter-conntrack3 libnettle6 libnftables0 libnftnl11 libnghttp2-14 libnpth0 libnss-systemd libpam-systemd libpcre2-8-0 libpng16-16 libprocps7 libpsl5 libpython2-stdlib libpython3-stdlib libpython3.7-minimal
  libpython3.7-stdlib libreadline7 libseccomp2 libssl1.1 libtinfo6 libunbound8 libunistring2 libusb-1.0-0 libxrender1 libxtables12 linux-image-4.19.0-9-amd64 nftables openjdk-11-jre-headless pigz pinentry-curses publicsuffix
  python-asn1crypto python-certifi python-cffi-backend python-cryptography python-enum34 python-httplib2 python-idna python-ipaddress python-openssl python-pycurl python-pysimplesoap python-requests python-urllib3 python2
  python2-minimal python3 python3-minimal python3.7 python3.7-minimal usb.ids usbutils xxd xz-utils
Пакеты, которые будут оставлены в неизменном виде:
  apt apt-utils gcc-4.9-base groff-base libgoogle-perftools4 liblocale-gettext-perl libstdc++6 libtcmalloc-minimal4 libtext-charwidth-perl libtext-iconv-perl libuuid-perl libxml2 lm-sensors perl perl-base perl-modules python-reportbug
  reportbug telnet tzdata
Пакеты, которые будут обновлены:
  acl acpi acpi-support-base acpid adduser base-files base-passwd bash bash-completion binutils bsdmainutils bsdutils busybox ca-certificates ca-certificates-java console-setup console-setup-linux coreutils cpio cron dash dbus debconf
  debconf-i18n debian-archive-keyring debianutils default-jre-headless diffutils discover dmidecode dmsetup docutils-common dpkg e2fslibs e2fsprogs eject exim4 exim4-base exim4-config exim4-daemon-light findutils fontconfig-config
  fonts-dejavu-core gettext-base gnupg gpgv grep grub-common grub-pc grub-pc-bin grub2-common gsfonts gsfonts-x11 gzip hostname ifupdown init init-system-helpers initramfs-tools initscripts insserv installation-report iproute2 iptables
  iputils-ping isc-dhcp-client isc-dhcp-common java-common jsvc kbd keyboard-configuration klibc-utils kmod laptop-detect less libacl1 libapt-inst1.5 libapt-pkg4.12 libasyncns0 libattr1 libaudit-common libaudit1 libavahi-client3
  libavahi-common-data libavahi-common3 libblkid1 libbsd0 libbz2-1.0 libc-bin libc6 libcap-ng0 libcap2 libcap2-bin libcomerr2 libcommons-daemon-java libcups2 libcurl3 libcurl3-gnutls libdb5.3 libdbus-1-3 libdebconfclient0
  libdevmapper1.02.1 libdiscover2 libdns-export100 libedit2 libestr0 libexpat1 libffi6 libflac8 libfontconfig1 libfontenc1 libfreetype6 libfuse2 libgcc1 libgcrypt20 libglib2.0-0 libglib2.0-data libgmp10 libgnutls-deb0-28
  libgnutls-openssl27 libgpg-error0 libgpm2 libgssapi-krb5-2 libice6 libicu52 libidn11 libirs-export91 libisc-export95 libisccfg-export90 libjpeg62-turbo libjson-c2 libk5crypto3 libkeyutils1 libklibc libkmod2 libkrb5-3 libkrb5support0
  liblcms2-2 libldap-2.4-2 liblzma5 libmnl0 libmount1 libncurses5 libncursesw5 libnetfilter-acct1 libnewt0.52 libnfnetlink0 libnspr4 libnss3 libogg0 libp11-kit0 libpam-modules libpam-modules-bin libpam-runtime libpam0g libpcap0.8
  libpci3 libpcre3 libpcsclite1 libperl4-corelibs-perl libpipeline1 libpopt0 libprocps3 libpulse0 libpython-stdlib libpython2.7-minimal libpython2.7-stdlib librtmp1 libsasl2-2 libsasl2-modules libsasl2-modules-db libsctp1 libselinux1
  libsemanage-common libsemanage1 libsepol1 libslang2 libsm6 libsmartcols1 libsndfile1 libsqlite3-0 libss2 libssh2-1 libssl1.0.0 libsystemd0 libtasn1-6 libtext-wrapi18n-perl libtinfo5 libudev1 libunwind8 libusb-0.1-4 libustr-1.0-1
  libuuid1 libvorbis0a libvorbisenc2 libwrap0 libx11-6 libx11-data libx11-xcb1 libxau6 libxcb1 libxdmcp6 libxext6 libxi6 libxmuu1 libxtst6 linux-base linux-image-amd64 lksctp-tools locales login logrotate lsb-base lsof man-db manpages
  mawk mc mc-data mime-support mount multiarch-support nano ncurses-base ncurses-bin ncurses-term net-tools netbase netcat-traditional nfacct openjdk-7-jre-headless openssh-client openssh-server openssh-sftp-server openssl os-prober
  passwd pciutils php5-common procps psmisc python python-chardet python-debian python-debianbts python-defusedxml python-docutils python-minimal python-pkg-resources python-roman python-six python-wstools python2.7 python2.7-minimal
  readline-common rsyslog sed sensible-utils sgml-base shared-mime-info startpar systemd systemd-sysv sysv-rc sysvinit-utils tar tasksel tasksel-data tcpd traceroute ucf udev unzip util-linux vim-common vim-tiny wget whiptail
  x11-common xauth xdg-user-dirs xfonts-utils xkb-data xml-core zabbix-agent zlib1g
обновлено 286, установлено 111 новых пакетов, для удаления отмечено 0 пакетов, и 20 пакетов не обновлено.
Необходимо скачать 252 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 556 MB.
Хотите продолжить? [Д/н] д
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
  librtmp1
Установить эти пакеты без проверки? [y/N] y
E: Некоторые пакеты невозможно аутентифицировать
root@unifi:~# curl
-bash: /usr/bin/curl: Нет такого файла или каталога
« Последнее редактирование: 30 Июня 2020, 16:21:23 от zg_nico »

 

Страница сгенерирована за 0.092 секунд. Запросов: 25.