Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблемма с установкой простейшей программы  (Прочитано 1182 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Artemius

  • Автор темы
  • Участник
  • *
  • Сообщений: 178
    • Просмотр профиля
Вот думал, на какой бы программе потренироваться? Решил, что на licq.
скачал и распаковал.
Вотом в терминале проделываю такое:

infotec@infotec-server:~> ls
bin  Desktop  Documents  public_html
infotec@infotec-server:~> cd Desktop
infotec@infotec-server:~/Desktop> ls
GnomeOnlineHelp.desktop  licq-1.3.5  licq-1.3.5.tar.gz  SuSE.desktop
infotec@infotec-server:~/Desktop> cd licq-1.3.5
infotec@infotec-server:~/Desktop/licq-1.3.5> ls
acinclude.m4     configure     licq_gpg.conf  README          src
acinclude.m4.in  configure.ac  Makefile.am    README.FREEBSD  stamp-h.in
aclocal.m4       doc           Makefile.in    README.GPG      upgrade
admin            include       plugins        README.ICS
bin              INSTALL       po             README.OPENSSL
config.h.in      LICENSE       post-install   share
infotec@infotec-server:~/Desktop/licq-1.3.5> ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
infotec@infotec-server:~/Desktop/licq-1.3.5> make
make: *** Не заданы цели и не найден make-файл.  Останов.
infotec@infotec-server:~/Desktop/licq-1.3.5> ls
acinclude.m4     config.log    LICENSE        post-install    share
acinclude.m4.in  configure     licq_gpg.conf  README          src
aclocal.m4       configure.ac  Makefile.am    README.FREEBSD  stamp-h.in
admin            doc           Makefile.in    README.GPG      upgrade
bin              include       plugins        README.ICS
config.h.in      INSTALL       po             README.OPENSSL
infotec@infotec-server:~/Desktop/licq-1.3.5> makefile
bash: makefile: команда не найдена
infotec@infotec-server:~/Desktop/licq-1.3.5> ./makefile
bash: ./makefile: Нет такого файла или каталога
infotec@infotec-server:~/Desktop/licq-1.3.5> ./makefile.in
bash: ./makefile.in: Нет такого файла или каталога
infotec@infotec-server:~/Desktop/licq-1.3.5> makefile.am
bash: makefile.am: команда не найдена
infotec@infotec-server:~/Desktop/licq-1.3.5> ./makefile.am
bash: ./makefile.am: Нет такого файла или каталога


Т.е. обычные вещи, которые пишут в faq:
./configuration
make
install

Я застопорился на мейк.
Помогите пожалуйста

Оффлайн ziv

  • Активист
  • *
  • Сообщений: 403
    • Просмотр профиля
Ты застопорился на configure - нужно установить build-essential.
И читай, пожалуйста, факи.

Оффлайн WildFire

  • Новичок
  • *
  • Сообщений: 30
  • WildFire
    • Просмотр профиля
Я застопорился на мейк.
Помогите пожалуйста

Нет, вы застопорились еще на ./configuration

ziv
Опередил!.. ;)

Оффлайн Artemius

  • Автор темы
  • Участник
  • *
  • Сообщений: 178
    • Просмотр профиля
Я читал факи.
К примеру этот - http://www.opennet.ru/docs/RUS/linux_beg_faq/Linux-FAQ-7.html


Цитировать
2 конфигурим пакет

./configure

(в тяжелых случаях нужно будет в параметрах указать пути для всех необходимых библиотек и header-файлов - но к счастью, обычно на близких системах они лежат одинакого и сам скрипт configure их находит, также параметы могут потребоваться, если пакет будет распологаться не в том месте, где предполагал разработчик программы, а в каком-либо другом )

Т.е. у меня получается "тяжелый случай"?
Я натыкался только на такого рода

В ридми самой аськи наналогично:

Цитировать
  1. `cd' to the directory where you unpacked Licq sources and type
     `./configure' to configure the package for your system.

     Running `configure' takes awhile.  While running, it prints some
     messages telling which features it is checking for.

Ничего конкретно, как его настраивать.

Оффлайн dmay

  • Старожил
  • *
  • Сообщений: 1084
  • man google, кому сказал!
    • Просмотр профиля
тебе-ж сказали - поставь пакет build-essential У тебя ./configure ругается что configure: error: no acceptable C compiler found in $PATH, внимательнее надо быть.
Ты попал в мою коллекцию криворуких тупых нубов!

Оффлайн Artemius

  • Автор темы
  • Участник
  • *
  • Сообщений: 178
    • Просмотр профиля
ziv, dmay, да, спасибо. Пропустил маленько :)

Оффлайн ziv

  • Активист
  • *
  • Сообщений: 403
    • Просмотр профиля
Вот это прочитай, не помешает: https://forum.ubuntu.ru/index.php?topic=2269.0

Оффлайн Artemius

  • Автор темы
  • Участник
  • *
  • Сообщений: 178
    • Просмотр профиля
Я никогда до этого не устанавливал пакеты. Пожалуйста, подскажите с чего начать?

Оффлайн ziv

  • Активист
  • *
  • Сообщений: 403
    • Просмотр профиля

 

Страница сгенерирована за 0.205 секунд. Запросов: 22.