Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Уменьшить разрешение монитора 20.04 с максимального  (Прочитано 1943 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн smart

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
проблема при следующих условиях
1. Монитор,подключенный по VGA, на максимальном разрешении не работает (белый экран, филипс некий, ЖКИ)
2. Системник на АМ?? некий, на основе nvidia чипов
3. Попытки установить разрешение 1280х1024 в лUbuntu при перезагрузке забываются
4. установка в grub vga=861 (и другие) в строке cmd_line, при загрузке, действуют только до начала вывода терминала (режим text)
далее снова белый экран на максимальном разрешении.

Подключение другого монитора, вход в защитный режим и там редактирование настроек как груба, командной строки и режима десктопа - коту под хвост.
ЛUbuntu упёрто переключается в макисмальныое разрешение экрана

В связи с этим - как весь процесс перевести на нужное разрешение ?

Я уже подумываю перекусить в кабеле DDC шину, но...надеюсь на более адекватное рещение
Листинги не дам, комп не тут и не сейчас, да и толку их давать - не видно
В защитном режиме xrandr не работает

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3062
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
smart, я внимательно прочёл весь ваш пост, но так и не понял какого разрешения вы хотел добиться на своём филипс некий?
Я странен, а не странен кто ж? (С)

Оффлайн smart

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
ну я в пункте 3 написал
3. Попытки установить разрешение 1280х1024 в лUbuntu при перезагрузке забываются

невнимательно прочитали !

PS - максимальное разрешение монитора - его проблема, которую надо обойти.
« Последнее редактирование: 17 Июль 2020, 23:04:30 от smart »

Оффлайн Dosifei

  • Любитель
  • *
  • Сообщений: 84
    • Просмотр профиля
Я уже подумываю перекусить в кабеле DDC шину, но...надеюсь на более адекватное рещение

Для начала попробуй это:
$ xrandr --output VGA-0 --mode 1280х1024 для сохранения данного разрешения после перезагрузки эту команду нужно прописать в ~/.xprofile.Ещё выхлоп дай
xdpyinfo | grep -B 2 resolution

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3062
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
smart, Ой простите, но вы тоже сам напортачил, для 1280х1024 в grub устанавливать vga в лучших кондициях нужно vga=792.
Я странен, а не странен кто ж? (С)

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
smart, параметр ядра video пробовали? Можно просто video=1280x1024ядру попробовать передать через grub2.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2463
    • Просмотр профиля
Можно ещё попробовать параметр vga=

Онлайн andytux

  • Старожил
  • *
  • Сообщений: 4480
    • Просмотр профиля
Можно ещё попробовать параметр vga=
Уже довольно давно, когда груб встречает в конфиге "vga=", то называет его устаревшим и рекомендует "video=".

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2463
    • Просмотр профиля
andytux, я с вами абсалютно согласен, но мы тут гадаем на кофейной гуще не зная ни версии ОС ни информации о железе. Правильно поставленный вопрос это 90% ответа. Я рекомендую ТС ознакомиться с этим разделом форума https://forum.ubuntu.ru/index.php?topic=215101.0

Оффлайн smart

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
lubuntu 2004
Linux amd 5.4.0-26-generic #30-Ubuntu SMP Mon Apr 20 16:58:30 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
        Subsystem: ASRock Incorporation C61 [GeForce 7025 / nForce 630a]
        Kernel driver in use: nouveau
        Kernel modules: nvidiafb, nouveau
grub

# If you change this file, run 'update-grub' afterwards to update                                             
# /boot/grub/grub.cfg.                                                                                       
# For full documentation of the options in this file, see:                                                   
#   info -f grub -n 'Simple configuration'                                                                   
                                                                                                             
GRUB_DEFAULT=0                                                                                               
GRUB_TIMEOUT_STYLE=hidden                                                                                     
GRUB_TIMEOUT=0                                                                                               
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`                                             
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"                                                                   
GRUB_CMDLINE_LINUX_DEFAULT="text video=792"                                                                   
GRUB_CMDLINE_LINUX=""                                                                                         
# GRUB GFXPAYLOAD_LINUX=1280x1024x32                                                                         
                                                                                                             
# Uncomment to enable BadRAM filtering, modify to suit your needs                                             
# This works with Linux (no patch required) and with any kernel that obtains                                 
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)                                     
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"                                                   
                                                                                                             
# Uncomment to disable graphical terminal (grub-pc only)                                                     
#GRUB_TERMINAL=console                                                                                       

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1280x1024x32

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


(Нажмите, чтобы показать/скрыть)
с этими настройками виден терминал после старта несколко секунд, и затем снова белый экран
(Нажмите, чтобы показать/скрыть)
Отправлено уведомление о нарушении в ЛС пользователю. Сообщение приведено модератором в нормальное состояние (полное сохранение смысла при этом не гарантируется), исходный вариант пользователя убран под спойлер в середине сообщения.
  --zg_nico
« Последнее редактирование: 23 Июль 2020, 10:46:19 от zg_nico »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3062
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
sorry for bukwy, ne stavil poka ruski
А куда подевался ruski из первого поста?
Я странен, а не странен кто ж? (С)

Оффлайн smart

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
А куда подевался ruski из первого поста?
по теме отвечай
(Нажмите, чтобы показать/скрыть)
+5% с уведомлением в ЛС. Ваши действия попадают под определение модерирования, принятое на форуме. Правилами форума подобное поведение строго запрещается.
  --zg_nico
« Последнее редактирование: 23 Июль 2020, 10:55:53 от zg_nico »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3513
  • Nil mortalibus arduum est
    • Просмотр профиля
smart, Вы эту рекомендацию пробовали? Каков результат?
Просто в Вашем текущем перечне умолчаний для grub я параметра video в упор не вижу, а вижу quiet и splash.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн smart

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
smart, Вы эту рекомендацию пробовали? Каков результат?
Просто в Вашем текущем перечне умолчаний для grub я параметра video в упор не вижу, а вижу quiet и splash.
GRUB_CMDLINE_LINUX_DEFAULT="text video=792"
предыдущая строка закомментирована !
Кое что получилось с принудительным разрешением - после video=792 nomodeset
Но, тогда неудобное разрешение в консоли и не изменяются разрешения в X
Таким образом, оставляю 1024х768  - с ядром бороться бесполезно....

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2463
    • Просмотр профиля
Попробуйте так
GRUB_CMDLINE_LINUX_DEFAULT="text video="

 

Страница сгенерирована за 0.089 секунд. Запросов: 25.