Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: GIMP: gimp-lensfun  (Прочитано 453 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн S.D. aka Xvost

  • Автор темы
  • Активист
  • *
  • Сообщений: 402
    • Просмотр профиля
    • Пост Ворскла
GIMP: gimp-lensfun
« : 26 Август 2020, 18:46:48 »
Собственно, как поставить на 20.04 этот плагин?

Зчитування переліків пакунків... Виконано
Побудова дерева залежностей                       
Зчитування інформації про стан... Виконано
Деякі пакунки неможливо встановити. Можливо, Ви просите неможливого,
або ж використовуєте нестабільний дистрибутив, і запитані Вами пакунки
ще не створені або були вилучені з Incoming.
Наступна інформація можливо допоможе Вам виправити ситуацію:

Пакунки, що мають незадоволені залежності:
 gimp-lensfun : Залежності (Depends): libgimp2.0 (>= 2.4.0) але він не буде встановлений
E: Неможливо усунути проблеми, ви маєте поламані зафіксовані пакунки.

Не из-за перевода ли GIMP в snap это происходит?
HP 250 G7 (1F3H9EA) Silver; Intel® Celeron(R) N4020 CPU @ 1.10GHz × 2; Mesa Intel® UHD Graphics 600 (GLK 2)
Ubuntu 18.04, Linux Mint 20.1 Cinnamon

Онлайн andytux

  • Старожил
  • *
  • Сообщений: 4478
    • Просмотр профиля
Re: GIMP: gimp-lensfun
« Ответ #1 : 26 Август 2020, 18:51:06 »
Сначала почини поломанное. Только после этого сможешь опять пихать невпихуемое.

Оффлайн S.D. aka Xvost

  • Автор темы
  • Активист
  • *
  • Сообщений: 402
    • Просмотр профиля
    • Пост Ворскла
Re: GIMP: gimp-lensfun
« Ответ #2 : 26 Август 2020, 20:08:24 »
sudo apt install -f

Зчитування переліків пакунків... Виконано
Побудова дерева залежностей                       
Зчитування інформації про стан... Виконано
оновлено 0, встановлено 0 нових, 0 відмічено для видалення і 0 не оновлено.

Synaptic проблем тоже не находит.
HP 250 G7 (1F3H9EA) Silver; Intel® Celeron(R) N4020 CPU @ 1.10GHz × 2; Mesa Intel® UHD Graphics 600 (GLK 2)
Ubuntu 18.04, Linux Mint 20.1 Cinnamon

Оффлайн Вокруг

  • Участник
  • *
  • Сообщений: 141
    • Просмотр профиля
Re: GIMP: gimp-lensfun
« Ответ #3 : 27 Август 2020, 07:46:45 »
В 10 версии гимпа почти ничего не работает старое. Смена API
Канал в Твиторе https://twitter.com/VokrugLinux

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 2267
    • Просмотр профиля
Re: GIMP: gimp-lensfun
« Ответ #4 : 27 Август 2020, 09:56:03 »
Я в Ubuntu-20.04 в Gimp ещё ничего не делал, но у меня есть и установлены пакеты и libgegl и gimp-lensfun,
так что дополнительного репозитария подключать не требуется.
Пётр.

Оффлайн S.D. aka Xvost

  • Автор темы
  • Активист
  • *
  • Сообщений: 402
    • Просмотр профиля
    • Пост Ворскла
Re: GIMP: gimp-lensfun
« Ответ #5 : 31 Август 2020, 13:04:30 »
Нарыл таки решение. Дело в том, что в Ubuntu 20.04 GIMP представлен в официальных репозиториях в виде snap-пакета. Как мне удалось понять, из-за пакета libgegl-0.4-0, которого то ли нет, то ли он не поддерживается. Если же устанавливать из репозитория
sudo add-apt-repository ppa:otto-kesselgulasch/gimpsudo apt install gimpто начинает выбивать ошибку про поврежденные пакеты.
То же самое при установке gimp-lensfun.
Дело в том, что репозиторий otto-kesselgulasch/gimp больше не поддерживается автором.

Нашел решение. Добрые люди создали репозиторий с gimp, gimp-lensfun и всеми необходимыми пакетами.
sudo add-apt-repository ppa:ubuntuhandbook1/gimpОтсбжда устанавливается всё без проблем.
HP 250 G7 (1F3H9EA) Silver; Intel® Celeron(R) N4020 CPU @ 1.10GHz × 2; Mesa Intel® UHD Graphics 600 (GLK 2)
Ubuntu 18.04, Linux Mint 20.1 Cinnamon

 

Страница сгенерирована за 0.072 секунд. Запросов: 25.