Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Никак не хочет запускаться Tor Browser после обновления до последней версии  (Прочитано 5655 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля
Братцы, помогайте! Это уже какой-то трабл. Был торбраузер с лаунчером. Раньше как минимум один раз уже обновлялся и все было в порядке (версия Ubuntu 20.04). Прилетело последнее обновление, сразу после него перезапустился и работал, но после, когда запустил его еще раз, ничего не произошло. Никаких сообщений, никакой реакции. Пробовал устанавливать заново с лаунчера - скачивает, а потом идет вечная проверка подписи. Уже переустанавливал сам лаунчер, не помогло. Потом скачал архив tar.xz с оф. сайта.
Порядок запуска с него:
(Нажмите, чтобы показать/скрыть)
После этого та-же история: никаких ошибок в выводе, никакой реакции. Просто написано, что оно его запускает (еще слово --detach в конце), а на деле ничего не происходит. Уж что делать я не знаю. Подскажите куда копать, что делать?  :-\

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
UbuntWindow,
Вы хоть папку из архива вынули? У меня всё запускается.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля
 Pilot6, вынул, вынул. Не настолько идиот.  ;D

Пользователь добавил сообщение 24 Сентября 2020, 10:22:05:
Pilot6, вытаскивал архиватором. Сначала открыл, потом указал директорию для распаковки.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
вынул, вынул. Не настолько идиот.
Ну так запусиииие "тот исполняемый файл двойным кликом". Там небось пробел в названии и вы в кавычки не взяли. Или что-то в этом роде. Я только что запускал без проблем.

И "Top Browser.desktop" - это не исполняемый файл, а desktop файл, по сути "ярлык" в терминологии винды. Иснолняемый файл там другой и в другом месте.
« Последнее редактирование: 24 Сентября 2020, 10:27:03 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля
Pilot6, а вот тут кроется причина, из-за которой я устанавливал браузер через лаунчер - когда запускаешь двойным кликом, он открывается как текстовый файл, с текстовым содержимым (наподобе torrc). Даже после выставления галочки, чтоб открывался как исполняемый файл.

Пользователь добавил сообщение 24 Сентября 2020, 10:26:42:
Pilot6, может можно где-то какой-то лог посмотреть или в терминале процес увидеть (типа verbose mode)?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
UbuntWindow,
Исполняемый файл находится в папке Browser и называется start-tor-browser.

Так что

./Browser/start-tor-browser

Остальное лениво объяснять. Ну или можете этот desktop файл положить в ~/.local/share/applications будет не хуже лончера.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля
Pilot6, он самый. На счет второго варианта я попробую.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
На счет второго варианта я попробую.
Только путь проверьте к папке, куда вы скачали. Он должен соответсвовать.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля
Pilot6, нихрена не сработало... Хоть ты переноси, хоть не переноси. По ходу дела я обнаружил почему эти файлы запускались как текстовые. Оказывается у них у всех была выставлена программа по-умолчанию "текстовый редактор". Заменил на "запуск приложений". Он какое-то время отображается в верхнем левом уголку экрана, когда запускаешь start-tor-browser (то есть сам "запуск приложений" запускается), потом через некоторое время пропадает и дальше ничего не происходит. То есть такая же история как и до этого. С терминала та-же х*рня - вводишь ./Browser/start-tor-browser курсор переносится на следующую строку и мигает, и мигает, и все.

Онлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1566
    • Просмотр профиля
chmod +x ./Browser/start-tor-browser
Затем
./Browser/start-tor-browser

Пользователь добавил сообщение 24 Сентября 2020, 13:29:19:
По ходу дела я обнаружил почему эти файлы запускались как текстовые.

Скрипты всегда, в графическом интерфейсе, открываются как текстовые если файл не исполняемый.
« Последнее редактирование: 24 Сентября 2020, 13:30:55 от Usermaster »

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля
Usermaster, yb[h
chmod +x ./Browser/start-tor-browser
Затем
./Browser/start-tor-browser
Нихрена...  :-[ Всё сделал, курсор просто переходит на следующую строку, замирает и нихрена после этого не происходит. Я ж говорю, может где-то можно логи какие-то посмотреть во время этого процесса, чтобы хотя бы узнать что во время этого происходит? Ещё хочу ещё раз подчеркнуть, что в варианте с лаунчером весь процесс замирает на этапе проверки подписи. Может в этом можно найти какую-то ниточку? Я ничего не делал с Ubuntu, чтобы можно было на это подумать. Всё началось после последнего обновления Тор-браузера. Ещё, за пару дней до этого, наконец-то прилетело обновление для tor (тот что не браузер, а socks и всё остальное). Может они как-то конфликтовать стали?

Оффлайн Lex Alexov

  • Модератор форума
  • Активист
  • *
  • Сообщений: 291
    • Просмотр профиля
Поставил из реп через Discover - так же вечная проверка подписи. Скачал с сайта, распаковал - запускается с *.desktop-файла без проблем.
Samsung NP-530U4b-S01; Intel i3-2367M (4) @ 1.44GHz; 8Gb DDR3 1333 МГц; AMD Radeon HD 7550M; Intel HD Graphics 4000; KDE-Neon 5.21 x64;

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля
Lex Alexov, а у меня раньше, при двойном клике запускался он в виде текстового файла. Потом, когда выставил ему "запуск приложений", после запуска ничего не происходит. Через терминал тоже. Где может скрываться ошибка? Если б можно было где-то глянуть какой-то лог во время запуска тор-браузера.

Пользователь добавил сообщение 26 Сентября 2020, 12:30:12:
В блоге тора тоже пишут про эту проблему с лаунчером. https://blog.torproject.org/new-release-tor-browser-100#comments Оказывается у него постоянно проблемы с ключами, после выхода новых версий. Один человек советует такое решение:
(Нажмите, чтобы показать/скрыть)
Проблема в том, что я не совсем понимаю, как это применить. Для меня это выглядит как обрывок ссылки, потом ещё один обрывок ссылки и команда. Я так понимаю, это после установки лаунчера надо вбивать? Пожалуйста, приведите этот коммент в подобающий вид, чтоб можно это было использовать, потому что как есть оно только ошибки в терминале выдаёт. Те два куска ссылки это какие-то две разные ссылки по факту. Даже когда первую ссылку спецом копируешь через "копировать ссылку", то всё равно терминал не понимает команду wget, точнее просит ещё что-то к ней, а ссылку эту не берёт в расчёт.
На счёт второго варианта с установкой браузера из архива, то нихрена этот метод не работает у меня. Всё делаю правильно, правильная директория, без пробелов в командах. Не запускается и всё. В инете тоже нашёл тему с такой проблемой. Там тоже советовали всё то, что и вы, и тоже нихрена не помогло. А потом чел отписал, что перекачал архив, распаковал и само заработало. Я тоже пробовал, но в моём случае ничерта не меняется.
Остаётся только один вариант, это через лаунчер как-то установить.
« Последнее редактирование: 26 Сентября 2020, 12:34:05 от UbuntWindow »

Оффлайн UbuntWindow

  • Автор темы
  • Любитель
  • *
  • Сообщений: 79
    • Просмотр профиля

 

Страница сгенерирована за 0.049 секунд. Запросов: 25.