Форум русскоязычного сообщества Ubuntu


Автор Тема: Неразрешенные зависимости libc6  (Прочитано 920 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Неразрешенные зависимости libc6
« : 25 Октябрь 2020, 17:54:05 »
Здравствуйте.

ubuntu 18.04 - появился кирпич.
Ввожу sudo apt-get install -f

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  libqt5concurrent5
Для его удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libc6 libc6:i386
Предлагаемые пакеты:
  glibc-doc glibc-doc:i386 locales:i386
Следующие пакеты будут обновлены:
  libc6 libc6:i386
Обновлено 2 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 280 пакетов не обновлено.
Установлено или удалено не до конца 30 пакетов.
Необходимо скачать 0 B/5 377 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 096 B.
Хотите продолжить? [Д/н] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Чтение базы данных … на данный момент установлено 387015 файлов и каталогов.)
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_amd64.deb …
Деконфигурируется libc6:i386 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb (--unpack):
 new libc6:amd64 package pre-installation script subprocess returned error exit status 1
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_i386.deb …
Деконфигурируется libc6:amd64 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb (--unpack):
 new libc6:i386 package pre-installation script subprocess returned error exit status 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Похоже, неразрешенные зависимости. Как это можно исправить?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #1 : 25 Октябрь 2020, 18:38:48 »

Если после перезагрузки проблема не уходит, ищите проблему в техподдержке.
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #2 : 25 Октябрь 2020, 19:02:35 »
не уходит

самостоятельно исправить не получится?

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2841
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #3 : 25 Октябрь 2020, 19:36:03 »
AY12, вы сторонние репозитории подключали? Если да, отключайте.
Затем попробуйте:
sudo apt clean
sudo apt-get install -f
sudo apt-get update
sudo apt autoremove
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #4 : 25 Октябрь 2020, 21:08:24 »
AY12, вы сторонние репозитории подключали? Если да, отключайте.
Вы имеете в виду это?


Не знаю. Как это нужно сделать?

Прочитайте правила: «Руководство по добавлению изображений на форум»
--Aleksandru
« Последнее редактирование: 25 Октябрь 2020, 21:31:30 от Aleksandru »

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2841
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #5 : 25 Октябрь 2020, 21:36:20 »
Снимите галку где у вас cybermax-dexter.
Потом кнопку закрыть, затем будет предложено обновить пакеты, обновляйте.
И далее выполните то, что я вам выше написал.
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #6 : 25 Октябрь 2020, 21:50:37 »
Снимите галку где у вас cybermax-dexter.
Потом кнопку закрыть, затем будет предложено обновить пакеты, обновляйте.
Когда я нажал закрыть, появилось:

Цитировать
Ошибка при загрузке информации об источниках приложений
Проверьте интернет-соединение.
W:GPG error: https://repo.skype.com/deb stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1F3045A5DF7587C3, E:The repository 'https://repo.skype.com/deb stable InRelease' is not signed.

Потом выполнил те 4 команды
sudo apt clean
sudo apt-get install -f
sudo apt-get update
sudo apt autoremove
но ничего не изменилось.

edit: убрал галочку со skype, сейчас мб получится...

Нет, не получилось.

« Последнее редактирование: 25 Октябрь 2020, 21:53:24 от AY12 »

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2841
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #7 : 25 Октябрь 2020, 22:00:27 »
Потом выполнил те 4 команды
Что было в терминале при их выполнении?
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #8 : 25 Октябрь 2020, 22:11:16 »
andry@andry-Aspire-A315-21G:~$ sudo apt clean
andry@andry-Aspire-A315-21G:~$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  libqt5concurrent5
Для его удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libc6 libc6:i386
Предлагаемые пакеты:
  glibc-doc glibc-doc:i386 locales:i386
Следующие пакеты будут обновлены:
  libc6 libc6:i386
Обновлено 2 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 270 пакетов не обновлено.
Установлено или удалено не до конца 30 пакетов.
Необходимо скачать 5 377 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 096 B.
Хотите продолжить? [Д/н] y
Пол:1 http://be.archive.ubuntu.com/ubuntu bionic-updates/main i386 libc6 i386 2.27-3ubuntu1.2 [2 550 kB]
Пол:2 http://be.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libc6 amd64 2.27-3ubuntu1.2 [2 827 kB]
Получено 5 377 kB за 21с (259 kB/s)                                           
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Чтение базы данных … на данный момент установлено 387015 файлов и каталогов.)
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_amd64.deb …
Деконфигурируется libc6:i386 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb (--unpack):
 new libc6:amd64 package pre-installation script subprocess returned error exit status 1
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_i386.deb …
Деконфигурируется libc6:amd64 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb (--unpack):
 new libc6:i386 package pre-installation script subprocess returned error exit status 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
andry@andry-Aspire-A315-21G:~$ sudo apt-get update
Сущ:1 http://be.archive.ubuntu.com/ubuntu bionic InRelease
Сущ:2 http://linux.teamviewer.com/deb stable InRelease                         
Сущ:3 http://be.archive.ubuntu.com/ubuntu bionic-updates InRelease             
Сущ:4 http://security.ubuntu.com/ubuntu bionic-security InRelease             
Сущ:5 http://be.archive.ubuntu.com/ubuntu bionic-backports InRelease           
Чтение списков пакетов… Готово                                     
andry@andry-Aspire-A315-21G:~$ sudo apt autoremove
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 libc6-dbg : Зависит: libc6 (= 2.27-3ubuntu1.2) но 2.27-3ubuntu1 уже установлен
 libc6-dev : Зависит: libc6 (= 2.27-3ubuntu1.2) но 2.27-3ubuntu1 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
andry@andry-Aspire-A315-21G:~$

убрал последнюю галочку с teamviewer, но все то же

andry@andry-Aspire-A315-21G:~$ sudo apt clean
andry@andry-Aspire-A315-21G:~$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  libqt5concurrent5
Для его удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libc6 libc6:i386
Предлагаемые пакеты:
  glibc-doc glibc-doc:i386 locales:i386
Следующие пакеты будут обновлены:
  libc6 libc6:i386
Обновлено 2 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 269 пакетов не обновлено.
Установлено или удалено не до конца 30 пакетов.
Необходимо скачать 5 377 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 096 B.
Хотите продолжить? [Д/н] y
Пол:1 http://be.archive.ubuntu.com/ubuntu bionic-updates/main i386 libc6 i386 2.27-3ubuntu1.2 [2 550 kB]
Пол:2 http://be.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libc6 amd64 2.27-3ubuntu1.2 [2 827 kB]
Получено 5 377 kB за 18с (291 kB/s)                                           
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Чтение базы данных … на данный момент установлено 387015 файлов и каталогов.)
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_amd64.deb …
Деконфигурируется libc6:i386 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb (--unpack):
 new libc6:amd64 package pre-installation script subprocess returned error exit status 1
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_i386.deb …
Деконфигурируется libc6:amd64 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb (--unpack):
 new libc6:i386 package pre-installation script subprocess returned error exit status 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
andry@andry-Aspire-A315-21G:~$ sudo apt-get update
Сущ:1 http://be.archive.ubuntu.com/ubuntu bionic InRelease
Сущ:2 http://be.archive.ubuntu.com/ubuntu bionic-updates InRelease             
Сущ:3 http://be.archive.ubuntu.com/ubuntu bionic-backports InRelease           
Сущ:4 http://security.ubuntu.com/ubuntu bionic-security InRelease             
Чтение списков пакетов… Готово                                       
andry@andry-Aspire-A315-21G:~$ sudo apt autoremove
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 libc6-dbg : Зависит: libc6 (= 2.27-3ubuntu1.2) но 2.27-3ubuntu1 уже установлен
 libc6-dev : Зависит: libc6 (= 2.27-3ubuntu1.2) но 2.27-3ubuntu1 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
« Последнее редактирование: 25 Октябрь 2020, 22:22:39 от AY12 »

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2841
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #9 : 25 Октябрь 2020, 22:24:09 »
sudo apt --fix-broken install
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #10 : 25 Октябрь 2020, 22:27:00 »
sudo apt --fix-broken install
andry@andry-Aspire-A315-21G:~$ sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  libqt5concurrent5
Для его удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libc6 libc6:i386
Предлагаемые пакеты:
  glibc-doc glibc-doc:i386 locales:i386
Следующие пакеты будут обновлены:
  libc6 libc6:i386
Обновлено 2 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 269 пакетов не обновлено.
Установлено или удалено не до конца 30 пакетов.
Необходимо скачать 0 B/5 377 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 096 B.
Хотите продолжить? [Д/н] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Чтение базы данных … на данный момент установлено 387015 файлов и каталогов.)
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_amd64.deb …
Деконфигурируется libc6:i386 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb (--unpack):
 new libc6:amd64 package pre-installation script subprocess returned error exit status 1
Подготовка к распаковке …/libc6_2.27-3ubuntu1.2_i386.deb …
Деконфигурируется libc6:amd64 (2.27-3ubuntu1) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb (--unpack):
 new libc6:i386 package pre-installation script subprocess returned error exit status 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Оффлайн Onlininer

  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #11 : 26 Октябрь 2020, 02:54:20 »
AY12, вы в "Программах и обновлениях" не только "галочку снимите" а выделите всю строку репозитания и внизу нажмите кнопочку "удалить". Потом, после закрытия этого окна проделайте, в терминале предложенные Aleksandru команды.

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #12 : 26 Октябрь 2020, 08:31:27 »
AY12, вы в "Программах и обновлениях" не только "галочку снимите" а выделите всю строку репозитания и внизу нажмите кнопочку "удалить". Потом, после закрытия этого окна проделайте, в терминале предложенные Aleksandru команды.
удалил все кроме "партнеры canonical", но ничего не изменилось.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27655
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #13 : 26 Октябрь 2020, 09:03:08 »
Удалите весь каталог /var/cache/debconf
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн AY12

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Неразрешенные зависимости libc6
« Ответ #14 : 26 Октябрь 2020, 12:40:15 »
Удалите весь каталог /var/cache/debconf
сделал
sudo rm -r /var/cache/debconf
sudo mkdir /var/cache/debconf

затем
sudo apt clean
sudo apt-get install -f
sudo apt-get update
sudo apt autoremove

кирпич исчез
Спасибо огромное!:))

 

Страница сгенерирована за 0.073 секунд. Запросов: 25.