Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: автозапуск virtualbox не работает  (Прочитано 435 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ArgusSW

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
автозапуск virtualbox не работает
« : 09 Ноябрь 2020, 17:53:37 »
Пробовал двумя способами. В обоих случаях команда набранная в консоли запускает машину. Добавленная в автозагрузку - не запускает.
1 вариант в rc.local
sudo su -c "VBoxManage startvm 'w7' --type headless" argus
2 вариант как тут https://losst.ru/avtozapusk-virtualnoj-mashiny-virtualbox
-- The job identifier is 1217.
ноя 09 17:40:02 server sudo[2199]: pam_unix(sudo:auth): Couldn't open /etc/securetty: No such file or directory
ноя 09 17:40:05 server sudo[2199]: pam_unix(sudo:auth): Couldn't open /etc/securetty: No such file or directory
ноя 09 17:40:05 server sudo[2199]:    argus : TTY=pts/0 ; PWD=/home/argus ; USER=root ; COMMAND=/usr/bin/systemctl edit vbox@.service --full --force
ноя 09 17:40:05 server sudo[2199]: pam_unix(sudo:session): session opened for user root by argus(uid=0)
ноя 09 17:40:26 server systemd[1]: Reloading.
ноя 09 17:40:27 server systemd[1]: /lib/systemd/system/dbus.socket:5: ListenStream= references a path below legacy directory /var/run/, updating /var/run/dbus/system_bus_socket → /run/dbus/system_bus_socket; please update the unit file >
ноя 09 17:40:27 server systemd[1]: /etc/systemd/system/vbox@.service:1: Assignment outside of section. Ignoring.
ноя 09 17:40:27 server systemd[1]: /etc/systemd/system/vbox@.service:2: Assignment outside of section. Ignoring.
ноя 09 17:40:27 server systemd[1]: /etc/systemd/system/vbox@.service:3: Assignment outside of section. Ignoring.
ноя 09 17:40:27 server systemd[1]: /etc/systemd/system/vbox@.service:1: Assignment outside of section. Ignoring.
ноя 09 17:40:27 server systemd[1]: /etc/systemd/system/vbox@.service:2: Assignment outside of section. Ignoring.
ноя 09 17:40:27 server systemd[1]: /etc/systemd/system/vbox@.service:3: Assignment outside of section. Ignoring.
ноя 09 17:40:27 server sudo[2199]: pam_unix(sudo:session): session closed for user root
Что ж ему не нравится то?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #1 : 09 Ноябрь 2020, 20:13:35 »
ArgusSW,
А sudo зачем?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ArgusSW

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #2 : 09 Ноябрь 2020, 20:31:11 »
а как надо?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #3 : 09 Ноябрь 2020, 20:35:48 »
а как надо?
Я не знаю как надо, но sudo su - бред в начале точно.

Пользователь добавил сообщение 09 Ноябрь 2020, 20:38:32:
Команду без всяких sudo в Автоматически запускаемые приложения положите.

Например

VBoxManage startvm 'w7'
« Последнее редактирование: 09 Ноябрь 2020, 20:38:46 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн ArgusSW

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #4 : 09 Ноябрь 2020, 20:52:11 »
по разному пробовал. из консоли полюбому запускается. Их автозагрузки - никак. Где рыть-то?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #5 : 09 Ноябрь 2020, 20:59:31 »
Где рыть-то?
ну я ж не знаю что вы там делаете. rc.local тоже не то место, где такое можно запускать. Это вообще ubuntu?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3061
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #6 : 09 Ноябрь 2020, 21:09:43 »
ArgusSW, попробуй как тут: https://forum.ubuntu.ru/index.php?topic=282566.0.
Я странен, а не странен кто ж? (С)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13696
  • Xubuntu 18.04
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #7 : 09 Ноябрь 2020, 21:10:58 »
AlexBKost,
Ну да. Вот там как раз это sudo su, что само по себе бред, да еще в rc.local.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3061
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #8 : 09 Ноябрь 2020, 21:24:25 »
Pilot6, но там [РЕШЕНО].

Есть и ещё: https://losst.ru/avtozapusk-virtualnoj-mashiny-virtualbox
« Последнее редактирование: 09 Ноябрь 2020, 21:26:56 от AlexBKost »
Я странен, а не странен кто ж? (С)

Оффлайн ArgusSW

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #9 : 09 Ноябрь 2020, 23:39:15 »
Замечательно. Я в первом посте написал что это не срабатывает. Срабатывает если эту команду стукануть через консоль. Но не через rc.local. У меня xubuntu. Массив на zfs, vm там же. Может такое быть что команда запустить vm проходит раньше чем что-нибудь там подмонтируется или т.п.?

Пользователь добавил сообщение 09 Ноябрь 2020, 23:40:59:
а как надо?
Я не знаю как надо, но sudo su - бред в начале точно.

Пользователь добавил сообщение 09 Ноябрь 2020, 20:38:32:
Команду без всяких sudo в Автоматически запускаемые приложения положите.

Например

VBoxManage startvm 'w7'

Пробовал. Та же история.
« Последнее редактирование: 09 Ноябрь 2020, 23:40:59 от ArgusSW »

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1158
    • Просмотр профиля
Re: автозапуск virtualbox не работает
« Ответ #10 : 10 Ноябрь 2020, 11:09:23 »
Положите комманду

VBoxManage startvm "w7"

в cron.

Раз запускается из коммандной строки, значит cron запустит.

Можно сделать небольшую задержку запуска, чтоб в системе все службы стартанули а потом и виртуалка завелась.
« Последнее редактирование: 10 Ноябрь 2020, 11:11:38 от Usermaster »

 

Страница сгенерирована за 0.077 секунд. Запросов: 26.