Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Как находить зависимости?  (Прочитано 213 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TheMihai

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Как находить зависимости?
« : 10 Ноябрь 2020, 13:19:01 »
Как их находить?

Вот к примеру
blender : Зависит: libavdevice58 (>= 7:4.0) но он не будет установлен
           Зависит: libavformat58 (>= 7:4.2) но он не будет установлен
           Зависит: libopenimageio2.1 (>= 2.1.10.1~dfsg0) но он не будет установлен
           Зависит: libswscale5 (>= 7:4.0) но он не будет установлен

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4467
    • Просмотр профиля
Re: Как находить зависимости?
« Ответ #1 : 10 Ноябрь 2020, 13:24:39 »
Твой вопрос звучит как: "научить плохому".
Система предостерегает тебя, чтобы ты ее не ломал. Хочешь поломать?

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5424
    • Просмотр профиля
Re: Как находить зависимости?
« Ответ #2 : 10 Ноябрь 2020, 15:30:37 »
TheMihai, прочитайте руководство.

пакеты нужно ставить из штатных репозиториев, тогда зависимости будут устанавливаться сами.
Отдельные пакеты можно ставить через gdebi.

Ваша проблема из-за того, что не подключены нужные репозитории или версия пакета не подходит под версию используемого дистрибутива.

 

Страница сгенерирована за 0.088 секунд. Запросов: 26.