Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Монтирование сетевой шары в локальную папку - проблема.  (Прочитано 402 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlexDem

  • Автор темы
  • Активист
  • *
  • Сообщений: 466
    • Просмотр профиля
Есть 2 сетевые NFS шары (2 сетевых диска на DNS): /mnt/HD/HD_a2 и /mnt/HD/HD_b2 которые соответственно монтируются в каталоги /home/alex/Vol_1
и /home/alex/Vol_2 командами в fstab
#Mount NFS volumes
192.168.1.9:/mnt/HD/HD_a2 /home/alex/Vol_1 nfs rw,hard,intr,rsize=8192,wsize=8192,timeo=14 0 0

192.168.1.9:/mnt/HD/HD_b2 /home/alex/Vol_2 nfs rw,hard,intr,rsize=8192,wsize=8192,timeo=14 0 0
Вернее монтировались во вчерашнего дня. Сегодня ничего не монтируется автоматом, локальные каталоги пусты, щелчок на ярлыке папки в проводнике говорит что  "mount: /home/alex/Vol_1: operation permitted for root only", хотя если ручками написать
sudo mount -t nfs 192.168.1.9:/mnt/HD/HD_a2 /home/alex/Vol_1то шара монтируется в нужную папку и открывается как ни в чем не бывало. Т.е. такое ощущение, что монтирование в fstab внезапно перестало работать на локальной машине. Но это странно, т.к. ничего не менялось.
Вопрос: как отследить проблему и как бы её пофиксить?




Пользователь добавил сообщение 20 Ноябрь 2020, 22:44:54:
Сам спросил - сам отвечу: fstab с какого то перепугу (непонятно с чего) стал требовать указать, что монтирование идет не от root, а от пользователя. Хотя раньше ему было пофигу. Добавление опции user,auto решило проблему. Теперь команда fstab для автоматического монтирования сетевых папок выглядит так:

192.168.1.9:/mnt/HD/HD_a2 /home/alex/Vol_1 nfs rw,hard,intr,rsize=8192,wsize=8192,timeo=14,user,auto 0 0
Кстати, монтирование samba папок тоже работало без указания этой опции.
« Последнее редактирование: 20 Ноябрь 2020, 22:44:54 от AlexDem »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27660
    • Просмотр профиля
хотя если ручками написать

sudo

А sudo типа не рут?

1. Забыли users
2. Забыли _netdev
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн AlexDem

  • Автор темы
  • Активист
  • *
  • Сообщений: 466
    • Просмотр профиля
А sudo типа не рут?

1. Забыли users
2. Забыли _netdev
Это понятно, потому и быстро разобрался, что подозрительно стало, почему из консоли с sudo все заработало, а без sudo тоже самое выдавало что нужен root.
Вопрос отчего оно с самого начала работало нормально, а потом заартачилось? Но раз проблему устранил, то наверное уже не так актуально. На будущее тем, кто будет этот же вопрос решать - в копилку знаний.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27660
    • Просмотр профиля
отчего оно с самого начала работало нормально
Потому что успевало смонтироваться во время загрузки системы.
Но раз проблему устранил, то наверное уже не так актуально
Измените user на users и добавьте _netdev чтобы задержать монтирование до поднятия сети.
users позволяет размонтировать том не только тому пользователю, который его смонтировал.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн AlexDem

  • Автор темы
  • Активист
  • *
  • Сообщений: 466
    • Просмотр профиля
Измените user на users и добавьте _netdev чтобы задержать монтирование до поднятия сети.
users позволяет размонтировать том не только тому пользователю, который его смонтировал.
Спасибо, полезный совет. Так и правда стало поудобнее...

 

Страница сгенерирована за 0.064 секунд. Запросов: 25.