Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Черный экран при установке и запуске  (Прочитано 1075 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн contague

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Добрый день, только начал знакомиться с Linux и при установке и запуске любого дистрибутива Linux сначала появляется черный экран, затем выключается монитор, ОС запускается, можно посмотреть лог.
С атрибутом "nomodeset" можно запуститься, но в низком разрешении.
Сейчас стоит Kubuntu 20.04 ядро 5.4.0-54-generic, пробовал установить драйвера с сайта amd, не помогает, установка открытых драйверов тоже не помогает, но не уверен что правильно обновляю.
Видеокарта radeon RX580, Windows с ней загружается, в фурмарке не артефактов не запредельных температур.
В какую сторону смотреть?



Пользователь добавил сообщение 28 Ноябрь 2020, 19:44:11:
Команда lspci -nn | grep -E 'VGA|Display' выводит
06:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev e7)команда lshw -c display выводит
*-display UNCLAIMED       
       description: VGA compatible controller
       product: Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:06:00.0
       version: e7
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:fcf00000-fcf3ffff memory:c0000-dffff
« Последнее редактирование: 28 Ноябрь 2020, 19:44:11 от contague »

Оффлайн jurganov

  • Активист
  • *
  • Сообщений: 448
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #1 : 29 Ноябрь 2020, 08:58:34 »
inxi -F
System:
  Host: juve Kernel: 5.8.0-25-generic x86_64 bits: 64 Desktop: MATE 1.24.0
  Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A
  serial: <superuser/root required>
  Mobo: Gigabyte model: F2A88XM-HD3P v: x.x
  serial: <superuser/root required> BIOS: American Megatrends v: F2
  date: 12/24/2015
CPU:
  Info: Quad Core model: AMD A8-7650K Radeon R7 10 Compute Cores 4C+6G
  bits: 64 type: MCP L2 cache: 2048 KiB
  Speed: 1895 MHz min/max: 1900/3300 MHz Core speeds (MHz): 1: 1896 2: 1896
  3: 1896 4: 1896
[b]Graphics:
  Device-1: AMD Kaveri [Radeon R7 Graphics] driver: radeon v: kernel
  Display: x11 server: X.Org 1.20.8 driver: ati,radeon
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: AMD KAVERI (DRM 2.50.0 5.8.0-25-generic LLVM 10.0.0)
  v: 4.5 Mesa 20.0.8 [/b]
Audio:
  Device-1: AMD Kaveri HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD FCH Azalia driver: snd_hda_intel
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Sound Server: ALSA v: k5.8.0-25-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp2s0 state: down mac: 1c:1b:0d:6a:c2:6a
  IF-ID-1: enx00093bf01a40 state: unknown speed: N/A duplex: N/A
  mac: 00:09:3b:f0:1a:40
Drives:
  Local Storage: total: 1.02 TiB used: 80.89 GiB (7.8%)
  ID-1: /dev/sda vendor: Kingston model: SUV400S37120G size: 111.79 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST31000524AS size: 931.51 GiB
и работает. на сводобном драйвере. ничего не ставил

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #2 : 29 Ноябрь 2020, 11:19:09 »
contague, покажи выхлопlspci -k | grep -EA3 'VGA|3D'

Оффлайн contague

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #3 : 29 Ноябрь 2020, 11:23:23 »
команда inxi -F у меня выводит
System:    Host: andrew-B450-AORUS-M Kernel: 5.4.0-54-generic x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine:   Type: Desktop Mobo: Gigabyte model: B450 AORUS M v: x.x serial: <superuser/root required> UEFI: American Megatrends
           v: F51 date: 07/29/2020
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP L2 cache: 3072 KiB
           Speed: 1373 MHz min/max: 1550/3400 MHz Core speeds (MHz): 1: 1373 2: 1374 3: 1375 4: 1375 5: 1434 6: 1451 7: 1367
           8: 1375 9: 1476 10: 1371 11: 1378 12: 1453
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: N/A
           Display: x11 server: X.Org 1.20.8 driver: fbdev FAILED: ati unloaded: modesetting,radeon,vesa
           resolution: 1024x768~76Hz
           OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.5
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
           Device-3: Razer USA Razer Banshee type: USB driver: hid-generic,snd-usb-audio,usbhid
           Sound Server: ALSA v: k5.4.0-54-generic
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:94:f4:49
Drives:    Local Storage: total: 606.42 GiB used: 11.66 GiB (1.9%)
           ID-1: /dev/sda vendor: Toshiba model: MK5076GSX size: 465.76 GiB
           ID-2: /dev/sdb type: USB vendor: Qumo model: N/A size: 28.87 GiB
           ID-3: /dev/sdc vendor: Kingston model: SHFS37A120G size: 111.79 GiB
Partition: ID-1: / size: 54.75 GiB used: 7.65 GiB (14.0%) fs: ext4 dev: /dev/sda2
           ID-2: /boot size: 938.0 MiB used: 276.9 MiB (29.5%) fs: ext2 dev: /dev/sda1
           ID-3: /home size: 136.51 GiB used: 3.71 GiB (2.7%) fs: ext4 dev: /dev/sda3
           ID-4: swap-1 size: 7.45 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:   System Temperatures: cpu: 34.6 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 254 Uptime: 30m Memory: 7.78 GiB used: 1.27 GiB (16.3%) Shell: bash inxi: 3.0.38


команда lspci -k | grep -EA3 'VGA|3D' выводит
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7)
        Subsystem: XFX Pine Group Inc. Radeon RX 580
        Kernel modules: amdgpu
06:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]

Правильно ли я понимаю что установлен драйвер amdgpu и это и есть свободный драйвер?

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #4 : 29 Ноябрь 2020, 11:35:08 »
Правильно ли я понимаю что установлен драйвер amdgpu и это и есть свободный драйвер?
- правильно... только не понятно почему не работает...
... и почему inxi выдает
Цитировать
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: N/A

Видимо нужно таки подождать более опытных в этом вопросе коллег...

Оффлайн contague

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #5 : 29 Ноябрь 2020, 12:02:52 »
Может это произойти из-за того что несколько загрузчиков? Сейчас при включении ПК если выбрать список boot devices появляются загрузчики Debian и Ubuntu они появились скорее всего когда я пытался установить другие дистрибутивы.
Фото выбора при загрузке:
https://yadi.sk/i/WEUm_bGVyBmrSQ

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #6 : 29 Ноябрь 2020, 12:48:14 »
contague, фото на Яндексе могут посмотреть далеко не все участники Форума...

1. «Руководстве по добавлению изображений на форум».

2. Secure Boot отключен?

3. устанавливать Ubuntu следует в том же режиме (UEFI или Legacy), что и установлена Windows.

4. в Windows нужно отключить Быструю загрузку, и после этого ВЫКЛЮЧИТ ПК, сейчас это не принципиально, а в будущем позволит избежать связанных с этим проблем.

Пользователь добавил сообщение 29 Ноябрь 2020, 12:51:22:
- другое пока на ум не приходит, потому, как я же предлагал...
нужно таки подождать более опытных в этом вопросе коллег...
« Последнее редактирование: 29 Ноябрь 2020, 12:51:22 от F12 »

Оффлайн contague

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #7 : 29 Ноябрь 2020, 13:05:20 »
Secure boot отключен.
Обе ОС установлены в режиме UEFI.

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1316
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #8 : 29 Ноябрь 2020, 14:02:27 »
- другое пока на ум не приходит, потому, как я же предлагал...
Да на железо ТС и в Лайф и установленная Ubuntu 20.04.1 загрузятся на ядерном amdgpu. Можно и проприетарь с АМД загрузить для Ubuntu 20.04.1 и установить. Инструкция там есть.
Так остаётся только моник какой-то левый подключен, или через левый переходник. Ну и ещё установка не офиц. релиза, а чей-то говносборки. Про Виндовс ты уже сказал.

Оффлайн contague

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #9 : 29 Ноябрь 2020, 15:23:12 »
Пробовал устанавливать драйвер amdgpu-pro, скачивал с амд amdgpu-pro-20.45-1164792-ubuntu-20.04, там просто запускал amdgpu-pro-install, но после установки в выводе lspci -k | grep -EA3 'VGA|3D' остается "Kernel modules: amdgpu".
Установлена Kubuntu 20.04, образ брал с оф сайта kubuntu.org.
Монитор подключен к видеокарте по hdmi кабелю без переходников, монитор Acer KA242YBi не старый, покупал в начале года.

Оффлайн jurganov

  • Активист
  • *
  • Сообщений: 448
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #10 : 29 Ноябрь 2020, 15:24:42 »
команда inxi -F у меня выводит

вот сравни...
у меня свобобный драйвер
Device-1: AMD Kaveri [Radeon R7 Graphics] driver: radeon v: kernel и у тебя
Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: N/A  хрен знает какой радеон без дрейвера

в личку отпишу про альтернативные дистрибутивы


Оффлайн contague

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #11 : 30 Ноябрь 2020, 09:21:50 »
Пока ничего не помогает, только при переустановки xserver-xorg совсем пропало изображение, пришлось переустановить Ubuntu.
Пока единственный выход вижу обновить bios видеокарты, но как-то рискованно.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3054
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04, 21.10
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #12 : 30 Ноябрь 2020, 10:50:51 »
Пока единственный выход вижу обновить bios видеокарты, но как-то рискованно.
Эта процедура, обновить bios, в твоём случае Чёрных экранов ничего не даст, патамучто у тебя AMD, и хочется приручить Kubuntu.

В заголовке темы я видел про
Цитировать
С атрибутом "nomodeset" можно запуститься, но в низком разрешении.
Это тоже не выход, патамучто загрузка происходит на драйвере VESA, с самым хреновым разрешением соответственно.

Для начала предлагаю попробовать загрузиться с параметром acpi=off, в моей практике были прецеденты, когда помогало с AMD.
Я странен, а не странен кто ж? (С)

Оффлайн contague

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #13 : 30 Ноябрь 2020, 23:05:53 »
Я думаю что обновить биос видеокарты может помочь если неправильно определяется видеокарта, добавление параметра acpi=off не помогает, после этого вообще перстал загружаться, сейчас очистил под ноль HDD и заново попробовал установить, не помогло. Пробовал посмотреть лог запуска с черным экраном (сохранил в файл вывод команды journalctl -b -1), но там чет дофига всего и особо ошибок загрузки драйвера или что-то с видео я не нашел. Единственное ближе к концу "Output HDMI-A-0 has no monitor section" почему-то не может найти выходы на монитор. Может попробовать заменить HDMI кабель.
Не нашел как правильно вставить файл лога https://yadi.sk/d/DmXJA98cKHjjCg.

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Черный экран при установке и запуске
« Ответ #14 : 02 Декабрь 2020, 10:50:36 »
Не нашел как правильно вставить файл лога
- копируешь текст и вставляешь в сообщение, но только обязательно прятать длинную "портянку", для этого можно использовать кнопку Код (кнопка со значком #), или кнопку Вставить спойлер (кружок с желтыми и черными секторами, как по мне, то чем-то напоминает Знак радиоактивности ;))

- текст, который желаешь спрятать, сначала выделяешь мышкой, а затем кликаешь по одной из упомянутых выше кнопок

Пользователь добавил сообщение 02 Декабрь 2020, 10:53:24:
- а использовать yadi.sk, не лучшее решение, т.к. не у всех форумчан есть доступ к этому ресурсу ::)
« Последнее редактирование: 02 Декабрь 2020, 10:53:24 от F12 »

 

Страница сгенерирована за 0.097 секунд. Запросов: 25.