Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: ati driver error  (Прочитано 1155 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rootkithunter

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
ati driver error
« : 05 Июль 2008, 18:07:23 »
Извините если пишу не туда, просто столкнулся с такой проблемой раннее в различных дистрибутивах таких проблем не было, дядька гугл искал весь день и толком не нашел того что надо.

Видеокарта ати радеон 9550. Kubuntu 8.04

sudo apt-get install dpkg-dev debhelper libstdc++5 dkms
./ati-driver-installer-8-6-x86.x86_64.run --buildpkg Ubuntu/hardy
sudo dpkg -i deb пакеты полученные

sudo aticonfig --initial

после рестарта иксов все равно получаю меса, крутил и пилил все что можно все равно ничего не выходит.

cat /var/log/Xorg.0.log

(EE) fglrx(0): Failed to initialize ASIC in kernel.
(EE) fglrx(0): [agp] unable to acquire AGP, error -1007
(EE) fglrx(0): cannot init AGP
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) fglrx(0): XMM failed to open CMMQS connection

Собственно хэлп ми плиз кто сталкивался.

Оффлайн Di'Brain

  • Новичок
  • *
  • Сообщений: 27
  • a d m i n i s t r a t o r
    • Просмотр профиля
Re: ati driver error
« Ответ #1 : 05 Июль 2008, 18:20:45 »
Удалите старые драйвера и попробуйте так: http://pronix.isgreat.org/news.php?item.91.5

Оффлайн rootkithunter

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: ati driver error
« Ответ #2 : 05 Июль 2008, 18:25:24 »
так тоже пробовал  :'(

Проблема мне кажется вот в этом:

(EE) fglrx(0): Failed to initialize ASIC in kernel.
(EE) fglrx(0): [agp] unable to acquire AGP, error -1007
(EE) fglrx(0): cannot init AGP
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) fglrx(0): XMM failed to open CMMQS connection

Оффлайн Di'Brain

  • Новичок
  • *
  • Сообщений: 27
  • a d m i n i s t r a t o r
    • Просмотр профиля
Re: ati driver error
« Ответ #3 : 05 Июль 2008, 18:54:05 »
А в новых драйверах 9550 поддержка есть? AGP, похоже, что не включен просто.

Возможно проблема кроется в этом:
Цитировать
X Fails to Load on Systems with Linux Kernel Version 2.6.x

This information applies to the following system configurations:

    * Linux kernel version 2.6.x
    * Any ATI Linux driver

A blank screen may appear momentarily when X starts to load. The following error message (or similar) may appear on the text console or in /var/log/XFree86.0.log:
(EE) fglrx(0): [agp] unable to acquire AGP, error ""xf86_ENODEV""xf86_ENODEV""

This is not a problem with the display driver.

Version 2.6 kernels require a second kernel module in addition to agpgart, which should be named similar to the manufacturer of your motherboard AGP chipset. This error message should occur if the other agp module is not loaded.

This issue can be worked around as follows:

   1. First make sure that agpgart is loading properly.
   2. To find out which AGP controller your motherboard uses, issue the following command: lspci | grep AGP
   3. To find a list of AGP related kernel modules installed on your machine, issue the following command and look for a module (*.ko file) that suits your AGP Controller: ls /lib/modules/`uname -r`/kernel/drivers/char/agp
   4. Use the modprobe command (as root) to load the module. For example: On a motherboard using a VIA® AGP Controller, you would load the via-agp.ko using modprobe as follows (notice that the trailing .ko is omitted): modprobe via-agp

Check the modprobe manpage for more information on loading kernel modules.

   5. To verify that the AGP module is already loaded, run lsmod as root. With the XServer running and the connection established, the usage count of this module must be greater than zero.

If you cannot find a suitable agp module for your motherboard, then you may want to upgrade to the latest version of the Linux kernel, or check your motherboard manufacturer's website for more information.
« Последнее редактирование: 05 Июль 2008, 18:58:44 от Di'Brain »

Оффлайн rootkithunter

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: ati driver error
« Ответ #4 : 05 Июль 2008, 19:50:02 »
в конфиге иксов fglrx заменил на ati, рестартанул иксы и все прерасно заработало, ati ccc пишет что теперь все гуд и никакие меса тут мы не юзаем :) , правда теперь если пустить fglrxinfo то получаем:
No protocol specified
Error: unable to open display (null)

Оффлайн Fliker-09

  • Активист
  • *
  • Сообщений: 338
  • Linux rocks and KDE too!
    • Просмотр профиля
Re: ati driver error
« Ответ #5 : 05 Июль 2008, 20:08:13 »
Потому что ati дрова это открытые дрова которые никак не связанны с fglrx ;). Кстати, они должны были заработать из коробки ведь у меня была такая карточка :).

Оффлайн rootkithunter

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: ati driver error
« Ответ #6 : 07 Июль 2008, 23:40:47 »
я бинарные брал атишные а не из репы :)

 

Страница сгенерирована за 0.056 секунд. Запросов: 23.