Форум русскоязычного сообщества Ubuntu


Автор Тема: нет звука Ubuntu 20.04.1 LTS  (Прочитано 4623 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн oriaraniar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
нет звука Ubuntu 20.04.1 LTS
« : 14 Декабря 2020, 00:14:26 »
Впервые поставил Ubuntu после долгого перерыва.
Плюс- минус настроил всё, кроме звука. С ним уже достаточно долго воюю.
В системе бегунки показывают, что звук вроде есть, но в ПульсАудио мои наушники отмечены как unplugged
Самое забавное, что в процессе поиска проблем вышел вот на эту статью https://www.linux.org.ru/forum/desktop/14431713 и после выполнения команд оттуда звук появился. Но, до первого ухода в сон, дальше он отвалился уже наглухо и манипуляции не помогают. Что можно сделать, чтоб звук появился и больше не пропадал?

Оффлайн jurganov

  • Активист
  • *
  • Сообщений: 856
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #1 : 14 Декабря 2020, 12:03:52 »
1) и что из описанного по ссылке ты делал??
2) там приведены выхлопы двух команд
aplay -l
lspci | grep Audio

Думаешь, мы сами должны догадываться что у тебя??
3) открой alsamixer
и нажми F6 скриншот приведи сюда, типа такого



тут видно и состояние наушников и выбор аудиокарты

Оффлайн oriaraniar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #2 : 15 Декабря 2020, 00:34:13 »
1 - дошел вот до этой команды,
sudo apt-get update;sudo apt-get dist-upgrade;
Тут появился звук.
2 -
feanor@feanor-MS-7508:~$ aplay -l
**** Список PLAYBACK устройств ****
карта 0: NVidia [HDA NVidia], устройство 0: ALC888 Analog [ALC888 Analog]
  Подустройства: 0/1
  Подустройство №0: subdevice #0
карта 0: NVidia [HDA NVidia], устройство 1: ALC888 Digital [ALC888 Digital]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 1: HDMI [HDA ATI HDMI], устройство 3: HDMI 0 [HDMI 0]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
feanor@feanor-MS-7508:~$ lspci | grep Audio
00:07.0 Audio device: NVIDIA Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Juniper HDMI Audio [Radeon HD 5700 Series]
3 https://ibb.co/5xbK679
https://ibb.co/93Nxhvd
https://ibb.co/mRBsxML

Плюс, такой момент.
Я, чтоб наделать скриншотов, загрузил систему. И всё работает, всё норм.
Решил, ради эксперимента в сон увести. И тут Ubuntu заглючила, в итоге ресетнул её.
После ресета звук пропал снова и пока возвращаться не хочет, хотя бегунки бегают
« Последнее редактирование: 17 Декабря 2020, 21:12:12 от Aleksandru »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #3 : 15 Декабря 2020, 01:48:45 »
в итоге ресетнул её.
Это не вполне понятно что значит. Если вернули в исходное состояние, то надо снова обновить.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн oriaraniar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #4 : 15 Декабря 2020, 02:02:25 »
Перезагрузил принудительно через ресет.
Никакие файлы после этого не менял.

Но в данном случае, я и до этого никакие файлы не менял. Я написал первый пост этого топика, выключил линукс, и до сегодня (уже вчера) не включал его.

Когда включил, звук самопочинился, до увода в сон. Потом пропал и перезагрузки уже не помогают.

upd
после очередной перезагрузки изменились устройства вывода
https://ibb.co/FDZmzYR
Пропал линейный выход в настройках, остался один цифровой.
« Последнее редактирование: 15 Декабря 2020, 02:30:02 от oriaraniar »

Оффлайн jurganov

  • Активист
  • *
  • Сообщений: 856
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #5 : 15 Декабря 2020, 06:07:56 »


№1 - перейти на это стрелками вправо/влево. Потом стрелкой вверх поднять уровень
№2 - выбрать стрелками свою звуковуху, как я понимаю - Nvidia

попробуй сделать так и отпишись

и попробуй поменять звуковуху по умолчанию
https://www.linux.org.ru/forum/general/11828658

советуют создать конфиг ~/.asoundrc

pcm.!default {
type hw
card 1
device 0
}
ctl.!default {
type hw
card 1
device 0

}
Цитировать
и перелогиниться, естественно. удобнее всего, имхо, смотреть нужные значения card и device в настройках звука audacious, внезапно. скорее всего у тебя будет hw:1,0, но если вдруг нет, то перебирай, пока не подойдет
« Последнее редактирование: 15 Декабря 2020, 06:19:07 от jurganov »

Оффлайн oriaraniar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #6 : 15 Декабря 2020, 09:45:44 »
Стрелками микшер я гонял, особо без результата.
По мануалу с ссылки прошелся, тоже эффекта нет.

Но сегодня повторился момент с изначально работающим звуком.
До ухода компа в сон всё работает штатно. Проблемы начинаются после ухода в сон и не лечатся перезагрузкой.
При этом после сна пропадает в настройках звука аналоговый выход, остаётся только цифровой.

Зато, если комп постоит ночь выключенный, то норм всё.

Такое ощущение, что есть какой-то косяк и он сбрасывается, когда напряжение с материнки снимается надолго. Или ещё какие кеши есть в убунте временные, хз.
Попробую ещё вечером поколдовать, если повторится эффект, то, возможно, проще будет режим сна выпилить из системы чем со звуком воевать
« Последнее редактирование: 15 Декабря 2020, 09:47:17 от oriaraniar »

Оффлайн jurganov

  • Активист
  • *
  • Сообщений: 856
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #7 : 15 Декабря 2020, 12:47:55 »
проще будет режим сна выпилить из системы чем со звуком воевать
у меня его просто нет ни спящего ни ждущего, поэтому мне трудно судить...

Оффлайн oriaraniar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #8 : 16 Декабря 2020, 09:50:16 »
В общем, делал конфиги, менял там идентификаторы.
Всё-равно звук то есть, то нет. Все бегунки бегают визуально, но звук не работает. Максимум, щелчки есть, когда уровень громкости меняешь.
Причём звук может пропасть и безо всякого сна, ставил виндовые проги, там wine ещё в процессе...
В какой момент, не отследил, но после манипуляций звук пропал и на текущий момент больше не появился, даже несмотря на перезагрузки системы и ночное отключение.

К слову, если создавать конфиг ~/.asoundrc, то alsamixer перестаёт открываться, говорит, что ошибка параметра, не знаю, влияет ли это или нет.

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1485
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #9 : 16 Декабря 2020, 11:55:38 »
Что можно сделать, чтоб звук появился и больше не пропадал?
Отказатся от режима сна, который часто барахлит на linux. Сон не гибернация, много не наэкономишь, а монитор и так погаснет через выставленное тобой время. Выпиливать тут нечего, просто в настройках питания отключить сваливание в сон, на кнопке оставить выключение, что-бы монитор погас из 3-х движков два нижних влево, верхним третьим устанавливаем время.

Оффлайн oriaraniar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #10 : 17 Декабря 2020, 20:17:40 »
Проблема даже не в спящем режиме. А в том, что нельзя угадать, какие устройства будут при перезагрузке очередной.
Вот сейчас загрузил - в настройках звука только фиктивный выход. С утра было всё норм.
При этом, даже если есть нужная аудиокарта, то звук то есть, то нет, хотя бегунки бегают. Есть предположение, что звук порой переключается на переднюю панель, но самой передней панели нет, проверить не на чем.
Если есть конфиги из ссылок в этой теме, не открывается alsamixer, если конфигов нет - открывается, но каждый раз разное количество столбиков.
Короче, полный ахтунг, я не понимаю, как такое может быть и как вообще система работает.

Оффлайн jurganov

  • Активист
  • *
  • Сообщений: 856
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #11 : 18 Декабря 2020, 05:53:48 »
Я думаю, проблемы в спящем режиме.
от него проблемы спокон века. и на венде были (у меня видюха ASUS на Тусле после ухода в сон не просыпалась), и на линуксе.
У меня нет спящего режима. нет и проблем. Хотя может быть причина в том, что у меня MATE, а не Gnome3

Оффлайн oriaraniar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #12 : 19 Декабря 2020, 00:51:56 »
Точно не спящий режим.
Вот буквально сейчас.
Систему загрузил - всё норм.
Открыл браузер, проверил, есть ли звук в ВК - норм.
Поставил с маркета игрушку - всё норм.
Поиграл часа 2-3 - тоже норм.
Закрыл игру.
Почитал всякие форумы. Тоже порядка 2 часов.
Включаю звук в ВК - звука нет.
Комп даже экран не блокировал, я всё время за ним работал. А звук в процессе работы пропал. Пропал в период тишины, когда ничего не звучало.

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1485
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #13 : 19 Декабря 2020, 02:19:24 »
Пропал в период тишины, когда ничего не звучало
Запусти в терминале альса микшер, там курсором перейди на авто мюте и отключи эту функцию, по умолчанию она включена. Тоже самое можно проделать правя конфиг, но тут я не в курсах который, их там как грязи... конфигов альсы, пульсы.

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1316
    • Просмотр профиля
Re: нет звука Ubuntu 20.04.1 LTS
« Ответ #14 : 19 Декабря 2020, 18:44:24 »
А звук в процессе работы пропал.
Ну, наверно, не в процессе работы, а после -
Закрыл игру.
Под себя монополизирует ресурс, но не возвращает.

 

Страница сгенерирована за 0.071 секунд. Запросов: 25.