Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Следующие пакеты имеют неудовлетворённые зависимости...  (Прочитано 1705 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dobronravov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Приветствую!

Последнее время цп стал нагружаться, все 4 ядра и память забивается. И оперативка 4 Гб и подкачка 2Гб. Хотя пользуюсь как и раньше только хромом. Решил на руткиты проверить:


sudo apt install clamav clamtk
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 bsd-mailx : Зависит: default-mta или
                             mail-transport-agent
 clamav : Зависит: clamav-freshclam (>= 0.99.4+addedllvm) но он не будет установлен или
                          clamav-data
          Зависит: libclamav7 (>= 0.99.4) но он не будет установлен
          Рекомендует: clamav-base но он не будет установлен
 clamtk : Зависит: clamav-freshclam (>= 0.95) но он не будет установлен или
                          clamav-data
          Зависит: libgtk2-perl (>= 2:1.241) но он не будет установлен
          Зависит: libtext-csv-perl но он не будет установлен
          Зависит: libjson-perl но он не будет установлен
          Зависит: gnome-icon-theme
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  gir1.2-geocodeglib-1.0 glib-networking:i386 libatk-bridge2.0-0:i386
  libatk1.0-0:i386 libatspi2.0-0:i386 libcairo-gobject2:i386 libcolord2:i386
  libdatrie1:i386 libdbusmenu-glib4:i386 libdbusmenu-gtk4:i386 libepoxy0:i386
  libgail-common:i386 libgail18:i386 libgdk-pixbuf2.0-0:i386
  libgraphite2-3:i386 libgtk-3-0:i386 libgtk2.0-0:i386 libharfbuzz0b:i386
  libjson-glib-1.0-0:i386 libllvm8 libnotify4:i386 libnspr4:i386 libnss3:i386
  libopenshot18 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 libproxy1v5:i386 librest-0.7-0:i386
  libsoup-gnome2.4-1:i386 libsoup2.4-1:i386 libthai0:i386
  libwayland-client0:i386 libwayland-cursor0:i386 libwayland-egl1:i386
  libxkbcommon0:i386 libxss1:i386 libxtst6:i386 notification-daemon:i386
  ubuntu-web-launchers
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  postfix
Предлагаемые пакеты:
  procmail postfix-mysql postfix-pgsql postfix-ldap postfix-pcre postfix-lmdb
  postfix-sqlite sasl2-bin dovecot-common resolvconf postfix-cdb postfix-doc
Следующие НОВЫЕ пакеты будут установлены:
  postfix
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 8 пакетов не обновлено.
Установлено или удалено не до конца 18 пакетов.
Необходимо скачать 0 B/1 148 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 076 kB.
Хотите продолжить? [Д/н] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Чтение базы данных … на данный момент установлено 243412 файлов и каталогов.)
Подготовка к распаковке …/postfix_3.3.0-1_amd64.deb …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/postfix_3.3.0-1_amd64.deb (--unpack):
 new postfix package pre-installation script subprocess returned error exit status 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/postfix_3.3.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Последнее редактирование: 17 Декабрь 2020, 20:31:16 от dobronravov »

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1268
    • Просмотр профиля
От рута идёшь в /var/lib/dpkg/status, там удаляешь внимательно строчки проблемного пакета,
например нормально установленный пакет начинается с...

Package: python-apt-common (имя пакета)
Status: install ok installed (состояние установки)
Пакеты разделены интервалом, ошибится трудно.
 
sudo apt install -f
sudo apt autoremove
sudo apt clean
sudo apt update
sudo apt upgrade
sudo dpkg --configure -a
« Последнее редактирование: 17 Декабрь 2020, 22:35:05 от vladimirzhuravlev »

Оффлайн dobronravov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
От рута идёшь в /var/lib/dpkg/status, там удаляешь внимательно строчки проблемного пакета,
например нормально установленный пакет начинается с...

Отредактировал файл status, удали вот это, сохранил изменения

Package: postfix
Status: install ok not-installed
Priority: optional
Section: mail
Architecture: amd64

других неустановленных не было. Затем ввел sudo apt install -f

sudo apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  gir1.2-geocodeglib-1.0 glib-networking:i386 libatk-bridge2.0-0:i386
  libatk1.0-0:i386 libatspi2.0-0:i386 libcairo-gobject2:i386 libcolord2:i386
  libdatrie1:i386 libdbusmenu-glib4:i386 libdbusmenu-gtk4:i386 libepoxy0:i386
  libgail-common:i386 libgail18:i386 libgdk-pixbuf2.0-0:i386
  libgraphite2-3:i386 libgtk-3-0:i386 libgtk2.0-0:i386 libharfbuzz0b:i386
  libjson-glib-1.0-0:i386 libllvm8 libnotify4:i386 libnspr4:i386 libnss3:i386
  libopenshot18 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 libproxy1v5:i386 librest-0.7-0:i386
  libsoup-gnome2.4-1:i386 libsoup2.4-1:i386 libthai0:i386
  libwayland-client0:i386 libwayland-cursor0:i386 libwayland-egl1:i386
  libxkbcommon0:i386 libxss1:i386 libxtst6:i386 notification-daemon:i386
  ubuntu-web-launchers
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  postfix
Предлагаемые пакеты:
  procmail postfix-mysql postfix-pgsql postfix-ldap postfix-pcre postfix-lmdb
  postfix-sqlite sasl2-bin dovecot-common resolvconf postfix-cdb postfix-doc
Следующие НОВЫЕ пакеты будут установлены:
  postfix
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 8 пакетов не обновлено.
Установлено или удалено не до конца 18 пакетов.
Необходимо скачать 0 B/1 148 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 076 kB.
Хотите продолжить? [Д/н] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Выбор ранее не выбранного пакета postfix.
(Чтение базы данных … на данный момент установлено 243412 файлов и каталогов.)
Подготовка к распаковке …/postfix_3.3.0-1_amd64.deb …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/postfix_3.3.0-1_amd64.deb (--unpack):
 new postfix package pre-installation script subprocess returned error exit status 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/postfix_3.3.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

В итоге в status снова появился этот же не установленный пакет

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2442
    • Просмотр профиля
Закройте synaptic и повторите процедуру.

Пользователь добавил сообщение 18 Декабрь 2020, 06:00:06:
locked by another process:
Заблокировано другим процессом
« Последнее редактирование: 18 Декабрь 2020, 06:00:06 от Dzhoser »

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1268
    • Просмотр профиля
Закройте synaptic
Так у него при этой работе синаптик и не должен быть в запуске, он ведь блокирует процесс. Снова удалить из конфига пакет и читать внимательно, что пишет терминал, если видим там "Для их удаления используйте «sudo apt autoremove», сразу используем эту команду.

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2442
    • Просмотр профиля
vladimirzhuravlev, Если вы внимательно посмотрите вывод который предоставил ТС, то там написано что пакет не может быть удален так как
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

Пользователь добавил сообщение 18 Декабрь 2020, 13:18:54:
Покажите вывод
lsof +d /var/cache/debconf/config.dat
« Последнее редактирование: 18 Декабрь 2020, 13:18:54 от Dzhoser »

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1158
    • Просмотр профиля
На виртуалке для всяких издевательств постоянно установлено 5-6 систем.
Очень часто встречаю что стандартная графическая обновлялка блокирует обновления и установку ПО (в консоли) на Xubuntu, Ubuntu сразу после загрузки системы.
Приходится ждать когда она там свои манипуляции с репозиториями сделает.
Чего никогда не встречается на Kubuntu, Debian, Mint.

Не совсем по теме правда.

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4464
    • Просмотр профиля
Цитировать
стандартная графическая обновлялка блокирует обновления и установку ПО (в консоли) на Xubuntu, Ubuntu сразу после загрузки системы
Поэтому, все эти обновлялки-оповещалки-предупреждалки сразу удаляю. Только после этого можно спокойно пользоваться.

Оффлайн dobronravov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Покажите вывод

lsof +d /var/cache/debconf/config.dat
lsof: WARNING: not a directory: /var/cache/debconf/config.dat
lsof 4.89
 latest revision: ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/
 latest FAQ: ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/FAQ
 latest man page: ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_man
 usage: [-?abhKlnNoOPRtUvVX] [+|-c c] [+|-d s] [+D D] [+|-E] [+|-e s] [+|-f[gG]]
 [-F [f]] [-g [s]] [-i [i]] [+|-L [l]] [+m [m]] [+|-M] [-o [o]] [-p s]
 [+|-r [t]] [-s [p:s]] [-S [t]] [-T [t]] [-u s] [+|-w] [-x [fl]] [--] [names]
Use the ``-h'' option to get more help information.


«sudo apt autoremove» вводил сразу после "sudo apt install -f", вот вывод

sudo apt autoremove
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 bsd-mailx : Зависит: default-mta или
                             mail-transport-agent
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).


sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  gir1.2-geocodeglib-1.0 glib-networking:i386 libatk-bridge2.0-0:i386
  libatk1.0-0:i386 libatspi2.0-0:i386 libcairo-gobject2:i386 libcolord2:i386
  libdatrie1:i386 libdbusmenu-glib4:i386 libdbusmenu-gtk4:i386 libepoxy0:i386
  libgail-common:i386 libgail18:i386 libgdk-pixbuf2.0-0:i386
  libgraphite2-3:i386 libgtk-3-0:i386 libgtk2.0-0:i386 libharfbuzz0b:i386
  libjson-glib-1.0-0:i386 libllvm8 libnotify4:i386 libnspr4:i386 libnss3:i386
  libopenshot18 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 libproxy1v5:i386 librest-0.7-0:i386
  libsoup-gnome2.4-1:i386 libsoup2.4-1:i386 libthai0:i386
  libwayland-client0:i386 libwayland-cursor0:i386 libwayland-egl1:i386
  libxkbcommon0:i386 libxss1:i386 libxtst6:i386 notification-daemon:i386
  ubuntu-web-launchers
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  postfix
Предлагаемые пакеты:
  procmail postfix-mysql postfix-pgsql postfix-ldap postfix-pcre postfix-lmdb
  postfix-sqlite sasl2-bin dovecot-common resolvconf postfix-cdb postfix-doc
Следующие НОВЫЕ пакеты будут установлены:
  postfix
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 8 пакетов не обновлено.
Установлено или удалено не до конца 18 пакетов.
Необходимо скачать 0 B/1 148 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 4 076 kB.
Хотите продолжить? [Д/н] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Чтение базы данных … на данный момент установлено 243412 файлов и каталогов.)
Подготовка к распаковке …/postfix_3.3.0-1_amd64.deb …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: ошибка при обработке архива /var/cache/apt/archives/postfix_3.3.0-1_amd64.deb (--unpack):
 new postfix package pre-installation script subprocess returned error exit status 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/postfix_3.3.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

"bsd-mailx" "default-mta", "mail-transport-agent" - в файле "status" распакованы и установлены

замкнутый круг какой-то получается, или я не догоняю...


Пользователь добавил сообщение 18 Декабрь 2020, 15:13:41:
На виртуалке для всяких издевательств постоянно установлено 5-6 систем.

у меня на ssd кроме ubuntu еще винда 10 стоит. Не помню правда, что первым ставил, но были проблемы с грабом
« Последнее редактирование: 18 Декабрь 2020, 15:13:41 от dobronravov »

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1485
    • Просмотр профиля
Следующие НОВЫЕ пакеты будут установлены:
  postfix

Вы постфикс настроили? на вопросы инсталлятора ответили?

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2442
    • Просмотр профиля
dobronravov, закройте все программы 
Перейдите в консольный режим
Ctrl+Alt+F2 там введите свой логин и пароль. Пароль при вводе не отображается.
В открывшейся консоли выполните команды
sudo apt avtocleansudo apt install -fsudo apt install updatesudo apt install upgrade -yПерейдите в Графический  режим
Ctrl+Alt+F7

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1268
    • Просмотр профиля
Хотя пользуюсь как и раньше только хромом
Ну не знаю... наверное юзаешь не только хром но и почтовик установлен, ибо ругается в основном в его сторону ?
Postfix — агент передачи почты (MTA — mail transfer agent). Если тандерболд установлен то продолжай дальше, лично я сразу всё относящееся к почте удаляю через синаптик. Открываю подраздел почта и удаляю всё, что там имеется. Правда сейчас синаптик не даст удалить этот мусор. Он пишет ошибку (случается у меня частенько при тестах), эту ошибку я вбиваю в поиск браузера. Обычно 2-3 команды из найденных в сети советов и всё приходит в норму. У тебя по идее ошибки были и до того, как ты начал что-то устанавливать в плане антивиря в части bsd-mailx : Зависит: default-mta или mail-transport-agent. Просто если при этом ты заюзал-бы синаптик, он тебе просигнализировал-бы, ведь при имеющихся поломанных пакетах он ничего не даёт удалять-устанавливать. Приложение clamav есть в синаптике, зачем без опыта лезть в терминал для установки ? Пытаясь установить clamav через синаптик, тот тебя сразу-бы отправил сначала чинить систему, а потом уж и устанавливать что-то можно было.

Оффлайн dobronravov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Cлетела Ubuntu, как обычно на моем hp. Надоело. Буду ставить винду. Всем спасибо.

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2442
    • Просмотр профиля
Может проблема в жёстком диске?

Оффлайн dobronravov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Может проблема в жёстком диске?
Проблемы были с самой первой установки Убунты, долго драйвера не мог найти на адаптеры вай-фай и блютуз. Раза 3 слетала после обновлений. 2 раза решал проблему, помню граб слетел, и один раз просто переустанавливал. По мере поиска решений не однократно сталкивался с отзывами об установке дистрибутивов на ноутбуки фирмы hp и везде писали, что это та еще проблема. Говорят, hp очень не любит бесплатные ОС и всячески мешает их использованию на своей продукции.

Жесткий не проверял, но вроде нормальный, не помню чтобы на него ругалась Ubuntu

 

Страница сгенерирована за 0.075 секунд. Запросов: 26.