Форум русскоязычного сообщества Ubuntu


Автор Тема: Ошибки при запуске kazam-а  (Прочитано 438 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mstdmstd

  • Автор темы
  • Активист
  • *
  • Сообщений: 309
    • Просмотр профиля
Ошибки при запуске kazam-а
« : 28 Декабрь 2020, 19:11:20 »
Всем привет

Нужно записать видео на своем Kubuntu 18
Установил kazam вкдлючая рекомендуемую либу
python3-xlib python3-cairo
как я вычитал тут
https://vitux.com/screen-recording-with-kazam-on-ubuntu/

Но при запуске получил ошибку
$ kazam
/usr/bin/kazam:32: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
Traceback (most recent call last):
  File "<frozen importlib._bootstrap>", line 888, in _find_spec
AttributeError: 'DynamicImporter' object has no attribute 'find_spec'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/kazam", line 147, in <module>
    from kazam.app import KazamApp
  File "/usr/lib/python3/dist-packages/kazam/app.py", line 36, in <module>
    from kazam.backend.prefs import *
  File "/usr/lib/python3/dist-packages/kazam/backend/prefs.py", line 30, in <module>                                                                                                                                   
    from kazam.backend.webcam import Webcam                                                                                                                                                                           
  File "/usr/lib/python3/dist-packages/kazam/backend/webcam.py", line 24, in <module>                                                                                                                                 
    from gi.repository import GObject, GUdev                                                                                                                                                                           
  File "/usr/lib/python3/dist-packages/gi/importer.py", line 127, in find_module                                                                                                                                       
    'introspection typelib not found' % namespace)                                                                                                                                                                     
ImportError: cannot import name GUdev, introspection typelib not found       

Проверяю версию :
kazam --version
/usr/bin/kazam:32: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
kazam 1.5.3 'NX-72307'
serge@AtHome:/mnt/_work_sdb8/wwwroot/lar/fantasylab.io/laravel.gotoconsult.io$ lsb_release -d; uname -r; uname -i
Description:    Ubuntu 18.04.5 LTS
4.15.0-128-generic
x86_64

Поискм в нете я нашем возможное решение чтобы закоментарить строки вроде
Keybinder.bind
как описано тут :  https://itectec.com/ubuntu/ubuntu-kazam-fails-with-pygiwarning-gtk-was-imported-without-specifying-a-version-first/

я закоментарил порядка 5 строк - не помогло и после растарта OS

Не подскажите как это вылечить ?

Спасибо!

Оффлайн Percoir

  • Участник
  • *
  • Сообщений: 163
  • Ubuntu 20.04
    • Просмотр профиля
Re: Ошибки при запуске kazam-а
« Ответ #1 : 28 Декабрь 2020, 20:44:16 »
Не подскажу конкретно по такому случаю.
С Kazamom и у меня проблемы были. Звук он не пишет, но я ставил из репозитория 20.04, а не как Вы. Там версия 1.4.5.
Если не принципиально именно Kazam, то vokoscreen-ng работает без проблем.
На нем остановился, перепробовав разные программы для записи скринкастов.

Оффлайн mstdmstd

  • Автор темы
  • Активист
  • *
  • Сообщений: 309
    • Просмотр профиля
Re: Ошибки при запуске kazam-а
« Ответ #2 : 29 Декабрь 2020, 07:26:06 »
Я нашел gtk-recordmydesktop - работает со звуком

А vokoscreen-ng работает со звуком ?

Оффлайн Percoir

  • Участник
  • *
  • Сообщений: 163
  • Ubuntu 20.04
    • Просмотр профиля
Re: Ошибки при запуске kazam-а
« Ответ #3 : 29 Декабрь 2020, 09:34:56 »
А vokoscreen-ng работает со звуком ?
Скринкасты пишутся со звуком, да.
Или в каком смысле работает со звуком?
И кстати, у Вас же Kubuntu, а vokoscreen-ng написан на QT.

 

Страница сгенерирована за 0.07 секунд. Запросов: 26.