Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблема с upgrade  (Прочитано 815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vikingasveitin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Проблема с upgrade
« : 08 Января 2021, 11:13:25 »
Добрый день, возникла проблема с командой upgrade(собственно, примерно такая же проблема была и с установкой пакета curl).
При выполнении команды всплывает ошибка:
"При обработке следующих пакетов произошли ошибки:
 tzdata
 xserver-xorg-legacy
 rtbth-dkms"
Если покопаться в процессе установки можно заметить такие ошибки:
"dpkg: ошибка при обработке пакета rtbth-dkms (--configure):
 installed rtbth-dkms package post-installation script subprocess returned error exit status 1"(такая же, как и при установке curl)"

"dpkg: ошибка при обработке пакета xserver-xorg-legacy (--configure):
 installed xserver-xorg-legacy package post-installation script subprocess returned error exit status 1"

"dpkg: ошибка при обработке пакета tzdata (--configure):
 installed tzdata package post-installation script subprocess returned error exit status 1"
Что делать?
« Последнее редактирование: 08 Января 2021, 19:22:29 от ALiEN175 »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #1 : 08 Января 2021, 12:22:54 »
Что хоть за система у вас?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Vikingasveitin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #2 : 08 Января 2021, 12:26:01 »
Что хоть за система у вас?

Ubuntu 20.04 LTS

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #3 : 08 Января 2021, 12:31:15 »
Это появилось недавно? Вообще пакет rtbth-dkms, насколько мне известно, не собирается под современные ядра.
А с другими странно. У вас видимо какие-то PPA подключены.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Vikingasveitin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #4 : 08 Января 2021, 12:40:22 »
Это появилось недавно? Вообще пакет rtbth-dkms, насколько мне известно, не собирается под современные ядра.
А с другими странно. У вас видимо какие-то PPA подключены.

С rtbth - относительно недавно: за несколько часов до создания данного обсуждения, когда пытался настроить камеру Intel RealSence. С оставшимися библиотеками - за несколько минут.
Установленные ранее PPA не вспомню. Окружение Cinnamon, как минимум, был точно установлен не через PPA.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #5 : 08 Января 2021, 12:44:29 »
С rtbth - относительно недавно:
То есть вы этот rtbth установили вот как раз недавно?
Установленные ранее PPA не вспомню.
А что мешает не вспоминать, а посмотреть?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Vikingasveitin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #6 : 08 Января 2021, 12:52:25 »
С rtbth - относительно недавно:
То есть вы этот rtbth установили вот как раз недавно?
Установленные ранее PPA не вспомню.
А что мешает не вспоминать, а посмотреть?

1. По крайней мере пытался. На одном из этапов установка зависала.
2. Из сторонних PPA:
http://dl.google.com/linux/chrome/debstable/main
http://ppa.launchpad.net/blaze/rtbth-dkms/ubuntufocal/main

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #7 : 08 Января 2021, 12:56:15 »
По крайней мере пытался. На одном из этапов установка зависала.

Какое сейчас ядро? Если 5.8, то загрузитесь с 5.4 и посмотрите что получится.

Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Vikingasveitin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #8 : 08 Января 2021, 13:36:20 »
По крайней мере пытался. На одном из этапов установка зависала.

Какое сейчас ядро? Если 5.8, то загрузитесь с 5.4 и посмотрите что получится.

Проблема решена, но не данным методом. По факту Secure Boot работает, но все разы я просто не до конца устанавлевал его. И после корректной его установки команда upgrade спокойно выполнилась.
Но остался лишь 1 вопрос: во время установки Secure Boot появлялось окно с описанием данной функции, и его нужно было подтвердить. И тогда я лишь случайным образом смог перейти к вводу пароля. Для будущих случаев как подтверждать подобные окна?(когда Enter не работает)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13876
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с upgrade
« Ответ #9 : 08 Января 2021, 13:40:17 »
Vikingasveitin,
Что вы называете установкой Secure Boot? Вы ничего не путаете? Это функция биоса, которую можно включить и выключить. Что вы там устанавливаете непонятно.
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.04 секунд. Запросов: 25.