Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: vbox/vwmare/Win 10 - Зависает вся система при запуске виртуальной машины  (Прочитано 1598 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andrew.progs

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Доброго времени суток!
Система kubuntu 20.04, есть 2 ssd - один nvme, второй - sata. На sata установлена kubuntu, на nvme - windows 10.
Одно время работал на fedora, вполне успешно пробросил диск nvme в виртуалку(Virtual Box) и все работало прекрасно около месяца до момента, пока не перестало, похоже, что случайно. Симптомы - в случайный момент полностью зависает хост-система при запущенной виртуалке. Ctrl+Alt+F1 не работают, Caps Lock тоже не реагирует на нажатия. То есть она могла проработать и 30 минут, и 30 секунд, от действий в обоих системах, кажется, не зависело. Т.к. нужно было работать, а не бодаться с системой, на некоторое время переехал обратно на Windows. Сейчас решил опять вернуться на linux, установил kubuntu 20.04, думал проблема в нестабильности fedora. Пробросил диск, запустил и получил те же симптомы. Подумал, что проблема в virtual box, установил vmware player, пробросил диск - в начале были те же симптомы, сейчас только доходит до загрузки Windows - сразу же все зависает, даже не доходит до окна входа в систему.
Пробовал различные конфигурации(менял кол-во процессоров, RAM, включал\отключал 3d-акселерацию и все остальные настройки, которые мог) - ничего не помогает. Пробовал установку на виртуальный диск - система установилась нормально и запускается, но сильно не тестировал, т.к. нужен вариант именно с реальным жестким диском.
Подскажите куда смотреть, я в linux относительно новичек, не знаю даже как идентифицировать проблему.

Характеристики:
ЦП: HexaCore Intel Core i7-8750H, 3900 MHz (39 x 100)
Системная плата: Lenovo Legion Y530-15ICH
Чипсет системной платы: Intel Cannon Point HM370, Intel Coffee Lake-H
Системная память: 16257 МБ  (DDR4 SDRAM)
Видеоадаптер: GeForce GTX 1050 Ti  (4 ГБ)

Пробовал с драйвером nouveau, а также с проприетарным драйвером nvidia 460

UPD: Во время зависания начинает шуметь кулер, как будто происходит какая-то работа на CPU
« Последнее редактирование: 16 Январь 2021, 23:55:00 от andrew.progs »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2425
    • Просмотр профиля
Вывод команды из Ubuntu free -mпри зависшей виртуалке

Оффлайн andrew.progs

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Вся система полностью зависает, у меня нет возможности ввести команду - помогает только зажатие кнопки выключения. В первом сообщении описано, что Ctrl+Alt+F1 и Caps Lock не дают никакой реакции.
То есть не реагирует на ввод как гостевая система, так и хост
« Последнее редактирование: 16 Январь 2021, 23:54:02 от andrew.progs »

Оффлайн ALiEN175

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 4708
  • Capture the truth
    • Просмотр профиля
ASUS P5K-C :: Intel Xeon E5450 :: 8 GB RAM :: Nvidia 8500GT :: XFCE
SAMSUNG N150 :: Intel Atom N450 :: 2 GB RAM :: Intel GMA3150 :: XFCE

Оффлайн andrew.progs

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Да, извиняюсь, неправильно написал. Имел ввиду этот шорткат. Текст сообщений изменил, чтобы не вводить дальше в заблуждение.
Суть остается та же - система зависает намертво и не реагирует ни на какие нажатия клавиш, помогает только hard reset
« Последнее редактирование: 16 Январь 2021, 23:53:35 от andrew.progs »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2425
    • Просмотр профиля
Показывайте
sudo dmesg | grep -i "error\|warn\|fail"sudo journalctl -xe

Оффлайн andrew.progs

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
sudo dmesg | grep -i "error\|warn\|fail"

[    0.248591] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.XHC.RHUB.TPLD], AE_ALREADY_EXISTS (20190816/dswload2-326)
[    0.248599] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
[    0.248664] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS01], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248669] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248703] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS02], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248707] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248740] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS03], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248743] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248776] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS04], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248779] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248812] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS05], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248815] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248847] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS06], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248851] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248883] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS07], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248887] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248919] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS08], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248922] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248954] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS09], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248957] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.248990] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS10], AE_NOT_FOUND (20190816/dswload2-162)
[    0.248993] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.249025] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS11], AE_NOT_FOUND (20190816/dswload2-162)
[    0.249028] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.249060] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS12], AE_NOT_FOUND (20190816/dswload2-162)
[    0.249064] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.249096] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.HS13], AE_NOT_FOUND (20190816/dswload2-162)
[    0.249099] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.249133] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.XHC.RHUB.HS14._UPC], AE_ALREADY_EXISTS (20190816/dswload2-326)
[    0.249137] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
[    0.249141] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.XHC.RHUB.HS14._PLD], AE_ALREADY_EXISTS (20190816/dswload2-326)
[    0.249144] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
[    0.250979] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.USR1], AE_NOT_FOUND (20190816/dswload2-162)
[    0.250984] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.250989] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.USR2], AE_NOT_FOUND (20190816/dswload2-162)
[    0.250992] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251030] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS01], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251034] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251067] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS02], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251070] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251103] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS03], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251106] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251139] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS04], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251142] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251175] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS05], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251178] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251210] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS06], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251214] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251246] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS07], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251249] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251281] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS08], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251285] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251317] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS09], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251320] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.251352] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.XHC.RHUB.SS10], AE_NOT_FOUND (20190816/dswload2-162)
[    0.251355] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.252384] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.I2C2.TPD0], AE_NOT_FOUND (20190816/dswload2-162)
[    0.252389] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.252426] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.I2C3.TPL1], AE_NOT_FOUND (20190816/dswload2-162)
[    0.252430] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.256042] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.PEG0.PEGP._ON], AE_ALREADY_EXISTS (20190816/dswload2-326)
[    0.256050] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
[    0.256055] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.PEG0.PEGP._OFF], AE_ALREADY_EXISTS (20190816/dswload2-326)
[    0.256059] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
[    0.733032] Initramfs unpacking failed: Decoding failed
[    0.774940] pcieport 0000:00:1d.0: DPC: error containment capabilities: Int Msg #0, RPExt+ PoisonedTLP+ SwTrigger+ RP PIO Log 4, DL_ActiveErr+
[    0.775759] pcieport 0000:00:1d.5: DPC: error containment capabilities: Int Msg #0, RPExt+ PoisonedTLP+ SwTrigger+ RP PIO Log 4, DL_ActiveErr+
[    0.901731] RAS: Correctable Errors collector initialized.
[    0.910570] Error adding keys to platform keyring UEFI:db
[    2.783671] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro
[    5.149890] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20190816/nsarguments-59)

sudo journalctl -xe

-- A start job for unit UNIT has begun execution.
--
-- The job identifier is 122.
Jan 17 11:48:14 andre-workstation dbus-daemon[2103]: [session uid=1000 pid=2103] Successfully activated service 'org.gtk.vfs.Metadata'
Jan 17 11:48:14 andre-workstation systemd[2091]: Started Virtual filesystem metadata service.
-- Subject: A start job for unit UNIT has finished successfully
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- A start job for unit UNIT has finished successfully.
--
-- The job identifier is 122.
Jan 17 11:48:18 andre-workstation rtkit-daemon[2024]: Supervising 5 threads of 2 processes of 2 users.
Jan 17 11:48:18 andre-workstation rtkit-daemon[2024]: Supervising 5 threads of 2 processes of 2 users.
Jan 17 11:48:35 andre-workstation sudo[3241]: pam_unix(sudo:auth): Couldn't open /etc/securetty: No such file or directory
Jan 17 11:48:38 andre-workstation sudo[3241]: pam_unix(sudo:auth): Couldn't open /etc/securetty: No such file or directory
Jan 17 11:48:38 andre-workstation sudo[3241]:    andre : TTY=pts/1 ; PWD=/home/andre ; USER=root ; COMMAND=/usr/bin/dmesg
Jan 17 11:48:38 andre-workstation sudo[3241]: pam_unix(sudo:session): session opened for user root by andre(uid=0)
Jan 17 11:48:38 andre-workstation sudo[3241]: pam_unix(sudo:session): session closed for user root
Jan 17 11:48:39 andre-workstation systemd-resolved[1184]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
Jan 17 11:50:56 andre-workstation sudo[3309]:    andre : TTY=pts/1 ; PWD=/home/andre ; USER=root ; COMMAND=/usr/bin/journalctl -xe
Jan 17 11:50:56 andre-workstation sudo[3309]: pam_unix(sudo:session): session opened for user root by andre(uid=0)
Jan 17 11:51:12 andre-workstation sudo[3309]: pam_unix(sudo:session): session closed for user root
Jan 17 11:51:27 andre-workstation sudo[3319]:    andre : TTY=pts/1 ; PWD=/home/andre ; USER=root ; COMMAND=/usr/bin/journalctl -xe
Jan 17 11:51:27 andre-workstation sudo[3319]: pam_unix(sudo:session): session opened for user root by andre(uid=0)

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2425
    • Просмотр профиля
Отключите в BIOS secureboot, если на сайте производителя есть новая версия обновите ее

Оффлайн andrew.progs

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
BIOS самый новый, Secure Boot отключил и теперь виртуалка запускается, спасибо большое за помощь!
Если дальше будут проблемы - я напишу сразу вывод этих двух команд
Еще раз спасибо за помощь!

Оффлайн Дед Дима

  • Новичок
  • *
  • Сообщений: 46
    • Просмотр профиля
Интересно, как это BIOS может влиять на запуск ВМ, пусть и Виндовс... развить бы тему.
и кста, галку бы поставить - решено.

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2425
    • Просмотр профиля
Очень даже может. Например если отключена функция виртуализации.

Оффлайн andrew.progs

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
и кста, галку бы поставить - решено.
К сожалению, проблема не решена. Не было времени нормально протестировать, зашло на экран логина - и я подумал, что уже все в порядке. Но оказалось, что проблема никуда не ушла, сейчас то же самое, разве что могу дойти аж до ввода пароля. Дальше опять зависание

Подумал может дело в перегреве - отключил Hyper Threading, дал виртуалке одно ядро и стал мониторить температуру в реальном времени до зависания. GPU: 43, CPU: <78, значит это не перегрев. Та даже если перегрев - то возникает вопрос почему? Как на kubuntu, так и на Windows запускал ресурсоемкие процессы, ничего подобного не было.

По логам. Вот содержимое /var/log/syslog с момента запуска виртуалки до зависания:
Jan 17 18:10:06 andre-workstation kernel: [   67.232750] /dev/vmmon[2889]: PTSC: initialized at 2207998000 Hz using TSC, TSCs are synchronized.
Jan 17 18:10:06 andre-workstation kernel: [   67.390378] /dev/vmmon[2889]: Monitor IPI vector: ff
Jan 17 18:10:06 andre-workstation kernel: [   67.390382] /dev/vmmon[2889]: HV      IPI vector: f2
Jan 17 18:10:08 andre-workstation wpa_supplicant[1179]: wlp7s0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-72 noise=9999 txrate=234000
Jan 17 18:10:11 andre-workstation org.kde.kglobalaccel[2161]: org.kde.kwindowsystem.keyserver.x11: Your keyboard setup doesn't provide a key to use for meta. See 'xmodmap -pm' or 'xkbcomp $DISPLAY'
Jan 17 18:10:11 andre-workstation org.kde.kglobalaccel[2161]: message repeated 12 times: [ org.kde.kwindowsystem.keyserver.x11: Your keyboard setup doesn't provide a key to use for meta. See 'xmodmap -pm' or 'xkbcomp $DISPLAY']
Jan 17 18:10:18 andre-workstation wpa_supplicant[1179]: wlp7s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-65 noise=9999 txrate=175600

Подумал, что есть вероятность того, что ядро не успевает записать в файл ошибку, поэтому пробовал как dmesg, так и journalctl с параметром follow - там то же самое, ошибок связанных никаких нет, либо я что-то неправильно понимаю. Разве что сейчас попробую решить проблему с meta, но что-то мне подсказывает, что проблема не в этом

Оффлайн Дед Дима

  • Новичок
  • *
  • Сообщений: 46
    • Просмотр профиля
попробуй top, может им отловишь.

Оффлайн andrew.progs

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
попробуй top, может им отловишь
А куда там смотреть и что ловить? Это же вроде диспетчер задач консольный. Проблема не в ресурсах - вм отдано одно ядро и 4Гб оперативки при 16ти системных и 32Гб свопа. И не в температуре - мониторинг показывает чуть завышенные значения, но далеко не критичные, чтобы давать такие эффекты

Оффлайн Дед Дима

  • Новичок
  • *
  • Сообщений: 46
    • Просмотр профиля
в терминале запусти и смотри на каком процессе виснет

 

Страница сгенерирована за 0.071 секунд. Запросов: 25.