Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: После загрузки Windows 10 перестал загружаться Grub  (Прочитано 845 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Aleksander001

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Здравствуйте!
Почитав форум, я на шёл много решений по моей проблеме, добросовестно испробовал всё.
Результат, всё так же после загрузки Windows 10 Pro - Grub не отображается.
Может кто ещё чего посоветует.
Вот данные по ПК:
Системная плата    ASRock H61M-VG3
Тип BIOS           AMI (01/07/2013)
DMI версия BIOS      P1.60
Видеоадаптер           Intel(R) HD Graphics
Дисковый накопитель   Hitachi HDS721050CLA360
Первоначально на диск была установлена Windows 10 Pro x64 с использованием UEFI, затем установлена Ubuntu Desktop 20.04.1 (64-bit) так же с UEFI.
Раздел на жёстком диске под Ubuntu был оставлен пустым (15Гб).
При установке Ubuntu, все параметры оставлял по умолчанию.

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5424
    • Просмотр профиля
после загрузки Windows 10 Pro - Grub не отображается.
GRUB должен отображаться до загрузки Windows10.
куда устанавливался загрузчик во время инсталляции Ubuntu? На диск, в раздел с корневой системой?
дайте выводsudo fdisk -l
sudo blkid

Оффлайн vladimirzhuravlev

  • Старожил
  • *
  • Сообщений: 1262
    • Просмотр профиля
 Ubuntu переустанови, путь для граба на виндовый ESP раздел... или... грузись вживую с установочной флешки и установи граб на виндовый ESP раздел.

Оффлайн Дюшик

  • Активист
  • *
  • Сообщений: 821
    • Просмотр профиля
Зайдите в BIOS и поставьте Ubuntu на первое место в списке загрузки. Или вызовите Boot menu (F12 или другая клавиша) и выберите Ubuntu.

А GRUB вообще установлен?
« Последнее редактирование: 26 Январь 2021, 15:27:29 от Дюшик »

Оффлайн Domitory

  • Участник
  • *
  • Сообщений: 200
    • Просмотр профиля
Раздел на жёстком диске под Ubuntu был оставлен пустым (15Гб).
При установке Ubuntu, все параметры оставлял по умолчанию.

Скорее всего GRUB установился в загрузочный сектор раздела а не в MBR всего диска.
Тут несколько вариантов можно попробовать.
1) Настроить загрузчик Windows на выбор операционных систем прописав в нем загрузку Ubuntu.
2) Если система была только установлена то переустановить Ubuntu проследив за тем чтобы загрузчик установился именно на диск SDA а не на SDA1...SDAn и прочии диски отличные от SDA. Наверное самый простой способ для новичка.
3) Загрузиться в LiveCD и переустановить GRUB или LILO
4) Загрузиться с LiveCD запустить в нем какой-нибудь приличный менеджер дисков и отметить раздел с Ubuntu как активный.

Что то из этого да поможет. Не видя как происходила установка и как в итоге разбит диск трудно что то конкретное посоветовать.
Возможно GRUB уничтожен Windows-ом, восстановлением системы после сбоев. А возхможно и вовсе не установили GRUB.






Оффлайн Ser_W

  • Активист
  • *
  • Сообщений: 341
    • Просмотр профиля
Aleksander001, загрузитесь с LiveCD, и в нем поставьте Grub Customuzer, и восполььзуйтесь им.

Оффлайн drion

  • Активист
  • *
  • Сообщений: 838
    • Просмотр профиля
Почти мой случай. Читайте, может помочь:
https://forum.ubuntu.ru/index.php?topic=313737.msg2440598#msg2440598

Оффлайн Aleksander001

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Всем спасибо за советы.

В итоге:
было достаточно в Windows 10 пропатчить загрузчик

1. командная строка от имени администратора
2. bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

 

Страница сгенерирована за 0.083 секунд. Запросов: 25.