Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Xubuntu 20.04, из-за падения Xorg не срабатывает автологин  (Прочитано 2747 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Skif_off

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
Попытки выяснить причину не удались, поиском ничего подходящего не нашёл.
Пробовал ставить систему параллельно, с теми же пакетами: проблема вылезла после установки VirtualBox из репозитория Oracle, снёс, но проблема вернулась через какое-то время. Пробовал вместо 6.1.х ставить 6.0.х, проблема уходила, но ненадолго, т.е. VirtualBox как будто ни при чём. Тупо снести пакет xserver-xorg-video-fbdev не пробовал.

Ранее стояла Xubuntu х64 16.04, что-то из 17.х (недолго), 18.04 - всё было в порядке. Система каждый раз ставилась начисто, не люблю обновляться с релиза на релиз, но в плане пакетов приблизительно одно и то же по крайней мере в части программ, глубоко влезающих в систему (службы, модули ядра).
Железо вроде в порядке, без разгона, температуры в норме, никаких странных зависаний. Монитор подключен через переходник DVI-VGA.

Подскажите, куда копнуть?

Логи во вложении:
- normal_Xorg.0.log - лог нормальной загрузки с автологином;
- fail-1_Xorg.0.log.old - лог упавшего процесса Xorg;
- fail-2_Xorg.0.log - лог повторного запуска Xorg, уже удачного, но приходится вводить логин и пароль.
Один момент: сейчас в Xorg.0.log.old большая пачка сообщений
(EE) FBDEV(0): FBIOPUTCMAP: No such deviceраньше такого не было, возможно, результат обновления Xorg 1.20.8 > 1.20.9.

Командная строка из _usr_lib_xorg_Xorg.0.crash
/usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
Кусок Xorg.0.log.old для индексации поисковиками:
[     5.188] (EE)
[     5.188] (EE) Backtrace:
[     5.189] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x13c) [0x5613c739859c]
[     5.190] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7f7ba0ec841f]
[     5.190] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (gsignal+0xcb) [0x7f7ba0d0518b]
[     5.190] (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 (abort+0x12b) [0x7f7ba0ce4859]
[     5.191] (EE) unw_get_proc_name failed: no unwind info found [-10]
[     5.191] (EE) 4: /lib/x86_64-linux-gnu/libc.so.6 (?+0x0) [0x7f7ba0ce471a]
[     5.191] (EE) 5: /lib/x86_64-linux-gnu/libc.so.6 (__assert_fail+0x46) [0x7f7ba0cf5f36]
[     5.191] (EE) 6: /usr/lib/xorg/Xorg (dixRegisterPrivateKey+0x239) [0x5613c7255ac9]
[     5.191] (EE) 7: /usr/lib/xorg/modules/libglamoregl.so (glamor_init+0xcf) [0x7f7b9040a35f]
[     5.192] (EE) unw_get_proc_name failed: no unwind info found [-10]
[     5.192] (EE) 8: /usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7f7ba05bbc00]
[     5.192] (EE) unw_get_proc_name failed: no unwind info found [-10]
[     5.192] (EE) 9: /usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7f7ba05b3dd0]
[     5.192] (EE) 10: /usr/lib/xorg/Xorg (AddGPUScreen+0xf5) [0x5613c72372d5]
[     5.192] (EE) 11: /usr/lib/xorg/Xorg (xf86PlatformMatchDriver+0xa44) [0x5613c7292cf4]
[     5.192] (EE) 12: /usr/lib/xorg/Xorg (xf86PlatformDeviceCheckBusID+0x225) [0x5613c7298035]
[     5.192] (EE) 13: /usr/lib/xorg/Xorg (config_fini+0xa4a) [0x5613c72948da]
[     5.192] (EE) 14: /usr/lib/xorg/Xorg (config_fini+0x15eb) [0x5613c729610b]
[     5.193] (EE) 15: /usr/lib/xorg/Xorg (config_init+0xd) [0x5613c72935dd]
[     5.193] (EE) 16: /usr/lib/xorg/Xorg (InitInput+0xb9) [0x5613c7276c89]
[     5.193] (EE) 17: /usr/lib/xorg/Xorg (InitFonts+0x36d) [0x5613c723af7d]
[     5.193] (EE) 18: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0x7f7ba0ce60b3]
[     5.193] (EE) 19: /usr/lib/xorg/Xorg (_start+0x2e) [0x5613c7224a2e]
[     5.193] (EE)
[     5.193] (EE)
Fatal server error:
[     5.193] (EE) Caught signal 6 (Aborted). Server aborting
[     5.193] (EE)
[     5.193] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[     5.193] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     5.193] (EE)
[     5.193] (EE) FBDEV(0): FBIOPUT_VSCREENINFO: No such device
[     5.212] (EE) Server terminated with error (1). Closing log file.

Пользователь добавил сообщение 06 Февраля 2023, 05:53:52:
Подскажите, пожалуйста, как получить подробный список запускаемых процессов и загружаемых модулей? Без лишнего, типа как в Win работало протоколирование загрузки.
Похоже, это единственное, что пока не сравнил.
« Последнее редактирование: 06 Февраля 2023, 05:53:52 от Onlininer »

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6198
    • Просмотр профиля
Тупо снести пакет xserver-xorg-video-fbdev не пробовал.
попробуйте. Для чего он вообще устанавливался?

Оффлайн Skif_off

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
БТР, это одна из зависимостей идущего из коробки xserver-xorg-video-all, у него почти все xserver-xorg-video-* в зависимостях.
Попробовал снести - не помогло.

Похоже, modesetting почему-то иногда лажает, вместо
(II) [KMS] Kernel modesetting enabled.в логе появляется
(II) [KMS] drm report modesetting isn't supported.
(EE) open /dev/dri/card0: No such file or directory
и пошло-поехало... Только вот внутренности Linux-систем знакомы не настолько, чтобы понять, что именно не так. И с разбегу не удалось найти способ получить список процессов, модулей и драйверов, чтобы сравнить в лоб.
modesetting - это часть ядра, ядер проверял кучу: отсюда https://kernel.ubuntu.com/~kernel-ppa/mainline/ брал последние версии в линейке, начиная с 5.0.х, если память не изменяет, и до 5.9.х (5.10.х ещё не было). Недавно снова попробовал драйвера с ppa:oibaf/graphics-drivers - ничего не помогает. Ждал HWE, но немного надоело :)

На какую-то массовую проблему ведь не сильно похоже, иначе решение удалось бы найти сравнительно легко? И условия 100%го воспроизведения не удаётся найти.

Сегодня попробовал тупо выключить modesetting, заменив в конфиге GRUB2 "quiet splash" на "nomodeset", и это вроде сработало, пока, но саму проблему не решило.

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6198
    • Просмотр профиля
ядер проверял кучу: отсюда https://kernel.ubuntu.com/~kernel-ppa/mainline/ брал последние версии в линейке, начиная с 5.0.х, если память не изменяет, и до 5.9.х (5.10.х ещё не было).
а со стандартным как себя ведёт система? Для чего ставите ядро из внешних источников?

Оффлайн Skif_off

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
Использую ядро по умолчанию, просто предположил, что проблема может быть связана с версией ядра, поэтому проверил версии ядра посвежее и постарее. Но ошибка возникала на каждом.

Оффлайн Skif_off

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
Пробовал сравнивать логи dmesg и journalctl, вроде ничего такого и какой-то системы уловить не удалось. Подумал было попробовать заставить systemd не распараллеливать загрузку, но разбегу не нашёл способ и по идее это было бы не очень хорошо.

Поэкспериментировал с параметрами ядра - nomodeset, quiet, splash и noplymouth: в конечном итоге решил убрать "quiet splash" из /etc/default/grub, похоже, позволяет обойти проблему (но не решить, поэтому пока тему решённой не помечаю), надо понаблюдать.

Оффлайн Skif_off

  • Автор темы
  • Участник
  • *
  • Сообщений: 164
    • Просмотр профиля
В Xubuntu 22.04 аналогично, проблема вылезла сразу после обновления пакетов после установки системы.

 

Страница сгенерирована за 0.051 секунд. Запросов: 25.