Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: помощь в настройке fetchmail (почта на iRedMail) [РЕШЕНО]  (Прочитано 568 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DimmKo

  • Автор темы
  • Участник
  • *
  • Сообщений: 249
    • Просмотр профиля
    • Image Hosting
Добрый день.

Помогите, пожалуйста, советом. Что-то не получается самому разобраться, всю голову сломал.

Установлена почта iRedMail.
Хочу настроить techmail, для проверки новых писем.

Вот конфиг:
(Нажмите, чтобы показать/скрыть)


Вот результат запуска:
(Нажмите, чтобы показать/скрыть)

Возможно, что-то упустил, но не могу сообразить что.

Спасибо за помощь.
« Последнее редактирование: 12 Февраль 2021, 15:31:50 от DimmKo »
Ubuntu Server 14.04.3 LTS | x86_64

Оффлайн AlexDem

  • Активист
  • *
  • Сообщений: 466
    • Просмотр профиля
Re: помощь в настройке fetchmail (почта на iRedMail)
« Ответ #1 : 05 Февраль 2021, 11:30:02 »
routines:tls_process_server_certificate:certificate verify failed
fetchmail: ********.ru: SSL connection failed.
Рискну быть кОпетаном Очевидность, но... ошибка проверки SSLсертификата, и как следствие - ошибка установки  SSL  соединения...

Оффлайн DimmKo

  • Автор темы
  • Участник
  • *
  • Сообщений: 249
    • Просмотр профиля
    • Image Hosting
Re: помощь в настройке fetchmail (почта на iRedMail)
« Ответ #2 : 12 Февраль 2021, 15:49:32 »
routines:tls_process_server_certificate:certificate verify failed
fetchmail: ********.ru: SSL connection failed.
Рискну быть кОпетаном Очевидность, но... ошибка проверки SSLсертификата, и как следствие - ошибка установки  SSL  соединения...

Спасибо, я наивно надеялся, что не в этом дело)))
Удалось победить!

На почтовике:
1) создал сертификат
1.1) создал ключ
(Нажмите, чтобы показать/скрыть)

1.2) создал сертификат
(Нажмите, чтобы показать/скрыть)

2) скопировал серт и ключ в /etc/ssl в соответствующие каталоги.

3) изменил параметры сервисов dovecot и postfix
/etc/dovecot/dovecot.conf
/etc/postfix/main.cf
параметры касательно SSL

3.1) перезапустил эти сервисы
Код: (bash) [Выделить]
sudo systemctl restart dovecot && sudo systemctl restart postfix
На той машине, где хотел использовать fetchmail
1) установка fetchmail
Код: (bash) [Выделить]
sudo aptitude install fetchmail
2) получил там сертификат
(Нажмите, чтобы показать/скрыть)

3) в каталоге пользователя, от кого будет запускаться fetchmail, создал каталог .fetchmailsslcerlts и туда скопировал полученный серт из шага 2, потом выполнить
Код: (bash) [Выделить]
c_rehash .fetchmailsslcerlts/
4) получаю fingerprint (Отпечаток сертификата)
(Нажмите, чтобы показать/скрыть)

5) полученные значения потом вставил в .fetchmailrc
(Нажмите, чтобы показать/скрыть)

Запуск и проверка
Код: (bash) [Выделить]
fetchmail -c -k -f .fetchmailrc
1 message (1 seen) for test@test.ru at test.ru.
Ubuntu Server 14.04.3 LTS | x86_64

Оффлайн AlexDem

  • Активист
  • *
  • Сообщений: 466
    • Просмотр профиля
Спасибо, я наивно надеялся, что не в этом дело)))
А в чем же еще, если тебе это прямым текстом написано... )))

Оффлайн DimmKo

  • Автор темы
  • Участник
  • *
  • Сообщений: 249
    • Просмотр профиля
    • Image Hosting
Спасибо, я наивно надеялся, что не в этом дело)))
А в чем же еще, если тебе это прямым текстом написано... )))

Вы знаете, прежде чем спросить тут, я погуглил, конечно.
И есть такой параметр:
(Keyword: no sslcertck, only in v6.4.X)
The opposite of --sslcertck, this is a discouraged option. It permits fetchmail to continue connecting even if the server certificate failed the verification checks. Should only be used together with --sslfingerprint.

Я его и использовал, но что-то не алло...
Ну да не суть, главное, что заработало.
Ubuntu Server 14.04.3 LTS | x86_64

 

Страница сгенерирована за 0.067 секунд. Запросов: 25.