Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: После установки на плату с UEFI не загружается система  (Прочитано 423 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alex_ctz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Добрый день!

Нужна помощь в настройке (установке) Kubuntu 21.04 на систему с UEFI и SSD M.2. Ситуация следующая:

Система: Intel Core i5-11500, материнская плата ASRock B560M PRO4 (Intel B560), DDR4-2666 8Gb HyperX Fury, SSD M.2 Kingston A2000 250GB, HDD Western Digital Blue 2000Gb.

Системным диском выбран чистый SSD. На нем будет работать только одна Kubuntu.

1) Скачал образ Kubuntu 21.04 Hirsute Hippo Release с официального сайта. Установочную флэшку записал из образа программой Startup Disk Creator.

2) Kubuntu c флэшки в Live режиме для ознакомления с системой до установки загрузилась нормально. Работает корректно.

2) С помощью программы Gparted создал на SSD диске раздел ESP для UEFI с файловой системой FAT32, поставил флаги "boot" и "efi", размер 512MB. Далее установщик Kubuntu определил размер, как 536MB.

3) В процессе установки системы на шаге подготовки разделов диска, разбил разделы следующим образом:
/dev/nvme0n1p1  efi          536MB   - этот раздел в таком виде определился сразу, остальные далее создавал
/dev/nvme0n1p2  ext4  /      50 000 MB
/dev/nvme0n1p3  ext4  home   149 999 MB
Свободное место              49 521 MB 

Раздел Swap не создавал, так как в системе есть поддержка подкачки в файл, а если надо, то поставлю подкачку на HDD или добавлю планку оперативной памяти.

В секции Boot loader "Устройство для установки системного загрузчика" выбрал: /dev/nvme0n1p1

4) Далее установка прошла успешно, система установилась. Но после перезагрузки компьютера не загружается. Загрузка компьютера завершается черным экраном с логотипом ASRock.

При этом, в UEFI в секции "Приоритет загрузка" имеется первым пункт: Ubuntu (M2_1 Kingston SA 2000M8250G), то есть диск с установленной системой.

В названии этого пункта нет упоминания об UEFI. В тоже время, если я подключаю установочную флэшку, то она обозначается вторым пунктом следующим образом:
UEFI: VendorCoProductCode

Загружая Kubuntu c флэшки в Live режиме, система видит SSD с установленной системой, ее корневой и домашний разделы.

При установке системы в UEFI не был отключен Secure Boot. Я отключил данный режим после установки.

Возможно, что при установке не правильно прописались параметры загрузки. Может возможно откорректировать их, загрузившись c флэшки в Live режиме? Устанавливаю систему с UEFI в первый раз. Не могу разобраться.
« Последнее редактирование: 09 Май 2021, 16:52:32 от alex_ctz »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4468
    • Просмотр профиля
Изучай свой УЕФИ, тебе с ним жить.
Во всех УЕФИ все очень по разному. Может банально все решится как здесь.
Посмотри в "boot menu", которое вызывается обычно клавишами типа "F8-F12". Иногда бывает, что можно загрузиться только из него.


Пользователь добавил сообщение 09 Май 2021, 17:47:02:
Цитировать
Kubuntu 21.04 Hirsute Hippo
Вообще, где-то рядом есть тема, что не все в порядке с этой версией. Поэтому не предлагают на нее обновляться.
« Последнее редактирование: 09 Май 2021, 17:47:02 от andytux »

Оффлайн alex_ctz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
По Kubuntu 21.04 Hirsute Hippo я поищу информацию. Выбрал эту версию, так как железо очень новое и надеялся на новые драйвера и другие доработки. Видеокарты сильно подорожали и пришлось брать более дорогой процессор с встроенной графикой получше. В настройках UEFI приоритет загрузки у меня изменяется и сохраняется нормально. Пробовал разные варианты. Также клавишей F11 вызывал boot меню и пробовал загрузиться из него. Результат как и прежде. Думаю, что при установке не корректно прописалась загрузка.

Сейчас есть несколько идей:

1) Создать флэшку в программе Rufus. Там можно указать параметр "Схема раздела и тип системного интерфейса: GPT для компьютеров с UEFI;"

2) Попробовать ставить систему с DVD, подключив внешний DVD-проигрыватель. В интернете нашел, что у некоторых была такая проблема: при установки с флэшки система не загружается, при установки с диска - все работает.

3) Хотелось бы перед этим попробовать вариант, как указано по вашей ссылке:

 "Легко можно получить флешку с дистрибутивом установщик которого не пропишет граб в виндовый загрузчик ESP. Сейчас только грузИться вживую с любого дистрибутива, устанавливать с терминала граб на ESP (помним определяясь, что он у нас в fat32) и апдейт граб."

Может кто знает или есть ссылка на список команд, как правильно с терминала поставить Grub на раздел ESP и обновить его. Как указал выше, я могу загрузиться в Live режиме с установочной флэшки. Пути к мои разделам на системном SSD и их названия указаны в первом сообщении. в Live режиме интернет подключился нормально. Так уже устанавливал Gparted.
« Последнее редактирование: 09 Май 2021, 18:11:23 от alex_ctz »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4468
    • Просмотр профиля
Цитировать
"Схема раздела и тип системного интерфейса: GPT для компьютеров с UEFI;"
Линуксу до лампочки, MBR (ms-dos) или GPT. Единственный случай, когда необходима GPT, если диск больше 2ТБ.
Цитировать
как правильно с терминала поставить Grub на раздел ESP
Правильней будет, посмотреть, может он уже стоит и не надо ничего портить.
Загрузись с флешки и посмотри на ESP-разделе, что-то типа /EFI/ubuntu/grubx64.efi.

Оффлайн alex_ctz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Загрузился с флэшки. В диспетчере файлов Dolphin видны только корневой и домашний разделы. Раздел ESP в нем не отображается. В программе управления разделами KDE Partition Manager данный раздел виден. Размер 521 MB, использовано 2% - 5,21 Mb.

В корневом разделе системы в папке boot имеется пустая папка efi и папка grub, в которой имеется папка с файлами x86_64-efi.

Как можно посмотреть содержимое раздела ESP?

Оффлайн shamanhuev

  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
Как можно посмотреть содержимое раздела ESP?
efibootmgr -v

Оффлайн alex_ctz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Результат выполнения команды efibootmgr -v из консоли Live-загрузки установочной флэшки следующий: (в приоритете загрузки в настройках Uefi я установил флэшку на первое место, а потом диск SSD с системой)

BootCurrent: 0001
Timeout: 1 second
BootOrder: 0001, 0000
Boot0000* ubuntu   HD(1,GPT, 44b3ec86-9602-44f0-bba5-d35a1f90ee78,0x800,
0x100000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0001* UEFI: VendorCorpProductCode 2.00....далее продолжается эта строка, касающаяся загрузочной флэшки


Как видно, у меня запись не /EFI/ubuntu/grubx64.efi  , a  \EFI\UBUNTU\SHIMX64.EFI
« Последнее редактирование: 10 Май 2021, 00:11:22 от alex_ctz »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4468
    • Просмотр профиля
Цитировать
у меня запись не /EFI/ubuntu/grubx64.efi
grubx64.efi - неподписанный загрузчик. Работает только при отключенном "secure boot".
SHIMX64.EFI - подписанный загрузчик. Работает всегда.
По логике, УЕФИ (согласно загрузочной записи) запускает SHIMX64.EFI. SHIMX64.EFI должен запустить grubx64.efi (если он конечно есть). Как минимум, ты должен увидеть консоль "grub rescue".
Там-же должен быть простейший grub.cfg, состоящий из трех строк. В нем указано, где брать полный конфиг груба.
Если по указанному месту (обычно /boot/grub/* на системном разделе) есть остальные файлы груба, то груб запустится.
Цитировать
В программе управления разделами KDE Partition Manager данный раздел виден. Размер 521 MB
Еще там можно увидеть, смонтирован-ли данный раздел (ключик), и если смонтирован, то куда. Там его и искать.
Иначе, монтировать, например в /mnt/nvme0n1p1 и заходить через эту точку монтирования.


Пользователь добавил сообщение 10 Май 2021, 10:12:43:
А вообще, что видишь при выборе в УЕФИ загрузки "ubuntu".
По умолчанию, если одна система, то груб не показывает меню а сразу переходит к загрузке дефолтного пункта меню.
Попробуй сразу после логотипа производителя нажимать "ESC", для того, чтобы груб показал меню. Чтобы легче поймать этот момент, в некоторых УЕФИ можно выставить таймаут. Например, я у себя выставил 2 секунды. Нужно попасть именно в этот таймаут.
У тебя стоит 1 секунда (с выводе efibootmgr строка после "BootCurrent:"). Можно изменить с помошью efibootmgr.


Пользователь добавил сообщение 10 Май 2021, 13:01:31:
Цитировать
Выбрал эту версию, так как железо очень новое и надеялся на новые драйвера и другие доработки
С этой стороны идея верная, но...
Цитировать
...Связано это с обнаруженной в Ubuntu 21.04 ошибкой в загрузчике shim, из-за которой возможен отказ загрузки систем...
Если дело только в shim, то возможные пути:
1. Отключить "secure boot". Переписать загрузочную запись без shim, с grubx64.efi.
2. Использовать загрузчик от другой версии (например из образа 20.04). Облегчает задачу то, что ЕФИ-загрузчик устанавливается простым копированием файлов. Можно из исо-образа скопировать файлы груба на ESP-раздел (можно на любой раздел FAT32, например на флешку) и получишь загрузчик, независимый от системы. Но этим загрузчиком ты сможешь загрузить хоть что, хоть откуда, хоть когда.
3. Переустановить систему с отключенным "secure boot", в надежде, что она настроит запуск системы без shim.
4. Установить другую версию системы.
« Последнее редактирование: 10 Май 2021, 13:13:11 от andytux »

Оффлайн alex_ctz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Еще сделал только первые пункты и вот, что получилось (в режиме Recovery mode система загрузилась):

1) В настройках UEFI поставил таймаут 2 секунды. После появления логотипа Asrock нажал ESC и открылось окно GRUB 2.04 с пунктами:

- Ubuntu
- Дополнительные параметры для Ubuntu
- UEFI Firmware Settings

При выборе первого пункта система не загрузилась - на экране логотип Asrock.
Третий пункт - это переход в настройки UEFI.

Выбрав второй пункт "Допнастройки" перешел в меню с пунктами:
- Ubuntu Linux 5.11.0-16-generic
- Ubuntu Linux 5.11.0-16-generic  (recovery mode)

Выбрав второй пункт "recovery mode" зашел в Recovery menu. Там нажал на первый пункт "Resume normal boot", на экране появилось
окно с сообщением "You are now going the recovery mode and continue the boot sequence... далее про графические адаптеры", в этом окне нажал OK и Kubuntu на SSD загрузилась. Работает корректно. Изменил некоторые настройки экрана и после перезагрузки опять через Recovery mode система загрузилась с сохранением всех изменений. Так что сама по себе установленная система работает нормально.

Если загрузка идет в обычном (необходимом режиме), то система не загружается, останавливаясь на черном экране с логотипом Asrock.


2) При загруженной системе в программе управления разделами KDE следующая информация по загрузочному разделу:

 Раздел: /dev/nvme0n1p1

- файловая система FAT 32
- метка - нет - пустое поле
- точка подключения: /boot/efi
- тип раздела: основной
- состояние: подключено на /boot/efi
- UUID: E01D-DF8A
- Метка раздела: (нет)
- UUID раздела: здесь длинный номер из чисел и букв
- Размер: 512 Мб
- Использовано 2% - 5,21 Мб
- Флаги:
1. загрузочный - этот отмечен
2.bios-grub - этот не отмечен

Пользователь добавил сообщение 11 Май 2021, 01:05:47:
Теперь по имеющимся папкам в корневом разделе установленной на SSD системы:

1) В корневой папке есть директория /boot. В ней директория grub. В последней есть файл конфигурации grub.cfg и среди прочих папок и файлов - директория x85_64-efi с файлами.

Также в папке /boot есть директория /efi (на ней иконка с замком) - это как я понимаю и есть примонтированный раздел /dev/nvme0n1p1
так как выполнив в терминале команду монтирования

sudo mount /dev/nvme0n1p1

получил ответ, что /dev/nvme0n1p1 уже смонтирован в /boot/efi

Таким образом я получил админдоступ к этому разделу. В нем такая структура папок:

1.1) /boot/efi/EFI/BOOT/
в этой директории файлы:
BOOTX64.EFI
fbx64.efi
mmx64.efi

и

1.2) /boot/efi/EFI/ubuntu/
в этой директории файлы:
BOOTX64.CSV
grub.cfg
grubx64.efi
mmx64.efi
shimx64.efi

в файле grub.cfg три строки и пути к грубу системы прописаны правильно: /boot/grub

Наверно сначала стоит проверить два первых пути решения проблемы с загрузчиком:

Первый
Цитировать
1. Отключить "secure boot". Переписать загрузочную запись без shim, с grubx64.efi.

Но я не знаю в каком файле это сделать и что-там исправить

Или второй
Цитировать
2. Использовать загрузчик от другой версии (например из образа 20.04). Облегчает задачу то, что ЕФИ-загрузчик устанавливается простым копированием файлов. Можно из исо-образа скопировать файлы груба на ESP-раздел (можно на любой раздел FAT32, например на флешку) и получишь загрузчик, независимый от системы. Но этим загрузчиком ты сможешь загрузить хоть что, хоть откуда, хоть когда.

Подскажите, пожалуйста, какую папку из образа 20.04 и в какое место раздела системы /boot/efi/ скопировать.

Смущает такой путь /efi/EFI/


« Последнее редактирование: 11 Май 2021, 03:19:44 от alex_ctz »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4468
    • Просмотр профиля
Цитировать
Наверно сначала стоит проверить два первых пути решения проблемы с загрузчиком
Ничего не надо. Загрузчик есть и работает. Не надо его теребить.
Единственно, если тебе захочется его настоить. Например, чтобы всегда показывал меню, изменить пункт по умолчанию и т.д.
Цитировать
Смущает такой путь /efi/EFI/
Все правильно. На ESP-разделе есть каталоги: /EFI, /boot. ESP-раздел монтируется в каталог /boot/efi.
Поэтому, абсолютный путь получается /boot/efi/EFI/..., /boot/efi/boot/...
Цитировать
какую папку из образа 20.04 и в какое место раздела системы /boot/efi/ скопировать.
Здесь, про создание загрузочной флешки. Тебе нужен пункт 9.
Вернемся к основной беде.
Цитировать
При выборе первого пункта система не загрузилась - на экране логотип Asrock.
Самое банальное, загрузиться с параметром ядра "nomodeset". На форуме много раз описывалось.

Оффлайн alex_ctz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Спасибо огромное, Andytux, за помощь!

Таким образом, если после успешной установки системы на материнские платы с UEFI, после перезагрузки не загружается система, то дело может быть не в загрузчике UEFI. В моем случае необходимо было вручную задать параметр драйвера Intel «nomodeset» для загрузки Linux (в моем случае встроенная графика в процессоре Intel. Такая установлена на многих ноутбуках).  Подытожив, небольшая инструкция, что в моем случае необходимо было сделать:

1. При загрузке компьютера зайти в настройки UEFI, нажав в начале загрузки F2 или DEL (или другие клавиши, в зависимости от модели устройства).

2. В настройках UEFI в секции "Загрузка" указать таймаут 2 секунды (по умолчанию у меня была 1 секунда).

3. Опять перезагрузить компьютер и в начале его загрузки нажав клавишу ESC войти в загрузчик GRUB.

4. Нажать латинскую букву E.

5. В открывшемся редакторе найти в тексте найти словосочетание quiet splash и перемещаясь с помощью стрелок добавить в конце данной фразы слово nomodeset. Должно быть quiet splash nomodeset. После этого нажать сочетание клавиш CTRL+X, после чего система загрузится.

6. В загруженной системе, чтобы не вводить параметр nomodeset при каждой загрузке, надо прописать его  в файле /etc/default/grub.

Для этого можно в терминале выполнить команду  sudo gedit /etc/default/grub   (если в системе установлен редактор gedit). В указанном файле найти строку типа GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash” и добавить в нее nomodeset, чтобы было ”quiet splash nomodeset”. Сохранить изменения в файле.

Далее в терминале выполнить команду

sudo update-grub2

и перезагрузить компьютер. Далее все должно загружаться. По окончании в настройках UEFI в секции "Загрузка" указать таймаут 1 секунды, чтобы быстрее шла загрузка.


« Последнее редактирование: 11 Май 2021, 16:32:30 от alex_ctz »

 

Страница сгенерирована за 0.103 секунд. Запросов: 25.