Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Как установить Dragonfire ,если выдает ошибку.  (Прочитано 1116 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн indigo488

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Из этой ( https://blog.desdelinux.net/ru/dragonfire-asistente-virtual-ubuntu/ ) статьи
получил комманду ( wget https://raw.githubusercontent.com/mertyildiran/Dragonfire/master/install.sh && chmod + x install.sh && sudo ./install.sh sudo pip install dragonfire )
Но при установке выдает ошибку :
chmod: cannot access 'x': No such file or directory

как можно это исправить?

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1591
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #1 : 14 Августа 2021, 16:41:28 »
+x (без пробела)

shamanhuev

  • Гость
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #2 : 14 Августа 2021, 16:43:21 »
И ещё ошибку выдаст. Команда не завершена правильно.
Или просто написана неправильно. Там последняя команда отдельно.
« Последнее редактирование: 14 Августа 2021, 16:44:57 от shamanhuev »

Оффлайн indigo488

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #3 : 14 Августа 2021, 16:44:20 »
Ок ,но возникла следуйщая ошибка
bash: ./debian/postinst: No such file or directory

shamanhuev

  • Гость
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #4 : 14 Августа 2021, 16:47:26 »
chmod + x install.sh
Возможно путь установки не совпадает с путём запуска.

Оффлайн indigo488

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #5 : 14 Августа 2021, 16:48:36 »
Я так понимаю нужно как-то самому из гита установить https://github.com/DragonComputer/Dragonfire
Но я пока не знаю как это сделать

shamanhuev

  • Гость
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #6 : 14 Августа 2021, 16:50:15 »
git clone adress

Оффлайн indigo488

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #7 : 14 Августа 2021, 16:56:16 »
ладно ,похоже мне ещё нужно много изучить что-бы понять как это всё работает

Пользователь добавил сообщение 14 Августа 2021, 17:01:11:
git clone adress
я выполнил эту операцию и что теперь?
« Последнее редактирование: 14 Августа 2021, 17:01:11 от indigo488 »

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 3147
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #8 : 14 Августа 2021, 17:28:53 »
indigo488, не заморачивайся пока с этим "git clone adress", просто почитай https://github.com/DragonComputer/Dragonfire/blob/master/README.md

там, кроме прочего, пишут
Цитировать
Installation

To run Dragonfire on a desktop Debian or Ubuntu system, either download the latest release (the .deb file) and install as follows:

sudo dpkg -i dragonfire_1.1.1_amd64.deb

... что в вольном переводе translate.google.com значит
Цитировать
Чтобы запустить Dragonfire на настольной системе Debian или Ubuntu, загрузите последнюю версию ( .deb файл) и установите ее следующим образом:

sudo dpkg -i dragonfire_1.1.1_amd64.deb

Оффлайн indigo488

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #9 : 14 Августа 2021, 17:41:03 »
Да я изучаю реадми,но при загрузке выдает ошибку ,
я пока-что немогу сказать какую потомучто в процессе установки Deepspeech который необходим для работы      Dragonfire,

Пользователь добавил сообщение 14 Августа 2021, 17:44:35:
Чтобы запустить Dragonfire на настольной системе Debian или Ubuntu, загрузите последнюю версию ( .deb файл) и установите ее следующим образом:

sudo dpkg -i dragonfire_1.1.1_amd64.deb
вот ,я так понимаю у меня нет файла
dpkg: error: cannot access archive 'dragonfire_1.1.1_amd64.deb': No such file or directory


Пользователь добавил сообщение 14 Августа 2021, 17:52:59:
установил пайтон27минимал после чего устанавливал файл но вот:
dpkg: error processing package dragonfire (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for man-db (2.9.1-1) ...
Errors were encountered while processing:
 dragonfire


Пользователь добавил сообщение 14 Августа 2021, 17:57:20:
dpkg: dependency problems prevent configuration of dragonfire:
 dragonfire depends on python3 (<< 3.7); however:
  Version of python3 on system is 3.8.2-0ubuntu2.
 dragonfire depends on flite; however:
  Package flite is not installed.
 dragonfire depends on python3-xlib; however:
  Package python3-xlib is not installed.
 dragonfire depends on portaudio19-dev; however:
  Package portaudio19-dev is not installed.
 dragonfire depends on python3-all-dev; however:
  Package python3-all-dev is not installed.
 dragonfire depends on flac; however:
  Package flac is not installed.
 dragonfire depends on python3-lxml; however:
  Package python3-lxml is not installed.
 dragonfire depends on python3-nltk; however:
  Package python3-nltk is not installed.
 dragonfire depends on python3-pyaudio; however:
  Package python3-pyaudio is not installed.
 dragonfire depends on libgstreamer1.0-dev; however:
  Package libgstreamer1.0-dev is not installed.
 dragonfire depends on subversion; however:
  Package subversion is not installed.
 dragonfire depends on libatlas-base-dev; however:
  Package libatlas-base-dev is not installed.
 dragonfire depends on automake; however:
  Package automake is not installed.
 dragonfire depends on autoconf; however:
  Package autoconf is not installed.
 dragonfire depends on libtool; however:
  Package libtool is not installed.
« Последнее редактирование: 14 Августа 2021, 17:57:20 от indigo488 »

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 3147
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #10 : 14 Августа 2021, 17:57:27 »
indigo488, в приведенных мной цитатах есть ссылка на latest release, она же последняя версия

1. кликаешь по ссылкам и попадаешь на https://github.com/DragonComputer/Dragonfire/releases/latest
2. скачиваешь оттуда dragonfire_1.1.1_amd64.deb
3. открываешь терминал (комбинация одновременно нажатых клавиш Ctrl Alt T) и переходишь в каталог с скачанным dragonfire_1.1.1_amd64.deb (например выполнив команду cd /home/indigo488/Загрузки)
4. и уже будучи в каталоге с вожделенным deb файлом выполняй в терминале sudo dpkg -i dragonfire_1.1.1_amd64.deb
« Последнее редактирование: 14 Августа 2021, 17:58:58 от F12 »

Оффлайн indigo488

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #11 : 14 Августа 2021, 18:01:10 »
indigo488, в приведенных мной цитатах есть ссылка на latest release, она же последняя версия

1. кликаешь по ссылкам и попадаешь на https://github.com/DragonComputer/Dragonfire/releases/latest
2. скачиваешь оттуда dragonfire_1.1.1_amd64.deb
3. открываешь терминал (комбинация одновременно нажатых клавиш Ctrl Alt T) и переходишь в каталог с скачанным dragonfire_1.1.1_amd64.deb (например выполнив команду cd /home/indigo488/Загрузки)
4. и уже будучи в каталоге с вожделенным deb файлом выполняй в терминале sudo dpkg -i dragonfire_1.1.1_amd64.deb
я уже с этим разобрался ,дальше ошибки из за не хватки каких-то пакетов , я так понимаю мне нужно каждый по отдельности устанавливать

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 3147
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #12 : 14 Августа 2021, 18:07:46 »
indigo488, для начала попробуй выполнить в терминале sudo apt install -f

или установи утилиту gdebi-gtk (если не установлена) и открой в ней deb файл, она сама подтянет все недостающие пакеты

shamanhuev

  • Гость
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #13 : 14 Августа 2021, 18:16:50 »
ar tv dragonfire_1.1.1_amd64.deb
rw-r--r-- 0/0      4 Dec 19 02:09 2019 debian-binary

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 3147
    • Просмотр профиля
Re: Как установить Dragonfire ,если выдает ошибку.
« Ответ #14 : 14 Августа 2021, 18:23:27 »
shamanhuev, намекаешь что зависимости времен 2019, и потому вряд ли будут удовлетворены в дистре 2021 ?..

Ну тогда научи новичка как собрать пакет из исходников. Как ты уже понял, простых намеков, типа "git clone adress" будет недостаточно ;)

 

Страница сгенерирована за 0.077 секунд. Запросов: 25.