Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проигрывание mp4  (Прочитано 409 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pulchra

  • Автор темы
  • Участник
  • *
  • Сообщений: 144
    • Просмотр профиля
Проигрывание mp4
« : 01 Ноября 2021, 08:10:09 »
Добрый день, столкнулся с проблемой для ubuntu 21.10 проигрывания видео в формате mp4 - не проигрывает, нет звука, висит картинка, обновляется раз секунд в пятнадцать. sudo apt install ubuntu-restricted-extras это установил. sudo apt install ffmpeg это тоже.
На вот это ругается: sudo apt install gstreamer1.0*
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Заметьте, выбирается «gstreamer1.0-qt5» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-wpe» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-ugly» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-packagekit» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-gl» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-fluendo-mp3» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-clutter-3.0» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-autogain-pulseeffects» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-qapt» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-python-dbg-plugin-loader» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-bad-videoparsers» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-adapter-pulseeffects» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-videosource» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-tools» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-espeak» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-really-bad» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-omx-generic» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-lame» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-base-apps» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-omx-generic-config» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-alsa» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-audiosource» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-audiosink» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-visualization» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-x» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-gtk3» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-pocketsphinx» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-rtsp» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-good» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-bad-faad» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-base» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-crystalhd» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-pipewire» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-python3-plugin-loader» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-vaapi-doc» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-videosink» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-base-doc» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-omx-bellagio-config» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-convolver-pulseeffects» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-python3-dbg-plugin-loader» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-ugly-amr» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-bad-apps» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-opencv» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-vaapi» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-nice» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-crystalizer-pulseeffects» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-bad» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-pulseaudio» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-python-plugin-loader» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-libav» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-plugins-rtp» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-doc» для шаблона «gstreamer1.0*»
Заметьте, выбирается «gstreamer1.0-fdkaac» для шаблона «gstreamer1.0*»
Заметьте, вместо «gstreamer1.0-plugins-bad-faad» выбирается «gstreamer1.0-plugins-bad»
Заметьте, вместо «gstreamer1.0-plugins-bad-videoparsers» выбирается «gstreamer1.0-plugins-bad»
Заметьте, вместо «gstreamer1.0-plugins-ugly-amr» выбирается «gstreamer1.0-plugins-ugly»
Уже установлен пакет gstreamer1.0-alsa самой новой версии (1.18.5-1).
gstreamer1.0-alsa помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-clutter-3.0 самой новой версии (3.0.27-2build1).
gstreamer1.0-clutter-3.0 помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-gl самой новой версии (1.18.5-1).
gstreamer1.0-gl помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-gtk3 самой новой версии (1.18.5-1ubuntu2).
gstreamer1.0-gtk3 помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-packagekit самой новой версии (1.2.2-2ubuntu3).
gstreamer1.0-packagekit помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-pipewire самой новой версии (0.3.32-1).
gstreamer1.0-pipewire помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-plugins-base самой новой версии (1.18.5-1).
gstreamer1.0-plugins-base помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-plugins-base-apps самой новой версии (1.18.5-1).
gstreamer1.0-plugins-base-apps помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-plugins-good самой новой версии (1.18.5-1ubuntu2).
gstreamer1.0-plugins-good помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-pulseaudio самой новой версии (1.18.5-1ubuntu2).
gstreamer1.0-pulseaudio помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-tools самой новой версии (1.18.5-1).
gstreamer1.0-tools помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-x самой новой версии (1.18.5-1).
gstreamer1.0-x помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-libav самой новой версии (1.18.5-1).
Уже установлен пакет gstreamer1.0-plugins-ugly самой новой версии (1.18.5-1).
gstreamer1.0-plugins-ugly помечен как установленный вручную.
Уже установлен пакет gstreamer1.0-vaapi самой новой версии (1.18.5-1).
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 gstreamer1.0-python3-dbg-plugin-loader : Конфликтует: gstreamer1.0-python3-plugin-loader но 1.18.5-1 должен быть установлен
 gstreamer1.0-python3-plugin-loader : Конфликтует: gstreamer1.0-python3-dbg-plugin-loader но 1.18.5-1 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
Куда капать?
« Последнее редактирование: 01 Ноября 2021, 08:23:18 от pulchra »

Оффлайн Domitory

  • Активист
  • *
  • Сообщений: 515
    • Просмотр профиля
Re: Проигрывание mp4
« Ответ #1 : 01 Ноября 2021, 08:48:12 »
Что за видеопроигрыватель?

У меня было недавно что проигрыватель VLC не показывал картинку

Помогло следующее.

В настройках VLC в разделе "ввод/кодеки" в пункте "Hsrdware-accelerated decoding" выбрать "Отключить".


В проигрывателе SMPlaer помогло изменение режима видео вывода

"Параметры"-> "Настройки" -> "Видео" -> "Устройство вывода" -> "ga|быстро-видео карты ATI"


Я использую VLC и заметил что с ним периодически возникают всякие мелкие неприятности после обновлений, иногда помогает переустановка его из snap-пакета либо наоборот из стандартного bin-пакета, через раз как-то.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28124
    • Просмотр профиля
Re: Проигрывание mp4
« Ответ #2 : 02 Ноября 2021, 11:51:45 »
sudo apt install gstreamer1.0*
ЭТО было ошибкой.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.037 секунд. Запросов: 25.