Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: x11VNC не запускается при физически отключенном мониторе  (Прочитано 1025 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн antigame99

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Добрый день, коллеги.

Пробую настроить домашний сервер для личных нужд с доступом только из домашней локальной сети.

Дано неттоп xubuntu 20.04.3 из коробки со всеми обновлениями на текущий день. x11VNC из оф репозитория.

Запускаю вот так:
(Нажмите, чтобы показать/скрыть)

Дополнительно ничего не настраивал.

Проблема в том, что при физически подключенном мониторе(HDMI) все без проблем запускается и работает, как хотелось бы. Но как только отключаю монитор, сервер x11vnc не стартует. На виртуалке такой проблемы не наблюдал.

На сколько я уловил из описания, x11vnc дает возможность подключения к текущей сессии, но если не подключен монитор не стартует и сессия X?

Подскажите куда рыть?

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1833
    • Просмотр профиля
Вообще должна стартовать, я на свой raspberry и к Debian подкючался без монитора.

Если скажите какая версия ubuntu, дам инструкцию по которой фиг знает сколько лет уже настраиваю. (там разница между системами с systemd и без).

Правда начиная с 21.10 нифига не работает. Рабочего варианта пока найти не удалось для неё.

Оффлайн antigame99

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Если скажите какая версия ubuntu, дам инструкцию по которой фиг знает сколько лет уже настраиваю. (там разница между системами с systemd и без).
kubuntu 20.04.3 LST 5.11.0-40
Я запуск с systemd победить не смог. Автозагрузку соорудил через исполняемый скрипт и  автозагрузку.

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1833
    • Просмотр профиля
Инструкция в текстовике.

Оффлайн antigame99

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
(Нажмите, чтобы показать/скрыть)

Процесс после перезапуска есть, но подключиться клиентом не могу. Запуск вручную и вуаля все работает.

« Последнее редактирование: 22 Ноября 2021, 13:35:56 от antigame99 »

Оффлайн Usermaster

  • Старожил
  • *
  • Сообщений: 1833
    • Просмотр профиля
А свой скрипт с автозагрузки сняли?

Оффлайн antigame99

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
А свой скрипт с автозагрузки сняли?
Конечно снял. По описаной Вами схеме процесс запускается от пользователя root. Наверное в этом проблема, попробую еще тут покопать.
В ручную я его запускаю от себя =)
Это похоже единственное отличие.

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 3439
    • Просмотр профиля
Вообще должна стартовать, я на свой raspberry ...
- тоже достаточно давно пользую Raspberry Pi с Ubuntu на борту, но так и не удалось добиться нормальной работы по x11vnc без подключенного к устройству монитора, в конце концов отказался от этой затеи, и уже года 2, если не 3, пользуюсь NoMachine  8)

 

Страница сгенерирована за 0.047 секунд. Запросов: 25.