Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: как установить библиотеку из более свежего дистрибутива  (Прочитано 1185 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vladimir_N-sk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Я сижу на (k)ubuntu 18.04LTS.
Мне нужно установить одну программу. При установке ругань на неудовлетворенную зависимость. Требует libc6 версии 2.34. А такая версия libc6 появилась только в impish(21.10).  :-\
Вопрос, а можно ли сидя на 18.04 установить библиотеку из репозитория 21.10? Как и не сломает ли мне это систему?   :o
Спасибо.

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 685
    • Просмотр профиля
Вопрос, а можно ли сидя на 18.04 установить библиотеку из репозитория 21.10? Как и не сломает ли мне это систему?
Всё зависит от того, как будете достигать указанной цели. Можно и сломать систему, можно и "нечаянно" проапгрейдить систему до 21.10. Наверное, безопаснее всего будет воспользоваться snap или flatpack (или их альтернативами).

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5781
    • Просмотр профиля
То есть, бэкап системы у тебя есть. Не факт, что успеешь установить. Стопроцентно, угробишь систему.
Безопасный вариант, подключай библиотеки через LD_PRELOAD.

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1098
    • Просмотр профиля
сломаешь пакетную базу ещё как

Оффлайн Vladimir_N-sk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Безопасный вариант, подключай библиотеки через LD_PRELOAD.
Так для этого надо скачать эти библиотеки, хоть в "ручном режиме". А как скачать?

shamanhuev

  • Гость

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 5781
    • Просмотр профиля

Оффлайн curiosus

  • Участник
  • *
  • Сообщений: 106
    • Просмотр профиля
Лучше не пробовать. От этой библиотеки зависит куча всего в системе. Есть высокая вероятность, что система будет сломана. Лучше обновиться до 20.04 или до 21.10.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28126
    • Просмотр профиля
Мне нужно установить одну программу
У этой одной программы название есть?…
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Vladimir_N-sk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
У этой одной программы название есть?…
Есть конечно. Insync. Но я думаю это не принципиально.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28126
    • Просмотр профиля
Попробуйте поставить из

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys ACCAF35C
sudo add-apt-repository 'deb http://apt.insync.io/ubuntu bionic non-free contrib'

P.S.
Причём это прямо на самой странице загрузки прописано.
Так сложно прочесть что ли?
« Последнее редактирование: 27 Ноября 2021, 17:46:12 от AnrDaemon »
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Vladimir_N-sk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Попробуйте поставить из
Попробовал. Выдает ошибку

Чтение списков пакетов… Готово
W: Пропускается получение настроенного файла «contrib1/binary-i386/Packages», так как в репозитории «http://apt.insync.io/ubuntu bionic InRelease» отсутствует компонент «contrib1» (возможно, компонент указан с ошибкой в sources.list?)

PS. А тут на форуме когда постишь сообщения всегда надо на загадки отвечать? Чёт заколебывает.

Пользователь добавил сообщение 27 Ноября 2021, 18:01:55:
Так, народ, я зачётно протупил.  :idiot2: Там на сайте программы можно выбрать номер своего дистрибутива (18.04) и тебе отдается соответствующий "правильный" deb-пакет.  :coolsmiley:
Всем сорри за беспокойство. :-[
« Последнее редактирование: 27 Ноября 2021, 18:01:55 от Vladimir_N-sk »

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3170
    • Просмотр профиля
PS. А тут на форуме когда постишь сообщения всегда надо на загадки отвечать?
Это скоро закончится. Защита от спамеров.
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28126
    • Просмотр профиля
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Vladimir_N-sk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Разницу видно? Или тебе микроскоп дать?
А ты чё хамишь-то, у тебя микроскоп лишний?
Я запустил ровно ту команду которую ты и предложил. Потом привел вывод команды.
Успокойся уже, я разобрался с дистрибутивом.

 

Страница сгенерирована за 0.045 секунд. Запросов: 26.