Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Продление (бесплатное) поддержки ESM для Ubuntu 16.04  (Прочитано 717 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Onlininer

  • Автор темы
  • Активист
  • *
  • Сообщений: 339
    • Просмотр профиля
Поддерживается ли по-прежнему Ubuntu 16.04 LTS?

Да,  Ubuntu 16.04 LTS поддерживается до 2026 года с помощью продукта Canonical Extended Security Maintenance (ESM). Xenial вошел в период ESM в апреле 2021 года с исправлениями безопасности на пять дополнительных лет, сверх пяти лет стандартной поддержки.

Заходим https://ubuntu.com/16-04
Логинимся.
Жмём Get started with ESM for Ubuntu 16.04 LTS
Открываем терминал Ctrl+tВыполняем (обведено красным)

Получаем кучу обновлений, настраиваим их:

« Последнее редактирование: 28 Декабря 2021, 17:45:07 от Onlininer »

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2987
    • Просмотр профиля
Ubuntu 16.04 LTS, для меня это прежде всего память о канувшей Unity.

Кстати сказать, мне это DE нравилось, пользовался с удовольствием...

Ну а относительно поддержки, то, как я понял, она касается исключительно закрытия свежевыявленных уязвимостей ядра и наиболее важных системных пакетов, т.е. обновления для установленных приложений и прочих пакетов приходить не будут, их актуальность остается на уровне той что была на момент завершения стандартной (пятилетней для LTS) поддержки...
Думается за год другой устареет окончательно, те же браузеры из родных реп не всякую веб страницу смогут открывать, а заменить их более современными будет ох как непросто, из-за пресловутых неудовлетворяемых зависимостей ::)

В общем не вижу я особого смысла в таком продлении поддержки для десктопных версий дистра, а вот для серверной - может быть, может быть  ::)
... ну или я что-то недопонял и поддержка на самом деле будет полноценная
« Последнее редактирование: 29 Декабря 2021, 09:12:03 от F12 »

Оффлайн qpdb

  • Активист
  • *
  • Сообщений: 355
  • xUbuntu 20.04
    • Просмотр профиля
Приветствую всех!

Ubuntu 16.04 LTS, для меня это прежде всего память о канувшей Unity.
Кстати сказать, мне это DE нравилось, пользовался с удовольствием...

Я тоже пользовался, просто до этого я другого Linux не видел😇… Я тогда ещё работал и это был государственный проект, кому там пришла в верхах в голову идея эксперимента, мы не поняли, но прислали программистов и всем установили Ubuntu c Unity. Ну а мы потом этих программистов донимали разными вопросами.

С Unity произошло как и всё на рынке происходит, если ты с рынка ушёл или тебя выдавили, назад вернуться очень тяжело😞… Меня, например, уже любые попытки реанимации Unity (а они есть) не интересуют. И я не один такой😕…

2021 Dec 28; 08:15 PM

Призываю не горячиться и быть взаимно вежливыми!

Оффлайн Onlininer

  • Автор темы
  • Активист
  • *
  • Сообщений: 339
    • Просмотр профиля
заменить их более современными будет ох как непросто
Не по теме: вчера просто скачал новый Firefox_95.0.2 распаковал архив в папку на рабочем столе, и..всё работает (этот пост с него пишу)

Я понимаю, что, наверное, сделал "по-лоховски"...
Google Chrome и браузер Microsoft обновляются в штатном порядке..пока...
UPD:
Откопал: Official PPA for Firefox Beta Official PPA for Firefox Beta
sudo add-apt-repository ppa:mozillateam/firefox-next
sudo apt-get update
И, на 16.04 :
« Последнее редактирование: 29 Декабря 2021, 19:07:57 от Onlininer »

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2987
    • Просмотр профиля
понимаю, что, наверное, сделал "по-лоховски"...
- абсолютно нет!
Firefox распространяется не только в виде установочных пакетов, но и в архивах с портативной (portable) версией программы, и это нормально...

Но я писал о другом, дело в том, что для нормального запуска и работы, даже портативной версии программы, нужно чтоб в системе были установлены определенные пакеты(библиотеки), причем именно конкретных версий, а это условие не всегда может быть соблюдено, особенно если речь идет об устаревших дистрибутивах (можешь сам проверить, например загрузившись в живую какую нибудь 14.10 или 15.04, и попробовать запустить там новый Firefox, предварительно распаковав свой архив его содержащий).

Google Chrome и браузер Microsoft обновляются в штатном порядке..пока...
- это скорее всего потому, что в ходе установки они внедрили в твою систему свои репозитории, и теперь эти репы (по сути сторонние) используются на ряду со штатными при получении системой обновлений... и до тех пор пока разработчики Google Chrome и браузера Microsoft будут собирать пакеты в том числе и для Xenial, этот софт будет обновляться в твоей системе в штатном порядке ::)

Оффлайн Onlininer

  • Автор темы
  • Активист
  • *
  • Сообщений: 339
    • Просмотр профиля
они внедрили в твою систему свои репозитории
:) Я их сам "внедрил", конечно... :)

Оффлайн AlexDem

  • Активист
  • *
  • Сообщений: 533
    • Просмотр профиля
Поддерживается ли по-прежнему Ubuntu 16.04 LTS?
А Server?
PS: разобрался, надо было sudo apt install ubuntu-advantage-tools
« Последнее редактирование: 29 Декабря 2021, 20:06:30 от AlexDem »

 

Страница сгенерирована за 0.042 секунд. Запросов: 25.