Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Следующие пакеты имеют неудовлетворённые зависимости  (Прочитано 1825 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dj_kuric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Доброго времени суток. Ubuntu 22.10 после обновления вылетели неудовлетворённые зависимости. apt --fix-broken install не помогло.
sudo apt upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 librygel-renderer-2.6-2 : Зависит: libgupnp-av-1.0-3 (>= 0.12.8) но он не установлен
 librygel-server-2.6-2 : Зависит: libgupnp-av-1.0-3 (>= 0.12.8) но он не установлен
 rygel : Зависит: libgupnp-av-1.0-3 (>= 0.12.8) но он не установлен
         Зависит: libgupnp-dlna-2.0-4 (>= 0.9.4-2) но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6198
    • Просмотр профиля
dj_kuric, нужно уточнить версию дистрибутива, 22.10 выйдет только в октябре.
Нужен полный вывод
apt --fix-broken install
и список подключенных репозиториев.

Percoir

  • Гость
А разве есть уже 22.10 даже тестовая?
Я думаю, ТС имел в виду 21.10.
Мне обычно помогало
sudo apt -f installНо я только на LTS

Оффлайн dj_kuric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
У меня установлена тестовая 22.04 До этого проблем не было.
sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libgupnp-av-1.0-2 libgupnp-dlna-2.0-3
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libgupnp-av-1.0-3 libgupnp-dlna-2.0-4
Следующие НОВЫЕ пакеты будут установлены:
  libgupnp-av-1.0-3 libgupnp-dlna-2.0-4
Обновлено 0 пакетов, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Установлено или удалено не до конца 3 пакетов.
Необходимо скачать 0 B/138 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 674 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 171212 файлов и каталогов.)
Подготовка к распаковке …/libgupnp-av-1.0-3_0.14.0-1_amd64.deb …
Распаковывается libgupnp-av-1.0-3 (0.14.0-1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libgupnp-av-1.0-3_0.14
.0-1_amd64.deb (--unpack):
 попытка перезаписать «/usr/share/gupnp-av/av.xsd», который уже имеется в пакете
 libgupnp-av-1.0-2 0.12.11-3
Подготовка к распаковке …/libgupnp-dlna-2.0-4_0.12.0-1_amd64.deb …
Распаковывается libgupnp-dlna-2.0-4 (0.12.0-1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libgupnp-dlna-2.0-4_0.
12.0-1_amd64.deb (--unpack):
 попытка перезаписать «/usr/lib/x86_64-linux-gnu/gupnp-dlna/libgstreamer.so», ко
торый уже имеется в пакете libgupnp-dlna-2.0-3 0.10.5-4build1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libgupnp-av-1.0-3_0.14.0-1_amd64.deb
 /var/cache/apt/archives/libgupnp-dlna-2.0-4_0.12.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


sudo apt -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libgupnp-av-1.0-2 libgupnp-dlna-2.0-3
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libgupnp-av-1.0-3 libgupnp-dlna-2.0-4
Следующие НОВЫЕ пакеты будут установлены:
  libgupnp-av-1.0-3 libgupnp-dlna-2.0-4
Обновлено 0 пакетов, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Установлено или удалено не до конца 3 пакетов.
Необходимо скачать 0 B/138 kB архивов.
После данной операции объём занятого дискового пространства возрастёт на 674 kB.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 171212 файлов и каталогов.)
Подготовка к распаковке …/libgupnp-av-1.0-3_0.14.0-1_amd64.deb …
Распаковывается libgupnp-av-1.0-3 (0.14.0-1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libgupnp-av-1.0-3_0.14
.0-1_amd64.deb (--unpack):
 попытка перезаписать «/usr/share/gupnp-av/av.xsd», который уже имеется в пакете
 libgupnp-av-1.0-2 0.12.11-3
Подготовка к распаковке …/libgupnp-dlna-2.0-4_0.12.0-1_amd64.deb …
Распаковывается libgupnp-dlna-2.0-4 (0.12.0-1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libgupnp-dlna-2.0-4_0.
12.0-1_amd64.deb (--unpack):
 попытка перезаписать «/usr/lib/x86_64-linux-gnu/gupnp-dlna/libgstreamer.so», ко
торый уже имеется в пакете libgupnp-dlna-2.0-3 0.10.5-4build1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libgupnp-av-1.0-3_0.14.0-1_amd64.deb
 /var/cache/apt/archives/libgupnp-dlna-2.0-4_0.12.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt autoremove не работает
« Последнее редактирование: 01 Февраля 2022, 12:11:13 от dj_kuric »

Оффлайн БТР

  • Заслуженный пользователь
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6198
    • Просмотр профиля
У меня установлена тестовая 22.04 До этого проблем не было.
С какой целью вы её установили? Она не подходит в качестве рабочей системы. Используйте стабильные LTS-релизы.

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5605
  • Все по палатам!
    • Просмотр профиля
dj_kuric, жди, когда разработчики исправят... чтобы ускорить, отправь им отчет об ошибке
Извините, я все еще учусь

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3819
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 22.04, 24.04
    • Просмотр профиля
Ubuntu 22.10 после обновления вылетели неудовлетворённые зависимости.
dj_kuric, 22.04 только лишь тестируется, а у тебя уже 22.10. Оригинально отличился на форуме.
Я странен, а не странен кто ж? (С)

Оффлайн jurganov

  • Старожил
  • *
  • Сообщений: 1503
    • Просмотр профиля
цирк уехал, а клоуны остались


Цитировать
Правила форума
2. На форуме ЗАПРЕЩЕНО
2.2. Оскорблять кого-либо или принижать его личные качества. Будьте вежливы и культурны!

+10%
--БТР


Пользователь добавил сообщение 02 Февраля 2022, 05:18:39:
а чё не так? поставил чуть ли не альфа-версию, а требует, что бы всё корректно работало.
Вот и пусть как тестировщик пишет рапорты в Каноникал
« Последнее редактирование: 02 Февраля 2022, 05:18:39 от jurganov »

 

Страница сгенерирована за 0.044 секунд. Запросов: 25.